Rapid Storage Technology
Intel® RST, RAID
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2030 Discussions

ich9r and latest intel AHCI work up to 2TB on GPT drive


Just so everyone will know my current status, and avoid wasting time....

I have 4 - 3TB Hitachi drives, and 1 64GB SSD for boot.

I have a SuperMicro MB with an ICH9R chipset, Raid built into ROM, and I have installed the iostor.sys drivers.

It is current running in AHCI mode,


Originally, I installed Server 2008R2 64bit without the F6 drivers. Bios was set to IDE, (instead of AHCI, or RAID)

When I bought the first two 3TB hitachi drives, they formated using GPT perfectly. I then copied 2.7TB of data to 1 of the new drives.

Everything worked.

I wanted to enable RAID, or at least AHCI, so I re-installed server 2008R2 64 bit and created the driver disk (F6 method) to install Intel Rapid Storage drivers. The install went fine, but I have several problems. One is severe.

1 I can no longer change the bios back to IDE, and I can not change it to RAID. If I do either, the computer reboots 1/2 way through boot up process.

2. My pre-filled 2.6TB GPT disk started acting... strange. Server would hang sometimes. Other times it would work normally.

3. After much diagnosing, It seems that my 2.7TB GPT disk works perfectly up to 2.0 TB, then just "hangs". I can copy data to it at 100MB per second for hours, right up to 2TB, then the copy just stops.

4. I have deleted the hard drive, and re-installed it numerous times. Hot swapping works. after I "clean all" or "Clean" in diskpart, It is formated and partition created as 2.7TB using GPTID. Explorer shows it is 2.7TB. I can copy data to it from other drives, but as soon as the copy gets to exactly 2TB, activity ceases, and no more data can be transmitted to the drive. I have used windows diskmanager to create, and partition it and I have used the Hitachi GPT provisioning software.

The only time I got to use the entire drive was before I loaded Intel Rapid Storage drivers.

When I change the bios back to IDE, Server 2008 won't boot. It goes into a boot loop.

When I change the bios to Raid, is also won't boot. Also with a boot loop.

When I change the bios back to AHCI, it has to be repaired, but then starts working normally (except for the 2.0TB limit on my 3TB drives)

I am looking for 2 things.

1. has anyone seen a problem like this? If so, where can I got to find out about it.

2. I can't re-install since it is my Domain Controller.

Does anyone have any suggestions, or ideas? I am not so sure where to go except to create a new domain controller, then reinstall it.



0 Kudos
5 Replies

Hi there

I understand that there is a hard drive size limitation of 2TB when running on RAID mode. However, this should not interfere when you are under AHCI.

By changing SATA modes, you will need to reinstall the operating system because the motherboard BIOS will detect different SATA mode and thinks there is a hardware change.

When you are installing f6 driver, make sure to select appropriate driver:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=20216&ProductFamily=Chipsets&ProductLine=Chipset+Software&ProductProduct=Intel%C2%AE+Rapid+Storage+Technology&lang=eng http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=20216&ProductFamily=Chipsets&ProductLine=Chipset+Software&ProductProduct=Intel%C2%AE+Rapid+Storage+Technology&lang=eng

"Intel(R) ICH9R/DO/DH SATA AHCI Controller"


"Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller"




I see. I could not get it to boot up in RAID mode ever. The boot drive is 64GB SSD and shouldn't be an issue, but even after installing the intel drivers (10.6.....) it won't boot up in RAID mode. It did boot up and run in AHCI mode so you are correct.

the problem is that even though it boots up and runs, and the Hitachi configuration program and diskmanager in windows format the 3TB drives with GPT, the space after 2TB is not available. I know it is there because before I installed the drivers (in IDE mode) I filled the drive up. It heald 2.7 TB of data and I had no problem accessing it. After I installed the drivers (from the CD that came with the MB), I have been unable to access the drives if they hold over 2TB of data. I have tried all the different drivers I could find, Each time It takes me 1.5-3 days to fill the drive up, then see what happens when it hits 2.0TB Each time it freezes and I have to look again, try another driver, then wait another 1-3 days to fill it up again. I have done this for almost 3 weeks now.

It seems like I have to build another machine, promote it to DC, then rebuild this machine without the intel drivers.

I find it amazing that the old IDE drivers from IBM (circe 1980';s) can give me 3TB and the brand new ICH9R and the drivers provided by Intel can not. With billions in the bank, why can't they hire a few more programmers to ensure their drivers are able to provide at least the same functionality as the 30 year old IBM drivers.

If anyone has any ideas to allow me to access the 800GB of missing space, I would try their ideas happily. I am almost out of ideas myself at this point.

0 Kudos

None of this helps me to understand why my 3TB drive shows up as 3TB, but only actually works up to 2TB. I run in AHCI mode...and it allows me to format it.. but stops responding exatly at 2TB. Doesn't that seem weird?

0 Kudos

I can report this problem is "mostly" fixed.

The fix? REMOVE the iastor intel drivers and let the built in Microsoft AHCI ver 1.0 drivers take over. They work smoothly and when the data approached teh 2TB boundary that had locked up the drive using any of the intel drivers, the data kept flowing.

NOTE: the microsoft IDE drivers that install in IDE mode worked originally and now I have verified that the Microsoft AHCI drivers (ver 1.0) work correctly in AHCI mode. I am not interested in RAID mode since it is so unreliable.

I have only one comment to add to the above.

INTEL makes the chipset and I have had this MB for over 1 year, so the hardware is not new. Intel has plenty of money to hire programmers, and 3TB drives have been available for some time. I don't understand how Microsoft can make drivers that work flawlessly, and Intel can not.

0 Kudos

The answer was to uninstall the INTEL drivers and use the built in Microsoft AHCI 1.0 drivers. They work perfectly.

0 Kudos