Rapid Storage Technology
Intel® RST, RAID
1979 Discussions

RST shows "Incompatible Version" on RAID 5 array on Z68 chipset


here are some details:

  • Windows 7 Ultimate SP1 x64


  • Z68 chipset based motherboard


  • i5 2500 cpu


  • 6 drives


    • 2x1GB Seagate ES.2 drives in RAID 0 as the system drive.


    • 4x2GB Western Digital RE4 drives in a RAID 5 GPT array, about 5.4GB of usable storage.


  • nVidia GS450 graphics card.


  • The motherboard has the latest BIOS.


  • The latest version the RST driver is used.


this system has been running for several months without any issues.

over the last month over 3TB of data has been copied over the local network onto the RAID 5 drive with no issues.

a couple of days ago, the system gave a BSOD due to an issue with the ACPI driver. the system gave several BSODs before the issue was resolved.

after booting from the last BSOD the RAID5 drive dissappered and the RST application gives an "Incompatible Version" status.

all four of the array drives are listed individually with a yellow triangle with an exlamation mark and the only option is to "Clear and reset disk" each disk individually.

so the question here is what is the result of using the "Clear and reset disk" option?

how can this array be recovered?

how can this be avoided in the future?

any suggestions and/or recommendations are appreciated!

0 Kudos
2 Replies

Hi there!

If you are getting "Incompatible version" it seems that your hard drives are not being detected by the RAID BIOS. In other words, hard drive firmware has to be updated.

"Clear and Reset disk" means your RAID structure and data will no longer be available.

If you reset disk to Non-RAID, you may want to try using data recovery software to get data back.

You cannot void this in the future as this is very hard to prevent.



0 Kudos

thanks for the response!

here are some additional details:

  • the four hard drives that make up this RAID 5 array all have the same version of and the latest that is available from Western Digital.


  • these drives have been used in other installations without a problem.


  • this array worked for quite some time without issues. if the firmware was the problem, i would think that it would have been seen from the start.


  • there is also a RAID 0 array on this controller which holds the system volume. this a 2TB MBR. the R5 is a GPT volume. why is the R0 array not affected?


any ideas why this occured on the R5 array?

the standard reasons of software versions not being compatible can not be the only cause! like I stated in the post that started this thread, this array worked hard for a couple of months without issues!

the thing that precipitated this situation was the ACPI driver and the system giving the BSODs because of this driver.

aside from recovering the data on the array, how can this be prevented in the future?

how can a system that has ACPI issues all of a sudden show the R5 array as "Incompatible? and why does that not affect the R0 array that is on the same controller and which holds the system volume?

how come this array is not affected?

0 Kudos