Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4616 Discussions

E-mail notifications in RAID Web Console 2


Hello, few months ago I bought the Intel SRCSATAWB RAID controller which has been working fine so far (except one of the breakout cables which was damaged upon arrival). I have set up everything to my liking except one thing:

I seem to be unable to properly set up e-mail notifications.

The thing is, whatever I type into the configuration window, when I try to send myself a test e-mail, I get an error message stating:


The test email could not be sent.

Check the mail server settings and try again.

I searched a bit on the Internet, but I found only these topics and none of these helped me:

- /message/124593


Also, I did a bit of testing. I have two SMTP server at my disposal, none of them use any kind of encryption and both listen on a standard port 25:

- The first one does not use any authentication (my computer is authentified by being in the same network)

- The second one does use a standard method of authentication (username and password)

No matter how I configure these, I am just unable to send a test e-mail.

By looking at the Wireshark logs, I noticed the following: RAID Web Console 2 seems to be improperly communicating with the SMTP server and thus I won't get authenticated with the second SMTP server which then, of course, denies any communication (relaying not allowed). Please see the attached image for more information.

Am I doing something wrong or is there actually a bug in the Web Console? I am willing to do various tests and logs if necessary.

I am using the newest Web Console 2 available:

Version 9.00.0000

Client Build: 2.90-00

0 Kudos
7 Replies

You're definitely on the right track - you cannot use "no authentication" with RAID Web Console 2. You must use a valid account that exists on the mail server. There is something else that needs to be enabled for that user account to - I'm looking through my old notes, to see if I can remember what check box has to be set.

I'm assuming the screenshot was taken from the second SMTP server?

0 Kudos

Yes, that is correct, the Wireshark log is from the second server that uses standard form of authentication (username, password) and no encryption. I guess, this is as simple as it gets for a "standard" SMTP server - at least this one should be accepted in Web Console 2 without any problems.

I would try something, but I don't know what and I don't have any other SMTP servers for testing purposes. But right now I remembered I have an Android phone. That means I have a Google account and that leads to automatic Gmail account and another SMTP server. I am going to try this one and will let you know how it went.

0 Kudos

Okay, the Google SMTP didn't work, because Google accepts only encrypted connection and Web Console 2 obviously doesn't support this. But I found a usable workaround.

I downloaded the miniRelay Server ( and used it as a localhost relaying SMTP server. It is a freeware portable small application, that can be set up to run at startup and put the icon in the system tray. I then set the Web Console 2 to use SMTP server at and unchecked the "This server uses authentication" checkbox.

This is how it looks in the miniRelay log:

[2011/08/04, 21:55:44] Command: MAIL FROM <</span>>


[2011/08/04, 21:55:44] Command: RCPT TO <</span>>


[2011/08/04, 21:55:44] [1] Looking for MX domain of


[2011/08/04, 21:55:44] [1] Connected with


[2011/08/04, 21:55:44] [1] Sending message


[2011/08/04, 21:55:44] [1] Message successfully sent

Completely easy configuration, in my case just run the EXE file and that's it. While not a solution, at least I can use e-mail notifications while I wait for the fix from Intel or LSI, if there will be any. This might at least help other users that have the same problem.

0 Kudos

On Windoes 7 this doesn't work exactly as described by @zoom. On Windows 7 I found that pointing RWC2 at IP address did not work (even with the firewall turned off). So I typed the network host name of my PC (which resolved to an address on my network) in the address field and that worked. localhost also did not work.


The logging is a bit limited in miniRelay Server, it has no installer, and I wasn't up to figuring out how to make it run at startup. So I went with Courier Mail Server which plugs into the Windows Services framework, has better logging, and has a few more useful configuration options. (It has no uninstaller, though, so you have

to manually delete it to get rid of it).

As has been stated previously, RWC2 attempts to authenticate with a username and password even if you have that feature turned off so don't bother trying to use it without authentication.

RWC2 could clearly use an update to set the smtp port and allow TLS connections. No modern SMTP

server is configured on port 22 without encryption. Installing your own SMTP server to make the email feature

work is a ridiculous burden.

0 Kudos

I know I'm a bit late to this, but hopefully this helps someone else.

I got this working, the basic premise is that the LSI RWC software is jacked up.

I figured it out after playing with Wireshark and Procmon and finally got it fixed.


I wanted to send unauthenticated but wireshark showed the mail being sent with authentication and a blank username and password, despite the xml and gui indicating authentication-type none.

After altering the xml file then it wouldn't even attempt to send email, even after restoring a backup copy of the xml. *banging head on desk*


It seems the XML file for the email configuration is normally here: C:\Program Files (x86)\RAID Web Console 2\MegaMonitor\config-current.xml

In the same folder is config-default.xml copy that to config-current.xml then make sure to uncheck its read-only attribute. (otherwise the gui settings never save)

Then restart the RWC service, then login and put your settings in exactly as you know they work, click "Test" it sends successfully as long as your settings are correct. Click OK. Navigate back in and test it again. Now it works the funny thing is if you look at the XML the email settings look exactly the same as before when it wouldn't send at all. So sorry I have no idea why this worked but it worked for me, good luck.

0 Kudos

I have the same issue even in the latest version of Raid Web Console. Is Intel ever going to fix this?

0 Kudos