Community
cancel
Showing results for 
Search instead for 
Did you mean: 
bmauk
Novice
927 Views

RS2WC080 Raid5 - all drives listed as Foreign Unconfigured Bad. Did I lose all my data???

Jump to solution

After a power outage, the Web Console 2 lists all my drives as Foreign Unconfigured Bad.

I am using controller RS2WC080, with 5 WD 1TB drives in RAID 5 config on a single virtual drive.

Is this recoverable?? Did I lose all my data??????

Please help!

/b

0 Kudos
1 Solution
bmauk
Novice
59 Views

Figured it out! Wanted to post my answer in case it help someone else one day...

I may not be 100% accurate in my representation, but basically the configuration is written to both the controller and to the drives.

So here's what I did:

  • I flipped all the drives from "Foreign, Unconfigured Bad" to "Foreign, Unconfigured Good".
  • Scanned the Foreign configuration, verified that it was correct
  • Accepted the configuration
  • Ran consistency check

And that's all it took. Data is back, array is Optimal, and im breathing easy.

whew.

/b

View solution in original post

1 Reply
bmauk
Novice
60 Views

Figured it out! Wanted to post my answer in case it help someone else one day...

I may not be 100% accurate in my representation, but basically the configuration is written to both the controller and to the drives.

So here's what I did:

  • I flipped all the drives from "Foreign, Unconfigured Bad" to "Foreign, Unconfigured Good".
  • Scanned the Foreign configuration, verified that it was correct
  • Accepted the configuration
  • Ran consistency check

And that's all it took. Data is back, array is Optimal, and im breathing easy.

whew.

/b

View solution in original post

Reply