Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4663 Discussions

S5520HC does not recognize add-in cards



I'm facing a problem with my S5520HC Server Board as it does not recognize my Adaptec 6405 SAS/SATA RAID Controller. I'll mention straightaway that it's installed in Slot 3 as both the card as the slot are PCI-E x8 (Slot 1 is PCI and Slot 2 is PCI-E x4). I must add that the card isn't officially fully supported (as can be seen on the Hardware List, but I've seen that at least someone ( got it working. Not only does he/she have the same chip, but the exact same model of both the motherboard and the RAID controller.

What does it do: It boots without any error beeps. I do not see any events in the log section in the BIOS, so that should be good. The card has power because it heats up and I can see several lights showing up (it starts with blinking, then switches to a few lights, then back to blinking and lastly the all famous Knight Rider mode).

What does it not do: Show up in the BIOS as bootable and it also doesn't show any configuration screens (like "Press CTRL+A to configure").

What did I already try to resolve the problem (none of these options solved it):

- Updated the BIOS to the latest available to date (04/25/2012) which is version 61;59;30;112. It is updated from version 50;53;28;112.

- A BIOS reset through the BIOS

- A BIOS reset by switching the jumper cap to pins 2-3 and then back to 1-2

- I've tested the card in every PCI-E slot (that means the x4, x8's and x16)

- I've read that the PCI-E slots are shared and that it runs through the ICH10 controller. So I've disabled the COM ports, on-board NICs and the on-board SATA controller

- I've tried it with the SATA controller enabled and set to "SW RAID"

- Updated the firmware of the RAID controller to the latest available since December, which is version 18668. It still had the first available firmware (18301). This had to be done by installing it in my desktop system (read below)

What I also tried:

- I've inserted the card in a desktop system. The card works instantaneously and shows me a configuration screen right after the POST. It did have an old firmware version pre-installed, but as mentioned it has been updated

- I've inserted an old PCI VGA graphics card into the server board and even though I enabled the "Dual Monitor Support" option in the BIOS, it is not showing anything on the monitor if I connect the VGA cable to the add-in card. In fact the monitor shows that the cable is disconnected. The graphics card is confirmed to be working (it has been working for the last 16 years)

Does anyone know what I can do at this point? I'm really at a loss here.

Thanks in advance,

0 Kudos
2 Replies

It sounds like you've tried everything I would try.

That's one of the frustrations of using untested hardware - it's not consistent. It may work completely fine in one system, and totally fail in another, and for no discernable reason.

0 Kudos

Thanks for the reply, Dan_O. I have figured it out myself, though. So I will provide everyone with the solution.

What I needed to do was disable "Silent Boot" in the BIOS as it hides the RAID Controller's configuration screen. I would think it's pretty important to show, but Intel must've thought otherwise. After it's disabled and rebooted it then showed up the configuration screen, but it will show "BIOS Not Installed". I found the message a bit confusing as the card had firmware installed. Turns out it's not about the card, but the computer BIOS. This is confirmed as it cannot be found as a bootable device in the BIOS. For that to happen you need to have at least one active array and then it will switch to "BIOS Installed". Be wary that it takes a huge amount of time to build and verify a raid set. For me it took at least 10 hours to build a 5.5TB RAID5EE set.

After this I benchmarked the drive in a portable Windows 7 with HDTune (as drivers aren't available and do not work for XP). I really wanted to do this because in one of the links in my original post it said that write performance was terrible. I'm here to show you that it has been fixed as HDTune showed me the following Write values (averaged) after several runs:

  • Top (w/ 8MiB block): 335MiB/s
  • Top (w/ stripe size block): 325MiB/s
  • Lowest (w/ default size block – 64KiB): 225MiB/s
  • Scatter: 165MiB/s

It certainly looks good, but I think it's not optimal yet. I say that because in Win7PE it shows only nearly 40% of the actual size of the array. So the top speed would probably also be higher.

However, if you feel that you need to have VMware ESXi 5 installed on your Adaptec 6405, then prepare to create your own disk with integrated scsi-aacraid drivers (follow this guide: as support is not included by default (against from what I've read elsewhere). The latest drivers I have found can be found here ( From there on you can always update the driver with the esxcli command once VMware is installed.


0 Kudos