Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
963 Views

Server Board S1400FP4 with C600 Upgrade Key RKSATA8

Hello all,

I have Server Board S1400FP4 with C600 Upgrade Key RKSATA8 pluged into special port. Where can I see, if the server board has found the key and if the key works correctly ?

Thank you.

Rgds

Tomas

13 Replies
Highlighted
Community Manager
26 Views

Hello Tomas,

 

 

In order to determine if C600 Upgrade Key RKSATA8 works correctly and has been successfully installed please consider the fact this depends on the Raid driver you are using, typically by pressing "Ctrl" + "E", "Ctrl" + I" or "Ctrl" + "G". (Intel® ESRT2 LSI*, Intel® RSTe, Intel® Integrated RAID Modules or RAID Adapters) For additional information, please refer to http://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb/g46033003_raid_qrg.p... Intel® RAID Quick Reference Guide

 

 

Note: Some keys may not be suitable for some boards or systems. There is no benefit to enabling eight ports on a system with only four physical ports.

 

 

If you have any more questions, please let me know.

 

 

Best regards,

 

Caesar B.

 

Highlighted
Novice
26 Views

Hello,

well that's the point - I would suppose, that such an information should be seen in RaidDriver (RaidBios) screen. For me it's shortcut "Ctrl+I" and there I can see the screen as on following picture.

Since there are 5 disc diplayed, I assume all works fine. (Physically there are 5 HDD SATA 500GB disc connected to "On-Board SATA/SAS Capable Controller").

There is "Intel(R) RSTe" option set up for SATA/SAS Capable Controller in the BIOS:

... and for it no driver is needed according Motherboard Setup Guide ... http://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb-s1400fp/sb/g64246003... http://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb-s1400fp/sb/g64246003..., chapter 3.3.23.3.

The reason, why I do this investigation, lies in the operation system level. I use UNIX SLES 12 SP 2. All works fine, OS boots up from the raid device, etc. The problem had come when I connected the 5th disc and want to have it a spare disc. First of all, when I boot up the server, RaidDriver (RaidBios) didn't offer the 5th disc to add it to existing RAID volume. The state of RaidDriver (RaidBios) screen (as seen above) was achieved within operating system by command "mdadm --add ...". But after that, the 5th disc (spare) was not added to existing isms device, but new one was created. See the state of /proc/mdstat :

server-a:~ # cat /proc/mdstat

Personalities : [raid6] [raid5] [raid4]

md125 : inactive sdf[0](S)

1105 blocks super external:imsm

md126 : active raid5 sdc[3] sdd[2] sde[1] sdg[0]

1391878144 blocks super external:/md127/0 level 5, 64k chunk, algorithm 0 [4/4] [UUUU]

md127 : inactive sde[3](S) sdg[2](S) sdc[1](S) sdd[0](S)

12612 blocks super external:imsm

unused devices:

The device sdf[0] is the 5th spare disc.

I've found no information on the internet, how could be the 5th disc added to "md127" and afterwards add it as o new disc to real RAID device "md126".

Can you advice me or forward the post to another forum section, where to solve this issue ?

Thank you in advance.

Rgds

Tomas

0 Kudos
Highlighted
Community Manager
26 Views

In this case, you should create a RAID 0 Volume with the spare disk so that the OS sees it and you could use it.

 

 

Please try this option and let me know if it solves the issue.

 

 

Best regards,

 

Caesar B.
0 Kudos
Highlighted
Novice
26 Views

You mean to create another RAID volume (Level RAID0) with one disc only ?

Thank you.

Rgds

Tomas

0 Kudos
Highlighted
Community Manager
26 Views

Yes, that is correct. I is a good trick for it to be recognized only.

 

 

Please let me know if it works for you.

 

 

Best regards,

 

Caesar B.
0 Kudos
Highlighted
Community Manager
26 Views

Hi there!

 

What RAID volume do you have in the first 4 drives? I believe we have tested this scenario when adding a drive to a current RAID 0 configuration up to 4 drives.

 

 

The following link might give you an idea of the RAID migrations or expansion.

 

 

http://www.intel.com/content/www/us/en/support/technologies/000006406.html Matrix RAID Volumes for Single RAID Arrays

 

 

By the way, I am going to share your feedback about the fact that the RAID BIOS does not acknowledge whether the RAID Upgrade key is installed or not.

 

 

Best regards,

 

Dave A.
0 Kudos
Highlighted
Novice
26 Views

Hello Dave,

the raid volume was RAID5 from the beginning (see the screenshot) with intention to add more HDDs, when they come from HW supplier. And more importantly, RAID upgrade key RKSATA8 was presented by that time as well. Actually it had to be, because HDDs were connected to SATA ports 0,1,2,4. The port 3 was detached since the HDD was on reclamation.

Regarding the link to Matrix of RAID Volumes - I'm not sure if it applies for me as well, since my HDDs are connected to "On-Board SATA/SAS Capable Controller", which offers up to 8 HDDs with certain RAID upgrade key.

And thanks for feedback share, I think it would be great to have an acknowledgement somewhere, that RAID Upgrade key was recognized by the motherboard/chipset.

Best rgds,

Tomas

0 Kudos
Highlighted
Community Manager
26 Views

Hello Tomas@SPIC.,

Regarding your first question:

Regarding your first question:

 

 

I have Server Board S1400FP4 with C600 Upgrade Key RKSATA8 plugged into special port. Where can I see, if the server board has found the key and if the key works correctly?
  • The SATA/SAS connector labelled "SATA/SAS_4" to "SATA/SAS_7" is NOT functional by default and is only enabled with the addition of an Intel® RAID C600 Upgrade Key option supporting eight SAS/SATA ports.

If you want to use the SATA/SAS controller with above 4 disks, make sure to have Upgrade Key connected and the 5th disk connected from port 4-7 on the blue ports.

 

See: 3.3.23 Onboard Serial Attached SCSI (SAS)/Serial ATA (SATA) Support and Options

 

At page 34: http://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb-s1400fp/sb/g64246003... http://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb-s1400fp/sb/g64246003...

 

 

 

 

Regarding the second issue: The problem had come when I connected the 5th disc and want to have it a spare disc.

 

My understanding is that you are looking for information on how to put the fifth disk installed as a spare disk of the raid 5 volume created, in case one of the disks that confirm the raid volume fails, then the fifth disk will replace it automatically, am I correct?

Best regards,

Caesar B.

0 Kudos
Highlighted
Novice
26 Views

Hello Caesar,

regarding first hint - yes I know that and that is what I did right from the beginning.

And regarding your validation, what I want to achieve - yes, the situation was as I replied to Dave A.

- I installed RAID upgrade key RKSATA8

- I connected 4 HDDs to SAS/SATA ports 0,1,2,4

- I created RAID volume 5 and installed OS SLES 12 SP2 on it

- when 5th HDD returned from warranty replacement, I connected it to port 3

- RAID BIOS didn't offer me to add 5th HDD to existing RAID volume ... (maybe, because the volume had status "healthy") ... and I didn't try to create another RAID volume (e.g. RAID0)

- I boot up OS and within I added 5th HDD to /dev/md127

- after reboot, RAID BIOS looked like on screenshot above, but on the OS level, the 5th HDD appears to be attached to different device, namely /dev/md125 (see above the command prompt copy&paste)

That's my current situation. What I have in plan to do is to simulate HDD failure via MDADM on OS level. I'll keep you informed about the results.

Thank you.

Best regards

Tomas

0 Kudos
Highlighted
Community Manager
26 Views

Hello Tomas@SPIC.,

Please try your HDD failure simulation and let us know of the results. Additionally, If I am not mistaken it is possible that you need to recreate the Whole RAID 5 and include the 5th HDD but maintain it as a disk member of that RAID 5 so it works upon failure.

Regards,

 

Caesar B.

 

0 Kudos
Highlighted
Novice
26 Views

Hello there,

the simulation of HDD failure ended up in state, that RAID5 volume has only 3HDD now. The 5th disc (spare) was not added automatically to /dev/md126 and no resync process has been started. See the command line history:

server-a:~ # mdadm -f /dev/md126 /dev/sdg

mdadm: set /dev/sdg faulty in /dev/md126

server-a:~ # cat /proc/mdstat

Personalities : [raid6] [raid5] [raid4]

md125 : inactive sdf[0](S)

1105 blocks super external:imsm

md126 : active raid5 sdc[3] sdd[2] sde[1]

1391878144 blocks super external:/md127/0 level 5, 64k chunk, algorithm 0 [4/3] [UUU_]

md127 : inactive sde[3](S) sdg[2](S) sdc[1](S) sdd[0](S)

12612 blocks super external:imsm

unused devices:

You have mail in /var/mail/root

server-a:~ # tail -n 25 /var/log/messages

2017-04-10T12:11:14.271457+02:00 server-a kernel: [579195.232656] md/raid:md126: Disk failure on sdg, disabling device.

2017-04-10T12:11:14.271470+02:00 server-a kernel: [579195.232656] md/raid:md126: Operation continuing on 3 devices.

2017-04-10T12:11:14.291451+02:00 server-a kernel: [579195.251996] RAID conf printout:

2017-04-10T12:11:14.291463+02:00 server-a kernel: [579195.251999] --- level:5 rd:4 wd:3

2017-04-10T12:11:14.291465+02:00 server-a kernel: [579195.252000] disk 0, o:1, dev:sdc

2017-04-10T12:11:14.291473+02:00 server-a kernel: [579195.252000] disk 1, o:1, dev:sdd

2017-04-10T12:11:14.291475+02:00 server-a kernel: [579195.252001] disk 2, o:1, dev:sde

2017-04-10T12:11:14.291476+02:00 server-a kernel: [579195.252004] disk 3, o:0, dev:sdg

2017-04-10T12:11:14.307484+02:00 server-a kernel: [579195.267988] RAID conf printout:

2017-04-10T12:11:14.307490+02:00 server-a kernel: [579195.267990] --- level:5 rd:4 wd:3

2017-04-10T12:11:14.307491+02:00 server-a kernel: [579195.267991] disk 0, o:1, dev:sdc

2017-04-10T12:11:14.307492+02:00 server-a kernel: [579195.267992] disk 1, o:1, dev:sdd

2017-04-10T12:11:14.307493+02:00 server-a kernel: [579195.267992] disk 2, o:1, dev:sde

2017-04-10T12:11:14.323969+02:00 server-a udisksd[9506]: Unable to resolve /sys/devices/virtual/block/md126/md/dev-sdg/block symlink

2017-04-10T12:11:14.327482+02:00 server-a kernel: [579195.288041] md: unbind

2017-04-10T12:11:14.327761+02:00 server-a systemd[1]: Stopping LVM2 PV scan on device 259:1...

2017-04-10T12:11:14.342152+02:00 server-a systemd[1]: Stopped LVM2 PV scan on device 259:1.

2017-04-10T12:11:14.355443+02:00 server-a kernel: [579195.315998] md: export_rdev(sdg)

Now I'm going to repair the volume manually.

Rgds.

Tomas

P.S. The resync process started after following sequence of commands:

server-a:~ # mdadm --remove /dev/md127 /dev/sdg

mdadm: hot removed /dev/sdg from /dev/md127

server-a:~ # mdadm --remove /dev/md125 /dev/sdf

mdadm: hot removed /dev/sdf from /dev/md125

server-a:~ # mdadm --add /dev/md127 /dev/sdf

mdadm: added /dev/sdf

server-a:~ # cat /proc/mdstat

Personalities : [raid6] [raid5] [raid4]

md126 : active raid5 sdf[4] sdc[3] sdd[2] sde[1]</s...

0 Kudos
Highlighted
Community Manager
26 Views

Hello Tomas,

 

 

Let me check on this information and try to reproduce the issue on our end. I will let you know of the outcome.

 

 

Best regards,

 

Caesar B.
0 Kudos
Highlighted
Community Manager
26 Views

Hello Tomas@SPIC ,

In order to expedite the resolution of this issue, please http://www.intel.com/content/www/us/en/support/contact-support.html Contact Support.

Best regards,

 

Caesar B.
0 Kudos