Software Archive
Read-only legacy content
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
17065 Discussions

Code Coverage in Parallel Composer

qnphan
Beginner
177 Views
Recently noticed that this Code Coverage feature option in the Composer
I tried it out using a working build by turned on the Code coverage feature and rebuild the project afresh.
the build failed and got the following error msg:

1>C:\\Program Files (x86)\\MSBuild\\Microsoft.Cpp\\v4.0\\Platforms\\Win32\\PlatformToolsets\\Intel Parallel Composer 2011\\Microsoft.Cpp.Win32.Intel Parallel Composer 2011.targets(196,5): error MSB6001: Invalid command line switch for "icl.exe". Parameter "path" cannot have zero length.

any suggestion to resolve it?

Is there a Code Coverage report page that can be shared? A link would help!thanks.

0 Kudos
8 Replies
Brandon_H_Intel
Employee
177 Views
So this project builds ok with the Intel compiler without code coverage activated? What compiler version are you using (update 1, update 2?)
qnphan
Beginner
177 Views
One clarification, the project buildssuccessfully with MS Visual Studio.
I went back to build the project with Intel C++, with Code Coverage feature disabled, it has the same error message!
In summary, this message shows up when using Intel Composer (update 1) with or without Code Coverage option enable.
qnphan
Beginner
177 Views
One clarification, the project buildssuccessfully with MS Visual Studio.
I went back to build the project with Intel C++, with Code Coverage feature disabled, it has the same error message!
In summary, this message shows up when using Intel Composer (update 1) with or without Code Coverage option enable.
Lingfeng_C_Intel
Employee
177 Views

This is MS Build issue related to Intel C++ compiler platform toolsets property.

For MSBuild tool, please visit below URL for more details, http://msdn.microsoft.com/en-us/library/ms171452.aspx

You can reinstall your XE version again to see if this issue is still exist or not.

Thanks,
Wise

Lingfeng_C_Intel
Employee
177 Views

Please follow up below way to try it again:

For some reasons the paths to Intel C++ compiler headers and libraries are not registered automatically in C++ projects. I put $(ICInstallDir)\compiler\include\ and $(ICInstallDir)\compiler\lib\ia32\ as first items in "Include directories" and "Library directories" options in the Configuration properties -> VC++ Directories dialog.

I believe this is a bug in VS integration.

qnphan
Beginner
177 Views
I added those two paths to the directories, respectively but the issue still persisted with number of clean and rebuild.

fyi, i just reinstalled the latest Parallel Studio (PS 2011, composer wit update 3) few days ago. The issue isstill there. TIA
qnphan
Beginner
177 Views
I added those two paths to the directories, respectively but the issue still persisted with number of clean and rebuild.

fyi, i just reinstalled the latest Parallel Studio (PS 2011, composer wit update 3) few days ago. The issue isstill there. TIA
qnphan
Beginner
177 Views
Hi Intel staff,
Sounds like you are aware of such issue associated with the Intel composer.
Any update or suggestion to uphold the code coverage feature in Composer?
Reply