Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Brandt__Lars
New Contributor I
61 Views

Crosswalk does not work on all phones

Hi

I have never before been able to install a Crosswalk apk, but didn't really care since everything worked without it.
However, I now have a problem with Android 4.1.X devices and Leaflet map "pinch zoom", which will crash the app. No workaround suggested seemed to work so I thought I would try a Crosswalk (16 embedded) build as a last solution, and to my great surprise it installed on the Huawei Y300 (Android 4.1.1). It also installed on my HTC Desire S (Android 4.0.4).

So the questtion is: Why won't it install on my Huawei Honor 7 Lite (Android 6.0) and Samsung Galaxy S3 (Android 4.3)?

With these two newer phones it downloads but displays the message "Program not installed" when I click the downloaded file.
I should mention that we host our own apps, and that it's the ARM apk (I also tried x86).

 

Tags (2)
0 Kudos
2 Replies
PaulF_IntelCorp
Employee
61 Views

It should install on all of those phones (some newer versions of Crosswalk do require a minimum of Android 4.1, but I believe that starts with Crosswalk 20 or 21, so 16 should be fine on the phones you are testing against).

I have an S3 and have successfully installed CW apps onto that device. Likewise, I have a Nexus 7 running Android 6 and my CW apps will also install and run on that device.

My suspicion is an existing app on the device is preventing installation. That is, an app with the same App ID, especially if the version code is lower on the new builds compared to the old builds. Remove the app with the same App ID and try installing again, I'm pretty sure that's the problem.

Brandt__Lars
New Contributor I
61 Views

Thanks, mystery solved :-)

It never occurred to me that this could be an issue, since the same normal build installs over and over again. That explains why it worked on my older phones, which had been lying in a drawer for a while.

Reply