Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PaulF_IntelCorp
Employee
290 Views

Intel XDK Release 3088, March 23, 2016

Today we released version 3088 of the Intel XDK. This update only applies to the mainstream Intel XDK release and does not apply to the Intel XDK IoT Edition or Intel XDK Early Access.

In this release we added many new features that were previewed in the Intel XDK Early Access and have fixed multiple issues. The complete set of new features are detailed in the Intel XDK Release Notes.

Below is a summary of those new features:

  • We no longer support CLI 4.1.2 builds. Projects that use CLI 4.1.2 MUST be updated.
  • Added Cordova CLI 5.4.1 to the Intel XDK build system. See this FAQ for details.
  • A new Certificate Management feature allows you to create or import Android certificate keystore files and iOS P12 distribution certificate files.
  • The Build tab allows you to build your app for multiple targets with a single mouse click.
  • Android and Android-Crosswalk options have been combined into a single target platform in the Build Settings section of the Projects tab.
  • Crosswalk support in the Intel XDK is now based on the Crosswalk Webview plugin (AKA "Cordova 4" in Crosswalk docs).
  • A new Publish tab has been added to assist you with creating and publishing application assets and information to a variety of Android stores.
  • The Windows and Windows Phone build options have been expanded and significantly updated to include Windows 10 Universal Apps. Please use the CLI 5.4.1 build option for your Windows and Windows Phone builds.
  • The built-in Brackets editor has been updated to version 1.6 and several new Brackets extensions have been added.
  • Whitelist settings in the Build Settings section of the Projects tab have been updated.
  • App Preview has been updated (to version 2.8.0). Check the respective stores to be sure you have the latest version.
  • Updates to our project file format will require that all projects be "updated" before you can use them with this release.

This release also addresses the Google App Store warning regarding the use of older versions of Cordova-Android. You must migrate your app to our CLI 5.1.1 or CLI 5.4.1 build system to eliminate this warning and to be able to publish apps in the Google App Store after May 9, 2016. Our CLI 5.1.1 build system has been updated to address this issue (see this FAQ for specific details).

Important Note About Intel XDK Versions 2893 and Older

Beginning with our upcoming June 2016 release, versions of the Intel XDK released prior to March 2016 (2893 and older) will no longer be able to use the Build tab, the Test tab or App Preview. This change is necessary to improve the security and performance of our Intel XDK cloud-based build system. If you are currently running version 2893 or older, of the Intel XDK, please upgrade to version 3088 or newer as soon as possible!

Version 2893 will continue to work (without the CLI 4.1.2 build option) until our June release, but it (and older versions) will no longer function following our June 2016 release. We encourage you to move to our 3088 release as soon as possible, in preparation for that significant change in our Intel XDK cloud services.

Our automatic updater will notify existing Intel XDK users when the update is available, directly within the Intel XDK. The updates will be released to all users within 24 hours. If you would like the update sooner, you can download and install it directly from xdk.intel.com.

Please report any issues in the forum.

-- The Intel XDK Team

Tags (2)
0 Kudos
30 Replies
Hamilton_Tenório_da_
Valued Contributor I
203 Views

Great job guys! I just downloaded this new version and I am exploring the new things.

I realized that intelxdk.js and xhr.js must be removed in order to debug and build. Is it corret? They are useless now?

Steve_N_1
Beginner
203 Views

I seem to be unable to build my project since updating to this version.

Error: Unable to upload project files

Despite having an internet connection. (Developing on OSX (Latest)).

Geoff_at_CFM
Beginner
203 Views

Wow, the Intel XDK moves fast!

Congrats on the update!

Steve_N_1
Beginner
203 Views

Scrap that, i re-started the application and it worked first time.

Should have taken that saying onboard "have you turned it off and on again?".

Geoff_at_CFM
Beginner
203 Views

I seem to be getting a LOT of crashes of the XDK when switching to the Emulator, and clicking the debug button, seems to happen even with simple new apps, with just a button on the home page. Perhaps more common in new apps?? I've been creating a few test apps today.

TIOT_O_
Beginner
203 Views

Updated to version 3088.
Previously the build generate an APK less than 1MB.
Now is generating a .zip package with 2 apks (+/- 23 mb each), totaling more than 45MB.
It is normal the increase in file size apk generated in the new build?

Gabriel_G_
Beginner
203 Views

Updated to version 3088.

I can't use debug tab with my device, could not generate module ?!

try even to build but there is an problem with phonegap-facebook-plugin/ ?!

Can someone help me please ?! THX in advance...

This what i get as error :

:phonegap-facebook-plugin:FacebookLib:bundleRelease
:prepareComAndroidSupportSupportV42400Alpha1Library
:prepareOrgXwalkXwalk_core_library164542119Library
:prepareDebugDependencies
:compileDebugAidl
:compileDebugRenderscript
:generateDebugBuildConfig
:generateDebugAssets UP-TO-DATE
:mergeDebugAssets
:createXwalkCommandLineFileDebug
:generateDebugResValues
:generateDebugResources
:mergeDebugResources.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/res/drawable-xhdpi/icon.png: libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/res/drawable-ldpi/icon.png: libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/res/drawable-xxhdpi/icon.png: libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/res/drawable-hdpi/icon.png: libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/res/drawable-mdpi/icon.png: libpng warning: iCCP: Not recognizing known sRGB profile that has been edited

:processDebugManifest
:processDebugResources
:generateDebugSources
:compileDebugJavaNote: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/src/nl/xservices/plugins/SocialSharing.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/src/com/adobe/phonegap/push/GCMIntentService.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

:preDexDebug
:dexDebug
UNEXPECTED TOP-LEVEL EXCEPTION:
com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;
    at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:596)
    at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:554)
    at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:535)
    at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:171)
    at com.android.dx.merge.DexMerger.merge(DexMerger.java:189)
    at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:454)
    at com.android.dx.command.dexer.Main.runMonoDex(Main.java:303)
    at com.android.dx.command.dexer.Main.run(Main.java:246)
    at com.android.dx.command.dexer.Main.main(Main.java:215)
    at com.android.dx.command.Main.main(Main.java:106)

 FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':dexDebug'.
> com.android.ide.common.internal.LoggedErrorException: Failed to run command:
      .../android-sdk/build-tools/21.1.2/dx --dex --no-optimize --output .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/build/intermediates/dex/debug --input-list=.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/build/intermediates/tmp/dex/debug/inputList.txt
  Error Code:
      2
  Output:
      
      UNEXPECTED TOP-LEVEL EXCEPTION:
      com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;
          at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:596)
          at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:554)
          at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:535)
          at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:171)
          at com.android.dx.merge.DexMerger.merge(DexMerger.java:189)
          at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:454)
          at com.android.dx.command.dexer.Main.runMonoDex(Main.java:303)
          at com.android.dx.command.dexer.Main.run(Main.java:246)
          at com.android.dx.command.dexer.Main.main(Main.java:215)
          at com.android.dx.command.Main.main(Main.java:106)
      


* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 1 mins 21.126 secs

.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/cordova/node_modules/q/q.js:126
                    throw e;
                    ^
Error code 1 for command: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/gradlew with args: cdvBuildDebug,-b,.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/build.gradle,--no-daemon
Command finished with error code 1: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/cordova/build --debug,--buildConfig=.../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/build.json
ERROR building one of the platforms: Error: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/cordova/build: Command failed with exit code 1
You may not have the required environment or OS to build this project
Error: .../builds/build.2016-03-24.07-05-16.R8radX.tmp/AppAnalyzer/platforms/android/cordova/build: Command failed with exit code 1
    at ChildProcess.whenDone (.../cordova/cordova-cli/5.1.1/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:134:23)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at maybeClose (internal/child_process.js:821:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

 

Gabriel_G_
Beginner
203 Views

just updated to 3088  and debug tab :
Request expired. Try again.
thx in advance
 

HBtec_EM
Beginner
203 Views

Previously the build generate an APK less than 1,4MB.
Now is generating a .zip package with 2 apks (+/- 23 mb each), totaling more than 45MB.
It is normal the increase in file size apk generated in the new build?
I have to know if my client uses ARMv7 processor or x86?

------------------------------------------------------

Antes eu gerava uma build com tamanho de 1,4MB.
Agora está gerando um pacote .zip com 2 apks (+/-23mb cada), totalizando mais de 45MB.
Isso é normal o aumento no tamanho do arquivo apk gerado com essa nova build?

Vou ter que saber se o meu cliente usa processador armv7 ou x86?

 

Hamilton_Tenório_da_
Valued Contributor I
203 Views

@HBtec> Imagino que antes você usava a compilação Android simples e agora você escolheu o Android Crosswalk, certo?

Se for isso, o arquivo fica bem maior mesmo. Nele está seu programa e todo o webview padrão para o Android. As 2 versões (ARM e x86) você carrega no Google Play e o próprio processo de instalação escolhe qual o melhor para o aparelho, sem você se preocupar. No painel do Google Play mude para o painel Avançado para você conseguir carregar as 2 versões.

PaulF_IntelCorp
Employee
203 Views

Geoff at CFM wrote:

I seem to be getting a LOT of crashes of the XDK when switching to the Emulator, and clicking the debug button, seems to happen even with simple new apps, with just a button on the home page. Perhaps more common in new apps?? I've been creating a few test apps today.

Geoff -- if this problem persists you may want to turn off the Emulate tab's auto reload function, that might help. See the image below for details:

Screen Shot 2016-03-24 at 8.51.06 AM.png

 

Kevin_L_3
Beginner
203 Views

Hi - a few questions and comments:

Some real concerns about what you've done to the certificate management with iOS. As most people know getting the certs and provisioning profiles right is real pain and that's an understatement. So why am I being prompted for a developer certificate or a new P12 file? I've rolled back to using the previous version as I'm in the middle of releasing my apps and I don't need any screw ups. So please explain what you have done to this and why? And why must I unlock the certificate when previously I didn't have to worry about this? This just seems an unneccessary step.

Please explain the purpose of your publish page. I like to control how I am doing the publishing directly myself - what value are you adding here? Can I still download the builds and do things the way I want to do them?

Where can I get the updated instructions on using this release too?

Thank you

PaulF_IntelCorp
Employee
203 Views

TIOT O. wrote:

Updated to version 3088.
Previously the build generate an APK less than 1MB.
Now is generating a .zip package with 2 apks (+/- 23 mb each), totaling more than 45MB.
It is normal the increase in file size apk generated in the new build?

Tiot -- See the release notes. Specifically, the section titled Android and Crosswalk* Builds Refactored.

Android and Crosswalk* Builds Refactored

The Android and Android-Crosswalk options have been combined into a single target platform in both the Build Settings section of the Projects tab and on the Build tab. In the Android Build Settings section there is a new check-box labeled Optimize your Android build with Crosswalk. When selected, your Android builds will be built with the Crosswalk WebView (which is the recommended configuration for all Android builds). If you de-select that check-box your Android APK will be built to use the "native" Android WebView, which varies with the version of Android and the device onto which your app is installed. Read Improving Android 4.x Performance with Crosswalk to learn the difference between a native Android WebView and the Crosswalk WebView for Android.

Depending on which column you selected in the table presented when you upgraded your project, your Android tab either has the "Optimize for Crosswalk" box checked or unchecked. Checked means you will build with Crosswalk, unchecked means you will build for the Android native webview. We highly recommend using Crosswalk, for the reasons outlined in the following articles:

See the images below for details regarding the project upgrade process and how to enable/disable Crosswalk as part of your Android build:

Screen Shot 2016-03-24 at 9.03.55 AM.png

 

Screen Shot 2016-03-24 at 9.03.12 AM.png

PaulF_IntelCorp
Employee
203 Views

Gabriel G. wrote:

Updated to version 3088.

I can't use debug tab with my device, could not generate module ?!

try even to build but there is an problem with phonegap-facebook-plugin/ ?!

Can someone help me please ?! THX in advance...

Gabriel -- please start a new thread for this issue and please ATTACH your detailed logs as a file, do not post them directly into the thread. It makes it harder to help when you do that. You can attach any file to your post by expanding the "File Attachments" link below the forum edit window and clicking the "Attach Media" button.

PaulF_IntelCorp
Employee
203 Views

HBtec EM wrote:

Previously the build generate an APK less than 1,4MB.
Now is generating a .zip package with 2 apks (+/- 23 mb each), totaling more than 45MB.
It is normal the increase in file size apk generated in the new build?
I have to know if my client uses ARMv7 processor or x86?

------------------------------------------------------

Antes eu gerava uma build com tamanho de 1,4MB.
Agora está gerando um pacote .zip com 2 apks (+/-23mb cada), totalizando mais de 45MB.
Isso é normal o aumento no tamanho do arquivo apk gerado com essa nova build?
Vou ter que saber se o meu cliente usa processador armv7 ou x86?

HBtec -- see this post > https://software.intel.com/en-us/forums/intel-xdk/topic/621866#comment-1865364

PaulF_IntelCorp
Employee
203 Views

Kevin L. wrote:

Hi - a few questions and comments:

Some real concerns about what you've done to the certificate management with iOS. As most people know getting the certs and provisioning profiles right is real pain and that's an understatement. So why am I being prompted for a developer certificate or a new P12 file? I've rolled back to using the previous version as I'm in the middle of releasing my apps and I don't need any screw ups. So please explain what you have done to this and why? And why must I unlock the certificate when previously I didn't have to worry about this? This just seems an unneccessary step.

Please explain the purpose of your publish page. I like to control how I am doing the publishing directly myself - what value are you adding here? Can I still download the builds and do things the way I want to do them?

Where can I get the updated instructions on using this release too?

Thank you

Kevin -- the certs you have been using with the previous version (2893) are still in the system. When you go to the Certs Management panel you will see an option to "convert" your "legacy" cert. This is the same cert you've been using, just repackaged into a new format that you can manage directly and not rely on the XDK to keep it safe for you. From there you can download it for safe keeping in case you need to use a different tool or transfer it to a new account, etc. The old format will stay in the system so you can use it with the 2893 version. See https://software.intel.com/en-us/xdk/docs/intel-xdk-certificate-management for more details about the certs.

We have made these changes to increase the security of your assets. The certs are particularly important because if someone else gets your certs they can be used to publish an update to your app without your permission. This is very important when apps include access to end-user personal account information. Choose the "48 hours" option to keep the cert unlocked while you have the XDK open.

The Publish tab, like all tabs in the XDK, is an optional feature. There is no requirement to use it, it is there to help people that need the help. The XDK is designed to allow you to use what you need and ignore what you do not need. The only "special" file in the XDK is the "project-name.xdk" file. Everything else is based on standard software components (such as the Cordova project, Ripple Emulator, Chrome CDT, etc.).

The docs have been updated, a few are still in the process of being updated, but they have not moved.

TIOT_O_
Beginner
203 Views

TIOT O. wrote:

Updated to version 3088.
Previously the build generate an APK less than 1MB.
Now is generating a .zip package with 2 apks (+/- 23 mb each), totaling more than 45MB.
It is normal the increase in file size apk generated in the new build?

Very Good! Resolved, generating less than 1MB

 

Geoff_at_CFM
Beginner
203 Views

Thanks Paul,

I did that and it is now running smoothly.

 

Paul F. (Intel) wrote:

Quote:

Geoff at CFM wrote:

 

I seem to be getting a LOT of crashes of the XDK when switching to the Emulator, and clicking the debug button, seems to happen even with simple new apps, with just a button on the home page. Perhaps more common in new apps?? I've been creating a few test apps today.

 

 

Geoff -- if this problem persists you may want to turn off the Emulate tab's auto reload function, that might help. See the image below for details:

 

S_L_D_K
Beginner
203 Views

Where a demo version of Admob to the new version of the XDK? The old plug-in com.google.admobsdk does not work. Could you tell me how I now connect the ads on the new version?

yusuke_s_
Beginner
105 Views

 

既にgoogle store にupload して公開いるアプリをアップデートしようとすると、証明書関連のエラーがでました。
(developper certificate を適当に作ってビルドしてみました)

今まで使っていた certificateを使って、すぐにgoogleに製品をアップデートしたいのですが、どうすればいいのでしょうか?

 

Reply