Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Dallas_M_
Beginner
59 Views

Issues getting VTune to work with Xeon Phi

Hi,

I recently got a Knights Corner Phi and have been setting it up. I set it up using the latest version of MPSS (3.8.1).

When trying to install the sampling driver, I get this message:

$ sudo ./micboot_install.sh 
SEP configuration files have been successfully installed in the configuration directory.
Please run  "service mpss restart" to start the SEP service.
itt successfully installed.
Please restart mpss service.
_amplxe_vtune_amplifier_xe_2017.1.0.486011 successfully installed.

Enabling prebuild driver installation.
Cannot find a prebuilt driver for stack sampling collection enabling Intel MPSS 2.6.38.8+mpss3.8.1 in /opt/intel/vtune_amplifier_xe_2017.1.0.486011/mic_sepdk/prebuilt/vtsspp.
Suggestion: Make sure the MPSS version is specified correctly.
If this does not help, run <VTune_install_dir>/mic_sepdk/src/vtsspp/build_mic.sh to manually build the vtss driver and enable this type of collection on the coprocessor card.

Enabling manual compilated driver installation.
Error: /opt/intel/vtune_amplifier_xe_2017.1.0.486011/mic_sepdk/src/vtsspp/vtsspp-k1om-2.6.38.8+mpss3.8.1smp.ko doesn't exist.

Manual VTSS++ driver compilation is required:
  unpack MPSS sources into /tmp/mic directory and then do
  KDIR=/tmp/mic/card/kernel /opt/intel/vtune_amplifier_xe_2017.1.0.486011/mic_sepdk/src/vtsspp/build_mic.sh --build clean all

Restart Intel Manycore Platform Software Stack (MPSS) to complete installation.
  sudo service mpss restart

Complaining that there is no precompiled driver for that version of MPSS. I double checked the directory. Looks like the latest version that's bundled with VTune is 3.7.2:

$ ls /opt/intel/vtune_amplifier_xe_2017.1.0.486011/mic_sepdk/prebuilt/vtsspp
vtsspp-k1om-2.6.38.8+mpss3.3.5smp.ko  vtsspp-k1om-2.6.38.8+mpss3.4.5smp.ko  vtsspp-k1om-2.6.38.8+mpss3.4smp.ko    vtsspp-k1om-2.6.38.8+mpss3.6smp.ko
vtsspp-k1om-2.6.38.8+mpss3.4.1smp.ko  vtsspp-k1om-2.6.38.8+mpss3.4.6smp.ko  vtsspp-k1om-2.6.38.8+mpss3.5.2smp.ko  vtsspp-k1om-2.6.38.8+mpss3.7.2smp.ko
vtsspp-k1om-2.6.38.8+mpss3.4.3smp.ko  vtsspp-k1om-2.6.38.8+mpss3.4.7smp.ko  vtsspp-k1om-2.6.38.8+mpss3.5smp.ko    vtsspp-k1om-2.6.38.8+mpss3.7smp.ko
vtsspp-k1om-2.6.38.8+mpss3.4.4smp.ko  vtsspp-k1om-2.6.38.8+mpss3.4.8smp.ko  vtsspp-k1om-2.6.38.8+mpss3.6.1smp.ko

 

In the README.txt, it just says that the precompiled driver should work and gives no instructions for rebuilding them. I tried following Sebastian's comment in this posting https://software.intel.com/en-us/forums/intel-vtune-amplifier-xe/topic/499431 but wasn't successful.

Any ideas on how to get the correct driver?

0 Kudos
1 Reply
P__Robert
Beginner
59 Views

Greetings!

Have you tried to rebuild the driver for your specific system?

The output message requests a rebuild of the vtss driver to enable stack sampling collection.

Try something along the lines of this:

sh /opt/intel/vtune_amplifier_xe/bin64/k1om/micboot_install.sh
#unpack MPSS sources into /tmp/mic directory
cp /mnt/nfs/System/mpss-src-3.8.1.tar /home/
cd /home/
tar xvf mpss-src-3.8.1.tar
tar xvf mpss-3.8.1/src/linux-2.6.38+mpss3.8.1.tar.bz2
cd /opt/intel/vtune_amplifier_xe/mic_sepdk/src/vtsspp/
KDIR=/home/linux-2.6.38+mpss3.8.1 /opt/intel/vtune_amplifier_xe/mic_sepdk/src/vtsspp/build_mic.sh --build clean all
sh /opt/intel/vtune_amplifier_xe/mic_sepdk/src/vtsspp/build_mic.sh --build

Thanks,

coast

Reply