Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_S_18
Beginner
312 Views

Login not accepted so stuck on Welcome screen [Solved]

I downloaded Intel XDK and started it up.  It opens and the the "Welcome" screen comes up.  I didn't have a login so I clicked on the link to create one.  There was a message about Adobe flash not working (this was in Chrome which should already have adobe flash) but that seemed to be needed just to play a movie.

I clicked on the link that brought me to the Intel Developer Zone so I created a login there.  Now when I try to start up XDK and login, the Welcome screen disappears and then immediately appears again and doesn't log me in.  If I click on the Sign Up button (the only other option I seem to have) it takes me to the developer zone and logs me in there in the browser window that's overlaying the Intel XDK window.  If i click the Cancel X in the upper right of the window, it closes the browser overlay and brings me back to the Welcome screen.

This is not a good way to start -- very frustrating!

Problem solved, it was an issue on the login server -- thanks all!

Dave

 

 

Tags (2)
0 Kudos
15 Replies
David_S_18
Beginner
312 Views

I also tried uninstalling Intel XDK and reinstalling.  That didn't fix the problem either

Swati_S_Intel1
Employee
312 Views

Are you on Windows or Mac or Ubuntu? If you are unable to sign up through Intel XDK, please go to signin.intel.com from your browser and create a new account. And then open Intel XDK and login from there. The overlay window you are seeing is normal. The way Intel XDK login works is, it uses signin.intel.com page for login, which is presented as an overlay. Once you login the overlay window will disappear. 

Regarding the flash message, could you send me the screen shot of that message?

David_S_18
Beginner
312 Views

I'm on Windows 10.  This is a new login I just created a few minutes ago.  I just checked and I can login at signin.intel.com just fine.

When I click on the Log In button on the "Welcome to the Intel XDK!" message box when Intel XDK starts up it doesn't bring up any dialog box or webpage overlay to enter my login and password.  It just briefly takes a way the Welcome box for an instant and then brings it up again.  So it looks like the first attached picture with the Welcome dialog box front and center.

If I click on the Signup button it does bring up an overlay webpage for after several seconds) that is a Create a new Account page on the Intel Developer Zone.

Then it looks like the second attached screenshot at the Intel Developer Zone create an account page.  Note the flash error on the right.

Even if I create a new account, Intel SDK isn't going to let me login in since it never brings up the signin.intel.com page overlay.

Note, If I click the Signup button and get the new account page overlay for Intel Developer Zone and then click on Login in the upper right of that overlay page then i am able to login and it brings up a page with links to Code Samples, Latest Blog Posts, etc. If I then click on the yellow bar above the overlay to cancel it, it takes me back to the Intel XDK overlay box with the Signup and Log In buttons -i.e. back to where I started.

James_H_2
Beginner
312 Views

David S. wrote:

When I click on the Log In button on the "Welcome to the Intel XDK!" message box when Intel XDK starts up it doesn't bring up any dialog box or webpage overlay to enter my login and password.  It just briefly takes a way the Welcome box for an instant and then brings it up again.  So it looks like the first attached picture with the Welcome dialog box front and center.

If I click on the Signup button it does bring up an overlay webpage for after several seconds) that is a Create a new Account page on the Intel Developer Zone.

Having the exact same problem here. I'm on a Mac with 10.9.5. Can't get past the Welcome screen.

Igor_S_1
Beginner
312 Views

.

Igor_S_1
Beginner
312 Views

 

James H.  wrote:

 

Quote:

David S. wrote:

 

When I click on the Log In button on the "Welcome to the Intel XDK!" message box when Intel XDK starts up it doesn't bring up any dialog box or webpage overlay to enter my login and password.  It just briefly takes a way the Welcome box for an instant and then brings it up again.  So it looks like the first attached picture with the Welcome dialog box front and center.

If I click on the Signup button it does bring up an overlay webpage for after several seconds) that is a Create a new Account page on the Intel Developer Zone.

 

 

 

Having the exact same problem here. I'm on a Mac with 10.9.5. Can't get past the Welcome screen.

 

After all, no one will answer this question? There are many people like me with the same problem and nobody does anything!
I'm angry, this issue is hindering the progress of my project! (Windows 10)

Pamela_H_Intel
Moderator
312 Views

Folks,

Please be patient. We must get sufficient information before we can determine the problem. I will check with engineering on this.

Pamela

James_H_2
Beginner
312 Views

This is clearly a serious bug if you cannot even dismiss the Welcome screen to get to the application. I am a first time user, or trying to be, but not getting very far.

Swati_S_Intel1
Employee
312 Views

@David, James, Igor, are you behind a proxy? Most likely if your proxy server requires authentication, then you are redirected back to welcome screen. If you are behind a proxy, try without a proxy (for example at home) or try to bypass the proxy (there are some tools to bypass the proxy if your company allows that). Another scenario could be your proxy server configuration restricts certain applications. You might have to change the server settings to whitelist the Intel XDK application. Other possibility is, Intel XDK looks at your proxy settings on startup, in some situations the proxy settings are not detected reliably. You might want to try setting some proxy environment variables on your system and then starting XDK from command line. See this FAQ on how to set those environment variables. Let me know if you are still having trouble logging in. 

Erik_J_Intel
Employee
312 Views

Hi all,

I'm sorry for the trouble.  I was able to reproduce the problems described here and I put in a fix that corrected the problem for me.  On the "Welcome screen" if you click "Login in" you should now either see a sign in page (if you have not validated your email address for example), or you should see a Terms and Conditions page where you can accept the XDK terms and conditions and then continue on with the XDK.

Please let us know if you continue to have problems and I will watch this thread for more issues.

erik

James_H_2
Beginner
312 Views

Not behind a proxy server here. I can see through the modal Welcome Screen that I am logged in, at least it appears to be. Clicking the login button just flashes the Welcome screen. Relaunched the application multiple times, same effect.

*** Update ***

Tried to launch the app today and it works. Go figure...damn internet gremlins.

David_S_18
Beginner
312 Views

I just found a debug log under ...\AppData\Local\Intel\XDK\bin\debug.log

Here's the content in case that's useful.  This content is written to the log as IDK starts up.  It doesn't seem to load anything else when I click on the Log-in button (which continues to just quickly remove and then return the Welcome dialog box as described above.

[13164:0505/094804:INFO:CONSOLE(17)] ""xdk:client:[2016-05-05T16:48:04.936Z]: (1462466884936): Failed to load theme: xdk" {"code":"MODULE_NOT_FOUND"}", source: C:\Users\david\AppData\Local\Intel\XDK\xdk\core-modules\private\logger.js (17)
[13164:0505/094815:INFO:CONSOLE(212)] ""NW proxy string: DIRECT"", source: /brackets.js (212)
[13164:0505/094816:INFO:CONSOLE(17)] ""client:build-tab:[2016-05-05T16:48:16.245Z]: (1462466896245): [refreshPage] Unable to generate project hash." {"message_":"no project selected","code_":null,"componentName_":null,"stack_":"Error\n    at new ComponentError (C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\public\\component-error.js:17:1122)\n    at makeError (file:///C:/Users/david/AppData/Local/Intel/XDK/xdk/components/client/backend-service-utils/backend-service-utils.js:17:187)\n    at Object.exports.generateProjectHash (file:///C:/Users/david/AppData/Local/Intel/XDK/xdk/components/client/backend-service-utils/backend-service-utils.js:17:1440)\n    at _refreshPage (file:///C:/Users/david/AppData/Local/Intel/XDK/xdk/components/client/build-tab/build-tab.js:17:6994)\n    at Object.start (file:///C:/Users/david/AppData/Local/Intel/XDK/xdk/components/client/build-tab/build-tab.js:17:3869)\n    at resumeClientInit (C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\private\\main.js:17:12040)\n    at C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\private\\main.js:17:1734\n    at _fulfilled (C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:834:54)\n    at self.promiseDispatch.done (C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:863:30)\n    at Promise.promise.promiseDispatch (C:\\Users\\david\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:796:13)"}", source: C:\Users\david\AppData\Local\Intel\XDK\xdk\core-modules\private\logger.js (17)

 

David_S_18
Beginner
312 Views

Yes, working fine for me now too.  Thanks

 

Dave

Erik_J_Intel
Employee
312 Views

Also regarding the Adobe Flash video on the sign up page, indeed that is just a video and not a necessary part of the signup procedure.

Erik_J_Intel
Employee
312 Views

 @James, I was the gremlin in this case, sorry.  I was too aggressive in a security check and prevented you (or anyone!) from seeing the Terms and Conditions page.  How this got through two weeks of testing I don't yet know, but I'm glad you are back on track.

erik

Reply