Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FP
Beginner
216 Views

Build failed

Hi there

Haven't built for a couple of days but didn't change anything. Today we're getting this error when attempting to build for Android or iOS (the only 2 we're currently using) - PS: We're still using version 2893 for a few more days due to planned release.

An error occurred while building the application. Verify your build assets are correct and try again.

I saw a tweet from April 18th which warned of build system downtime - is there something going on?

Thanks

 

 

 

 

Tags (2)
0 Kudos
26 Replies
Mauricio_G_
Beginner
204 Views

I have the same issue with all my apps, including the one that I'm working right now. The last build that I could make was on 18/4/2016 at 6:27:53 P.M.

Pamela_H_Intel
Moderator
204 Views

@FP - no, the downtime has passed. I will check with the build engineers.

@Mauricio - you are using 2893 also? 

Pamela_H_Intel
Moderator
204 Views

@FP and @Mauricio - please include your detailed build logs so we can get more details.

FP
Beginner
204 Views

Pamela H. (Intel) wrote:

@FP and @Mauricio - please include your detailed build logs so we can get more details.

Pamela - there is no build log, it doesn't even start. As soon as I click on "Build App Now" the error comes up (See attached screenshot) - I have been building with no issues for months with the same set up - hope this helps.

Thanks

Mauricio_G_
Beginner
204 Views

Yes also version 2893. It's the same as FP, no building log, it just shows that message.

Ulises_G_
Beginner
204 Views

 

i have this problem, the same

 

FP wrote:

Cita:

Pamela H. (Intel) escribió:

 

@FP and @Mauricio - please include your detailed build logs so we can get more details.

 

 

Pamela - there is no build log, it doesn't even start. As soon as I click on "Build App Now" the error comes up (See attached screenshot) - I have been building with no issues for months with the same set up - hope this helps.

Thanks

 

Swati_S_Intel1
Employee
204 Views

Are you using Cordova CLI 4.1.2 by any chance? If so, please upgrade to CLI 5.1.1 as support for 4.1.2 has been removed. If you are still experiencing issue, please send your project zip or your .xdk file via private message.

FP
Beginner
204 Views

SWATI S. (Intel) wrote:

Are you using Cordova CLI 4.1.2 by any chance? If so, please upgrade to CLI 5.1.1 as support for 4.1.2 has been removed. If you are still experiencing issue, please send your project zip or your .xdk file via private message.

Using 5.1.1 here - how do I send the flles by Private message?

Pamela_H_Intel
Moderator
204 Views

@FP - Click on the "Send Author A Message" link at the top of a post of the person you want to send to.

Mauricio_G_
Beginner
204 Views

FP wrote:

Quote:

SWATI S. (Intel) wrote:

 

Are you using Cordova CLI 4.1.2 by any chance? If so, please upgrade to CLI 5.1.1 as support for 4.1.2 has been removed. If you are still experiencing issue, please send your project zip or your .xdk file via private message.

 

 

Using 5.1.1 here - how do I send the flles by Private message?

I'm also using 5.1.1, could you send instructions to send you the project via private message.

I don´t know if the problem is in the coding, because I haven't made changes to my project since my latest build wich was on 18/04/2016 at 6:21 pm. Even my other projects wich I haven't been modifying are the same. Even a partner programmer here has the same problem.

 

Pamela_H_Intel
Moderator
204 Views

@Ulises - you too are using 2893? And no build log? And using CLI 5.1.1 or 5.4.1?  iOS and Android? or Windows?

Pamela_H_Intel
Moderator
204 Views

Did any of you use any non-ASCII characters in your passphrase or alias for your keystore when you upgraded your legacy cert? (Android)

FP
Beginner
204 Views

Pamela H. (Intel) wrote:

Did any of you use any non-ASCII characters in your passphrase or alias for your keystore when you upgraded your legacy cert? (Android)

We didn't have to upgrade our cert as we are still using v 2893 so no that's not the issue. Nothing changed since last build which was also on April 18th like one of the other posters.

Thanks

Mauricio_G_
Beginner
204 Views

Pamela and SWATI S. my colleague programmer tells me that even the Intel XDK demos can´t be built on v2893.

Pamela_H_Intel
Moderator
204 Views

FP - yes, of course, sorry - I was trying to think of anything that could be a problem.

Okay, folks, there was a release yesterday - both a build release and an XDK release. I will test and get back to you all. 

satya_k_
Beginner
204 Views

Hi Pamela,  getting same issue, even samples are getting the same error, 

Pamela_H_Intel
Moderator
204 Views

Folks - it seems the build release yesterday that resolves several issues with XDK v3088 inadvertently affected the building of 2893.

Here is a workaround you can try if you want to continue working while we work on resolving the issue.

If you try this and ever want to revert back to 2893, YOU MUST SAVE A BACKUP OF YOUR PROJECTS - they will not be backwards compatible once you upgrade them. 

  1. Save a BACKUP COPY of your project directories.
  2. Download XDK 3240 (released yesterday)
  3. [[ I recommend that you download your legacy cert before converting it, in case you need to revert to 2893 later. ]]
  4. Try your projects with this new version. You will need to convert your legacy cert (https://software.intel.com/en-us/forums/intel-xdk/topic/622926). 

Otherwise, you can wait for us to troubleshoot this issue.

Pamela

FP
Beginner
204 Views

Hi there

Thanks - we have updated to the latest version, but we cannot see where to download the legacy cert in the old format before we convert (in case we need to go back to 2893 as per Pamela's last post)

How do we download the existing certs in the old format?

Thanks

FP
Beginner
204 Views

Hi there

I know you've fixed the issue, but in the meantime we decided to update to the latest xdk version and all is well.

Thanks for the support

Pamela_H_Intel
Moderator
63 Views

Hi all, as FP says, the issue was fixed last night. So you can continue to use 2893 for awhile. But keep in mind that we do not continue to support old versions, so you should expect to upgrade soon.

@FP - when you say "all is well", does that mean you figured out the cert process? 

Reply