Community
cancel
Showing results for 
Search instead for 
Did you mean: 
berndhartke
Beginner
97 Views

SOLVED: ifort installation and activation via flexlm successful, but cannot run ifort

While writing this forum entry text, I kept experimenting with a few further ideas to solve the problem, and by chance I could fix it. Nevertheless, this may help others, so I am still posting this: On vanilla linux systems, I have just installed flexlm with a valid (new) license file on one machine (license server). On another machine, I have installed the full compiler package (icc, ifort, mkl, etc., Version 16.0.3.210 Build 20160415), choosing activation via the just installed flexlm on the other machine. Upon query by the installation script, I entered the port number (28518) and machine name, and after a while the script told me "Activation completed successfully" Assuming that all is fine, after the installation finished (and after running compilervars.sh), I tried to use "ifort", but kept getting this message: Error: A license for Comp-FL is not available (-76,61026,2). License file(s) used were (in this order): ... ... ...(some lines deleted).... .... .... ifort: error #10052: could not checkout FLEXlm license Using telnet, I have verified that from the other machine I can reach the license server machine on port 28518. And, as suggested elsewhere in this forum, I have generated a license checkout log by setting the environment variable INTEL_LMD_DEBUG (letting its contents point to a filename of my choice); sadly, however, the long output generated there did not really help me (although presumably it does help the experts). In the above error message text, at the location "some lines deleted", several directories are listed where the compiler searches for a license file. Coming from earlier installations w/o license servers, I mistakenly assumed that with flexlm in place and after having made successful contact with this flexlm during compiler installation/activation, it is o.k. that in those locations there really is no license file -- because the compiler should contact the license server, and there of course a license file is present (I copied it there). HOWEVER, getting desperate, I simply copied my license file (the same one I copied to the license server) also to one of those locations, and *bingo* things instantly worked. What I still do not understand is why a local license file is still necessary, after successful activation of the compiler suite during installation, and (accepting for the moment that this is needed) why the compiler installation script (install.sh) failed to provide for that or at least instruct me to do such a copy manually. (By the way, I also wonder why this version of install.sh does not remind me to source compilervars.sh; all the previous versions always did that, at the end of the installation.) So, again, maybe the above helps some other users, and just out of interest I still would appreciate an answer to those questions at the end. Bernd
0 Kudos
4 Replies
James_T_Intel
Moderator
97 Views

You shouldn't need to copy the license file locally.  This is a working solution, but the least preferred method, as any future updates such as renewing support will require updating the license file on every client.  The instructions at https://software.intel.com/en-us/articles/intel-software-license-manager-getting-started-tutorial#Se..._ describe the ideal method of setting up the license on the client systems.

berndhartke
Beginner
97 Views

Thanks for your reply. However, I do not quite understand what is different in the text you are pointing to. To quote verbatim from there: 1. Start the product installer 2. When it comes to product activation, the default activation option will be "Use Serial Number" 3. Do not use this option, but select "Alternative Activation > Use License Server" instead and specify the server name and port of the license server. This is exactly what I did: During "install.sh", I chose activation via "use license server" and then specifying the port number and server name of the license server. Sadly, this did not lead to a working setup on the client. Copying the license server to one of the default locations on the client simply was a guessed attempt of mine to fix the situation. I agree that I should not have to do that. But without it, and with following the exact procedure you are pointing to, things did not work, and I wonder why. The "install.sh" did manage to contact the license server successfully (at least it issued a message "activation completed successfully" after a few minutes (as indicated on the page you are pointing to, this can take some time, which is fine), but none of my attempts to run "ifort" or "icc" after the end of the installation succeeded in obtaining the license -- only after copying the license file by hand to a default location this worked. Bernd
Jennifer_D_Intel
Employee
97 Views

Hello,

Based on your comments, I believe the error is caused by a problem with trusted storage.  When you provided the port and host it was able to install, but further checkouts attempt to use trusted storage and fail.  Providing the license file gives it an alternative to trusted storage.  Setting the environment variable INTEL_LICENSE_FILE=port@host should also work.  I will pass your questions regarding install.sh and compilervars.sh on to the compiler team and let you know what they say.

As for what happened with trusted storage, I'm not sure.  I will contact the installer developers and see if there is a fix or root cause.  Can you send me your log file in a private message?

Thank you,

Jennifer

 

james_t_5
Beginner
97 Views

All, I am not a computer nerd, exactly what steps did you take.  I know for you this seems trival, but for me--big problem.  Jim turner, jamesdanielturner@hotmail.com,  jamesdanielturner10 (skype), 979-402-7584

 

 

 

 

Reply