Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Richard_S_
Beginner
111 Views

Version 2.

I want to use Crosswalk 23. But the only available in Intel XDK is 19 how can I upgrade it to 23?

19.png

Tags (2)
0 Kudos
1 Reply
PaulF_IntelCorp
Employee
111 Views

The current version of the XDK does not offer a way to specify CW 23, however, that option will be available in the XDK release that corresponds to the build system retirement, in a few weeks. Note that CW 23 requires at least CLI 6.5 and Android 4.1 or greater in order to build and run correctly.

Our build system does not support building with CLI 6.5 or with CW 23 and will be retired soon, so I'm assuming you are using the export to Cordova/PhoneGap Build feature on the Build tab (the "Cordova Build Package" button). If you are using the Cordova export feature, you can modify the config.xml file that is created by changing three lines in it to be similar to the following:

<preference name="phonegap-version" value="cli-6.5.0" />
<preference name="android-minSdkVersion" value="16" />
<plugin name="cordova-plugin-crosswalk-webview" />

You won't find these three lines next to each other in the config.xml, (which is fine, they can stay where they are in the config.xml file), they just need to be changed to be like those shown above. Note that the minSdkVersion version may be higher if you have specified a higher number, which is fine; you only need to change that number to 16 if it is currently set to 15 or less.

Reply