Issues related to Intel® Wireless Adapters and technologies
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6086 Discussions

7260.HMWWB dual-band Wireless-AC not bound to transport driver?


Hi all,

I just upgraded my Acer Aspire One AO722 from a Broadcom 802.11n mini-PCIe card to an Intel 7260.HMWWB card to enable connection on 802.11ac to my router. However whilst the Bluetooth is working fine, the wifi doesn't work at all and comes up saying no connections available. If I run the manual diagnostic program it fails the hardware test with an error of "Wireless Hardware is not bound to transport driver".

This is using the most recent ProSet driver/program package I could find on the Intel website (17.0.5) under Windows 7 home premium 64-bit. I did try the auto-detect and update option on the website, but it either just corrupted the screen and locked the machine up (when run under Chrome) or blue-screened it (when run under IE). Presumably this is due to it having an AMD C-50 processor rather than an Intel one.

Device manager doesn't have any !'s in it, and the Network Adapters section lists "Intel(R) Dual Band Wireless-AC 7260" and the driver tab under it says and that everything is working correctly. I already tried resetting the Winsock and TCP/IP stacks after seeing that tip on various web pages, but that didn't help either.

Is this going to be a hardware issue with the card itself, or is it a general incompatibility between the Intel PCIe card and the AMD-based processor/motherboard? My only remaining plan is to try it under a Linux Live-CD to see if that sees the thing ok or not (as a hardware test), but can anyone recommend any other methods to get this thing working?

Editted to add - Under an Ubuntu 14.04 live-CD the card works fine and plays nice (I'm posting this from it via my 5GHz network) so there's definitely something messed up with either the Windows driver or how they're interacting with my Windows 7 installation. So now the question is what to do to get the thing also working under Windows 7?

0 Kudos
2 Replies

Hi DarrenHill, the troubleshooting steps you tried are a good approach and perhaps there is also the option to update your system BIOS. However, there are some things to consider when upgrading your wireless adapter:

  • Just like any other device, not all wireless adapters are physically and electrically compatible with all systems.
  • The system BIOS could be designed to accept certain wireless adapter models only.
  • The installation of these adapters is subject to country-specific regulatory approvals which include the system, wireless adapter and antennas.

We highly encourage contacting your http://www.intel.com/support/oems.htm system manufacturer in order to obtain a list of validated wireless adapter models that are compatible with your system and the proper means to accomplish this hardware integration.

http://www.intel.com/support/wireless/sb/CS-006192.htm Wireless Networking — Installation error when installing or swapping Intel wireless adapters

http://www.intel.com/support/wireless/wlan/sb/CS-011644.htm Intel® Wi-Fi Products — Regulatory information regarding hardware installation or upgrade



Thanks for the reply.

The BIOS is completely up to date (one of the first things I checked), and as it is an Acer system there is no whitelisting in place. Plus in the case of both BIOS and fundamental hardware operation and compatibility, the fact that under the Ubuntu LiveCD the card worked fully straight away eliminates both as root causes.

From the testing, the issue is strictly down to the Windows drivers. Initially as I said using my existing Windows7 installation, the problem was that the drivers could not be bound to the hardware. So what I did was to completely wipe and reinstall the Windows environment from scratch, with the Intel card drivers the very first thing to be put back on. In doing so the card was then correctly bound to the driver and the first three manual diagnostics tests passed. However the card was still not able to actually see (and therefor connect to) any wifi network at all, on either 2.4GHz or 5GHz frequency. This was with the netbook sitting literally on the same desk as the wifi router, a distance between them of approximately 4 inches.

I also have to notify you that to try and confirm I had the full and correct drivers I did try to use the automatic check/update page on the Intel website, but that just caused either my machine to lock-up with a completely corrupted screen (if tried under Chrome) or a blue-screen-of-death crash (if tried under IE). So for my AMD C-50 based system at least that page is totally unusable.

In the end as the Windows 7 drivers are not usable at all, I have switched back to the previous Broadcom 802.11n card (which after the Windows 7 reinstall works perfectly, albeit more slowly than the 802.11ac card did under Linux) and I have returned the Intel card to my supplier and received a full refund. From some separate support discussions with other Acer users on their support forums I now hear reports from other users as well about issues and incompatibilities with the Intel Windows driver software, so I am fully confident that those are the root cause. And sadly due to this when I again look for an 802.11ac card in the near future, it will either be a Qualcomm/Atheros or a Broadcom model.