Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
836 Views

AC 7260 Slow upload / Good download

Can anyone let me know how to fix the slow upload issue for AC 7260 wireless card?

I have a small NAS drive (WD Mycloud) connected to the router (D-link 868), and wireless upload and download speed to the NAS from laptop is good (20MBps & 30MBps) when my laptop is around the router. The laptop has AC 3160 adapter.

I also have a PC which has a wireless adapter upgraded to AC 7260 from Dell's DW1703 (Wireless N). The download speed for the PC is acceptable @ 25 MBps, however the upload speed to the NAS is just @ 4MBps.

I have updated the driver and bios, and tried to change the adapter settings to recommended. But nothing works.

If anyone had this same issue before, can you please share how the issue was fixed?

Thank you very much!!!

0 Kudos
1 Reply
Highlighted
Honored Contributor II
7 Views

sparkon,

If we understand it correctly, you have replaced the PC original Wireless Adapter for the Intel(R) Dual Band Wireless-AC 7260, correct?

If that is the case, we would like to inform you that Intel does support integration which is when the original wireless adapter is replaced for another one. That is a chance that the adapter installed may not be compatible with the system you installed it in. Please take a look at this only document related to this matter. http://www.intel.com/support/wireless/wlan/sb/cs-011644.htm Intel® Wi-Fi Products — Regulatory Information Regarding Hardware Installation or Upgrade

On our best effort to help you, here as some other documents related to this topic as well as some steps that might improve your experience.

1 - Try to change the channel on the router to a less crowded one.

2 - Disable Power Saving Functions in order to have the adapter working at its maximum performance. - Go to Control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply to default settings.

3 - Check the Change Plan Settings: Change Advanced Power Settings >> Power Saving Mode and make sure both On battery and Plugged in are set to Maximum Performance.

4 - Go to Device Manager >> Network Adapters >> Intel(R) Dual Band Wireless-AC 7260, right click on it and select Porperties.

5 - On the Adavanced tab, set the Value of U-APSD support to Disabled.

6 - Cjeck the value of Transmit Power and make sure it is set to 5. Highest.

7 - Set the Preferred Band to Prefer 2.4GHz band.

8 - Set the HT Mode to HT.

9 - Set the 802.11n Channel for 2.4GHz to limit 20MHz

10 - Set the Roaming Aggressiveness to Lowest.

11 - Set the Ad Hoc QoS Mode to WMM Disabled.

http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-006321.htm Intel® Wi-Fi Products — Access Point (AP) Firmware Updates May Resolve Wireless Network Issues

http://www.intel.com/support/wireless/wlan/sb/CS-035591.htm Intel® Wi-Fi Products — Current Top 10 Frequently Asked Questions

http://www.intel.com/support/wireless/sb/CS-029893.htm Wireless Networking — Frequently Asked Questions - Wi-Fi