Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
902 Views

AC 8265: Does not connect to Hidden 5Ghz Wireless network - Any ideas of solution?

​Lenovo X1 Yoga laptop - Latest Driver installed 20.70.5.2

Connection works perfectly if network is broadcasting SSID. 300mbs, however when SSID is hidden fail to connect. Access point Linksys 300N with latest firmware.

Any ideas?

0 Kudos
3 Replies
Highlighted
Super User Retired Employee
21 Views

Are you (a) clicking on the Unknown Network entry and then providing SSID (etc.) or (b) creating a new profile with SSID (etc.) and then waiting for it to connect automatically? If one path isn't working, try the other.

 

Hope this helps,

...S

0 Kudos
Highlighted
Beginner
21 Views

​Hi Scott, thanks

(a) YES - Computer start to connect and than provide mess that cannot connect to network

(b) I did create the profile with SSID etc. It does not connect

 

The odd think is that when SSID is activated it connects instantly on 5Ghz

Problem does not occur on 2.4GHz. It does connect to hidden network.

 

Driver bug?

0 Kudos
Highlighted
Super User Retired Employee
21 Views

No, I don't believe there's a driver bug. I normally keep SSIDs exposed because of a (ridiculous!) bug in my D-Link DIR-865L router (Guest Network doesn't work if private SSIDs hidden). I temporarily set it to hide the SSIDs. I then attached to the 5GHz band by clicking on the Hidden Networks entry and entering SSID (etc.) manually. On a Core m3-based Compute Stick with 8260 component, it failed to connect completely the first time (well, had no internet access). I waited about 15 second and then re-clicked on the entry and it attached and worked immediately. On NUC8i7HVK NUC with 8265 component, after providing SSID and passphrase, it connected immediately and works just fine.

 

So, what could be the cause. Something in your router? You never mentioned model.

...S

0 Kudos