Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7431 Discussions

AX1650s not reaching 1gb speed

Radar224
Beginner
871 Views

Good evening,

 

I have a Dell XPS13 equipped with an AX1650s adapter.

Connecting to a new internet provider I switched to the Wifi 6 system. Now my download speed is never higher than 370 and upload will reach appr 900Mbps.

We did all the test but still unable to reach higher download speeds.

I did a clean install of the Killer suite but no improvement.

Hopefully someone in the community could shed some light on this for me.

0 Kudos
7 Replies
DeividA_Intel
Employee
850 Views

Hello Radar224,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® Killer™ Wi-Fi 6 AX1650 (i/s).   



In order to better assist you, please provide the following:  


1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

2. Have you checked this issue with the Internet Service Provider (ISP)? This is because you mentioned that the issue appears after connecting to a new ISP.

3. Did the old IPS give the same issue?

4. What is the brand and model name of your router/modem?

5. Have you tried the latest drivers from Dell?

6. Have you tried a clean install of the Intel drivers?



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Radar224
Beginner
839 Views

HI Deivid,

Thanks for your reply!

1- This is the original adapter that came with the Dell 2021 XPS13.

2- Yes the issue has been investigated by the ISP and I have been assured that the speed into our property is close to 1Gig.

3- No, our previous IPS maxed out at 600Mbps and was using Wifi 5 technology.

4- The Modem is supplied by our ISP, Telus Canada and manufactured by Intertek. Model B20T 

5- Yes all drivers are up to date

6- I did a clean install of the Killer intelligence center three days ago.

 

In front of the router I am able to download at appr 600Mbps with a pixel 6 phone, The same spot will give me appr 360 with the Dell.

A second Dell computer with idential specs behaves exactly the same as the one in my original question.

The settings in the Killer app were not altered from the typical install.

Bandwidth in the app is sitting at 1500

 

Hope that helps

I am looking forward to your reply.

Radar224

 

 

 

0 Kudos
DeividA_Intel
Employee
825 Views

Hello Radar224, 



Thanks for all the information provided. In order to continue further I would like to confirm the following:


1. Is the issue present in both bands (5GHz and 2.4GHz)?

2. Does the pixel 6 phone has the same issue if is far from the router? You mentioned that tried just in front of the router.

3. Is the issue present if you tried with a direct connection (Ethernet cable)?

4. Have you checked this behavior with Dell to confirm any compatibility issues? This is because the issue is present in another Dell computer.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Radar224
Beginner
810 Views

Hi again,

1- Yes, both bands.

2-The pixel 6 downloads appr twice the speed (500) when placed side by side about 20ft away from the router.

3- Yes I never managed more than download 375, upload 900 wired or wifi, therefore I thought it could be a setting I am not aware of?

4- I never checked with Dell since they equipped this laptop. Also, my one year service contract has expired. I never had any issues until I switched to wifi 6

 

Thanks again for all your advise!

Radar224

 

0 Kudos
DeividA_Intel
Employee
798 Views

Hello Radar224, 



Thanks for the confirmation. Before we continue further, can you try the recommended settings for 802.11ax connectivity?


Also, since the issue happens with wired and wifi I recommend you check this issue with Dell to confirm that there is no malfunction with the laptop.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Employee
776 Views

Hello Radar224,  


 

After checking your thread, I would like to know if you need further assistance. 


If so, please let me know. 


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Employee
748 Views

Hello Radar224,  


 

I was checking your thread and see that we have not heard back from you.  


I’m going to close your post, but if you need further assistance, please do not hesitate to create a new thread. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Reply