Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6022 Discussions

AX200 160mhz on MSI mainboard doesn't work

VincentH
Beginner
320 Views

I have a MSI X570 Unify board which has AX200 160MHz embedded. Wifi stopped working after I did a power off when my OS was stuck. Something I noticed in the dmesg log saying OTP is empty and no valid mac address is found. I did a search in the community, but hasn't found any similar posts. Bluetooth seems working fine though.

 

What can I do to recover from this?

 

[ 4.052530] iwlwifi 0000:28:00.0: enabling device (0000 -> 0002)
[ 4.084176] iwlwifi 0000:28:00.0: api flags index 2 larger than supported by driver
[ 4.084188] iwlwifi 0000:28:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
[ 4.084320] iwlwifi 0000:28:00.0: loaded firmware version 62.49eeb572.0 cc-a0-62.ucode op_mode iwlmvm
[ 4.172879] iwlwifi 0000:28:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[ 4.306388] iwlwifi 0000:28:00.0: OTP is empty
[ 4.306399] iwlwifi 0000:28:00.0: no valid mac address was found
[ 4.306400] iwlwifi 0000:28:00.0: Failed to read NVM: -22
[ 4.306402] iwlwifi 0000:28:00.0: WRT: Collecting data: ini trigger 13 fired.
[ 4.307530] iwlwifi 0000:28:00.0: Start IWL Error Log Dump:
[ 4.307531] iwlwifi 0000:28:00.0: Status: 0x00000040, count: 6
[ 4.307532] iwlwifi 0000:28:00.0: Loaded firmware version: 62.49eeb572.0 cc-a0-62.ucode

0 Kudos
4 Replies
David_G_Intel
Moderator
289 Views

Hello VincentH

  

Thank you for posting on the Intel️® communities. 

Please share with us more information:

  • Which Linux distro do you use?
  • Is your driver up to date? Where did you download them from?
  • Error Log Dumps
  • Intel® System Support Utility (Intel® SSU) results:
    • Download the Intel SSU https://downloadcenter.intel.com/download/26735/
    • Open the application and select "Everything" click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".  
    • Click on the menu where it says "Summary" to change to "Detailed View".  
    • To save your scan, click on "Next", then "Save".  

 

Regards, 

David G 

Intel Customer Support Technician


David_G_Intel
Moderator
235 Views

Were you able to check the previous post?  

Let us know if you still need assistance.   


Best regards,  

David G.  

Intel Customer Support Technician  


VincentH
Beginner
226 Views

After a kernel update (5.12.13), issue is recovered. Thanks for the response.

David_G_Intel
Moderator
209 Views

We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. Since the thread is now solved, we will proceed to close it. 

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Best regards, 

David G 

Intel Customer Support Technician 


Reply