Wireless
Issues related to Intel® Wireless Adapters and technologies
6287 Discussions

AX201 and AX210 very poor signal bluetooth

EasyNet
Beginner
1,078 Views

Hello,

 

I brought last week another WiFi card, an AX210, after thinking AX201 has a broken Bluetooth module. But changing the the previous AX201 card with AX210 I notice the same issue: extremely poor Bluetooth signal. between -90 and -100dBm.

My MegaBoom 3 and Sony SRS-12 speakers  are not able to negotiate a link with my desktop, neither Windows nor Linux.  In Linux, using blueman-manager, I was able to see the signal for the devices which was between -90 and -100dBm, depending where I was placing the devices.

If I'm placing near by case, the signal is -84 dBm. If is on my desk is going to -100.

If I'm using an USB BT4.0 adapter I'm able to connect all devices without issues.AX210 - Bluetooth Megaboom3.png


The WiFi connection I can reach over 325Mbps links on my Ubiquiti Access Point which can handle 802.11ac up to 867Mbps. Because my desktop position is not very good for WiFi signal, I get this values for WiFi link, but still is very good.


I have some antennas that claims are about 12dBi.

My problem is still the Bluetooth connectivity. Why the bluetooth is very poor in signal for those cards? They are not using the same WiFi antenna? Or it has an internal antenna and because is connected on M.2 slot on my desktop motherboard is actually blocked by the case?

 

Both modules have only 2 antenna connectors.

 

This is an output from bluetoothctl:

 

bluetooth]# default-agent
Default agent request successful
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller 60:DD:8E:F6:C6:C3 Discovering: yes
[NEW] Device C0:28:8D:DA:01:7B MEGABOOM 3
[bluetooth]# pair C0:28:8D:DA:01:7B
Attempting to pair with C0:28:8D:DA:01:7B
Failed to pair: org.bluez.Error.ConnectionAttemptFailed
[DEL] Device C0:28:8D:DA:01:7B MEGABOOM 3
[NEW] Device C0:28:8D:DA:01:7B MEGABOOM 3
[CHG] Device C0:28:8D:DA:01:7B UUIDs: 0000110d-0000-1000-8000-00805f9b34fb
[CHG] Device C0:28:8D:DA:01:7B UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device C0:28:8D:DA:01:7B UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device C0:28:8D:DA:01:7B UUIDs: 0000110f-0000-1000-8000-00805f9b34fb
[CHG] Device C0:28:8D:DA:01:7B UUIDs: 0000fe61-0000-1000-8000-00805f9b34fb
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 20 0b 00 00 00 00 00 00 c0 28 8d da  ..c. ........(..
  01 7b 22                                         .{"
[bluetooth]# connect C0:28:8D:DA:01:7B
Attempting to connect to C0:28:8D:DA:01:7B
[DEL] Device C0:28:8D:DA:01:7B MEGABOOM 3
[NEW] Device C0:28:8D:DA:01:7B MEGABOOM 3
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 40 0b 00 00 00 00 00 00 c0 28 8d da  ..c.@........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 40 0b 00 00 00 00 00 00 c0 28 8d da  ..c.@........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 40 0b 00 00 00 00 00 00 c0 28 8d da  ..c.@........(..
  01 7b 22                                         .{"
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Key: 0x0003
[CHG] Device C0:28:8D:DA:01:7B ManufacturerData Value:
  01 1a 63 00 40 0b 00 00 00 00 00 00 c0 28 8d da  ..c.@........(..
  01 7b 22                                         .{"
[DEL] Device C0:28:8D:DA:01:7B MEGABOOM 3

 

Kind regards.

0 Kudos
4 Replies
David_G_Intel
Moderator
1,060 Views

Hello EasyNet


Thank you for posting on the Intel️® communities. Please share more information with us:

  • What is the model of the motherboard and its BIOS version?
  • Is this a new computer? If so, have check with your system's OEM for validated drivers or support on known issues related to the symptoms experienced?
  • What OS versions did you use?
  • Were you able to have you Bluetooth connection in a normal/expected performance before?
  • Have you installed any recent software or hardware in your system?
  • Which drivers did you test?


Regards, 

David G 

Intel Customer Support Technician 


EasyNet
Beginner
1,019 Views

Hi David_G_Intel,

 

The motherboard is an Asrock X570M Pro4 with BIOS version 3.60, latest one. The computer is new one and asambled by me, not by a specific vendor.

As OS I tried Windows 10 21H2 with latest versions of drivers from Intel site for both WiFi and Bluetooth. The main OS is Linux. One is Debian Bookworm with Linux Kernel 5.14.X and for about 2 weeks I'm using Linux Kernel 5.15.3. I have another Linux OS which is Pop_OS! with Kernel 5.13.x.

From beginning I faced this issue with both cards, extreamly poor performance with Bluetooth in both cases and I wasn't able to pair the devices with Bluetooth.

Windows 10 is a fresh install on a separate SSD, so no additional software. In Linux everything is in kernel. I just updated the firmwares for Linux to be able to use drivers with Kernel 5.15.

For Windows 10 I installed WiFi drivers 22.90.0 and for BT 22.90.2.

BTW: The Bluetooth is connected via mini PCIe M.2 slot to USB bus.

 

Kind regards.

 

David_G_Intel
Moderator
1,001 Views

Thank you for the update. Let me further investigate this request and I will post updates on this thread.


Regards, 

David G 

Intel Customer Support Technician 


David_G_Intel
Moderator
958 Views

In this case the issue seems to be with the antennas or the installation process, the best option is to contact the motherboard OEM to verify compatibility and confirm the proper installation process.

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Regards, 

David G 

Intel Customer Support Technician 


Reply