Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
7301 Discussions

AX210 PCIe Wi-fi 6E card turning on power save flag in a packet

Kwaki
Beginner
2,557 Views

Hello,

 

I'm using AX210 on Linux system. That can detect an access point and the communication seems going well most of time.

However I monitored that AX210 wifi module sometimes sends a QoS null packet with power management flag ON, then enters power save. When this happens, wifi module doesn't wake up during around 100 [ms] and communication stops during this term.

 

To disable this power save feature, I added few codes in iwlwifi driver trying to reset the bit related to power save like IEEE80211_HW_SUPPORTS_PS.

 

In the end, none of my trial worked well.

 

Could you please advise me how to prevent wifi module from going power save ?

 

Many thanks for your support in advance.

Best regards,

0 Kudos
16 Replies
DeividA_Intel
Moderator
2,527 Views

Hello Kwaki,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your   


  

In order to better assist you, please provide the following:  


1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

2. Is this a laptop or desktop computer? 

3. Is this issue recent? If so, when did it start?

4. What is your operating system version and kernel?

5. Can you take any pictures where we can see the issue?

6. This feature may be controlled by the operating system, have you checked with the Linux support?



Regards,  

Deivid A. 

Intel Customer Support Technician 


0 Kudos
Kwaki
Beginner
2,511 Views

Hello Deivid,

Many thanks for replying back.

 

Here, I added my comments.

 

1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?
No, this is not original PCIe wifi NIC. I newly purchased it in a market.

2. Is this a laptop or desktop computer?
It is on the embedded hardware environment which is Raspberry Pi compute model 4 with IO expansion board.

3. Is this issue recent? If so, when did it start?
1 month
I have attempted to integrate it recently.

4. What is your operating system version and kernel?
I'm trying on two different operating system.
Raspberry Pi OS based on Linux kernel Ver 5.15
LineageOS 19.1 based on Linux kernel Ver 5.10

5. Can you take any pictures where we can see the issue?
I attached few pictures.
menuconfig.jpg shows kernel configuration that enables the corresponding driver.
dmesg iwlwifi.txt log shows the part of dmesg log like iwlwifi driver is loaded.
Power Save Mode.jpg shows that power save flag is turned ON in the wifi header of a packet. This is the packet from Raspberry Pi to another device that notifies to go power save mode.

6. This feature may be controlled by the operating system, have you checked with the Linux support?
No, I haven't contacted them yet.
If my understanding is not wrong, there are mainly two ways that wifi module goes power save mode.
One is that wifi module goes power save mode because the system itself goes power save mode. In this case, the operating system controls to trigger power save mode toward wifi module.
Another is that wifi module triggers poser save mode by itself, depending on its configuration. In this case, wifi module can go power save mode without controlled by the operating system, then take a balance of power consumption. This way is what I need to disable.

 

Best regards,

Kwaki

0 Kudos
DeividA_Intel
Moderator
2,485 Views

Hello Kwaki, 


  

Thank you for the information provided 


  

I will proceed to check the issue internally and post back soon with more details. 


 

Best regards, 

Deivid A.  

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Moderator
2,478 Views

Hello Kwaki, 



In order to continue with the investigation, provide the following information:


1. To confirm, did you notice the issue with the original wireless card?

2. Are you able to replicate the issue while using Ubuntu?

3. You mentioned that the issue started a month ago, prior to that was the unit working bofore? If so, what did you change? What kernel was installed? What firmware was installed?



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Kwaki
Beginner
2,458 Views

Hello Deivid,

 

1. To confirm, did you notice the issue with the original wireless card?
Yes, I can see the same behavior with original wireless card.
On my Raspberry Pi CM4, wifi module from Broadcom is mounted as default and wifi communication is natively available without changing anything.
I first noticed with AX210 then changed back to Broadcom module. Anyway, I don't have the way to disable it for now.

2. Are you able to replicate the issue while using Ubuntu?
I haven't tried with Ubuntu but I think I can prepare the environment.
From my understanding, this depends on whether the wifi module itself has the capability to disable it. If not, that doesn't depend on distribution.

3. You mentioned that the issue started a month ago, prior to that was the unit working bofore? If so, what did you change? What kernel was installed? What firmware was installed?
I'm sorry, this contxt was misleading. I just got all kits and AX210 card one month ago. The issue itself happened from beginning.
I didn't change firmware and kernel code at all but I just changed kernel configuration from "menuconfig" to enable AX210 driver.

 

Best regards,

Kwaki

0 Kudos
DeividA_Intel
Moderator
2,449 Views

Hello Kwaki

 

 

Thanks for the confirmation. In this case, our support on Linux systems is limited since our driver and support are oriented to Windows systems. 

 

Is it possible for your to test with Ubuntu's latest version?

 

 

Regards,  

Deivid A.  

Intel Customer Support Technician  

 

0 Kudos
Kwaki
Beginner
2,433 Views

Hello Deivid,

 

OK, I understand.

I will try on Ubuntu for Linux system environment.

 

Many thanks for following up.

We can close this ticket.

 

Best regards,

Kwaki

0 Kudos
DeividA_Intel
Moderator
2,417 Views

Hello Kwaki, 



Thanks for letting me know that you will try Ubuntu. Remember that if the issue persists with the latest version of Ubuntu you can let me know and I can try to investigate this issue further.


Thanks for your comprehension.



Regards,  

Deivid A.  

Intel Customer Support Technician


0 Kudos
DeividA_Intel
Moderator
2,374 Views

Hello Kwaki,  


 

I reviewed your post, please let me know if the issue was resolved, if not, do not hesitate, just reply back.


  

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Moderator
2,356 Views

Hello Kwaki,  


 

I was checking your thread and see that we have not heard back from you.  


I’m going to close your post, but if you need further assistance, please do not hesitate to create a new thread. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Kwaki
Beginner
2,346 Views

Hello Deivid,

Many thanks for following up.

I can't try further right now, therefore please close this ticket.

I may come back when I get more insight.

 

Thank you again.

Best regards,

0 Kudos
DeividA_Intel
Moderator
2,317 Views

Hello Kwaki, 



Before we finish, I would like you to try the following:


To turn off power saving mode on the AX210 WLAN device, you can consider disabling PCIe ASPM on AX210. A brief introduction to ASPM can be found here: https://wireless.wiki.kernel.org/en/users/documentation/aspm


The section 'Enabling ASPM with setpci' provides steps to look for the Link Control Register of the PCIe device, and provides an example to disable ASPM:


  • # Disables ASPM, enables only L0
  • sudo setpci -s 00:1c.1 0x50.B=0x40
  • (Notes. The ASPM value will be automatically re-enabled after the system reboot.)


If the setpci method doesn't work, please try to access BIOS and disable settings related to 'PCIe power save' or 'PCIe ASPM'



Please let me know if this helps.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Moderator
2,297 Views

Hello Kwaki, 


 

After checking your thread, I would like to know if you need further assistance. 


If so, please let me know. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Moderator
2,218 Views

Hello Kwaki,  


 

I was checking your thread and see that we have not heard back from you.  


I’m going to close your post, but if you need further assistance, please do not hesitate to create a new thread. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Moderator
2,168 Views

Hello Kwaki, 



As the last recommendation, try checking this issue with your operating system distributor for further instructions on this matter. 



Regards,  

Deivid A.  

Intel Customer Support Technician


0 Kudos
Kwaki
Beginner
2,070 Views

Hello Deivid,

 

Thank you for following up.

I need to make sure whether this wifi module is capable to disable power save and also manages IEEE80211_HW_SUPPORTS_PS flag properly. Because this power save is not the case that happens synchronized with system (host chip). I have no idea to make sure of the internal spec of HW so far.

I may buy other wifi PCI card having different vendor's chip and attempt the same approach. Then, I should be able to get further information.

 

Best regards,

0 Kudos
Reply