Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LCarv2
Beginner
1,352 Views

Centrino Advanced-N 6205, PROSet/Wireless insists there are no recognized wireless adapters in system

I like the PROSet/Wireless client software, have used it for almost 7 years (on Dell and ThinkPads).

1. A recent annoyance on my T430s (with Advanced-N 6205 adapter) is that whenever I bring the system

out from standby (sleep), and re-enable the wireless radio via the Lenovo hotkey GUI ... Radio On,

iFrmewrk.exe GUI reports that no wireless network adapters are found in the system.

In this situation, if I change to Windows management of the adapter, it does work.

 

Or, if I then use the nice new handy GUI command: Reset PROSet then wait a couple of minutes for it to complete

 

and restart the software services, that brings the software back to normal operation. But I have to do that every time we wake up and re-enable.

 

It didn't behave like this in the past. Is there a power management setting in the Advanced-N 6205 driver software which causes that behavior ?

2. In recent weeks/months is that although I am running the PROSet/Wireless version 17.1.0 x64 client software

Wireless_17.1.0_s64 ... which has driver version 15.13.0.2 ... when I run the Intel Driver Update Utility (version 2),

it reports my PROSet/Wireless driver version ( 15.13.0.2 ) is out of date, since there is a latest version 15.13.0.1 available.

Today, for "fun" I decided to try letting that be installed; so it eventually was able to download itself and then refused to install,

 

reporting that since version 15.3.0.2 was on the system, there was no way to perform an update.

Then I totally removed/uninstalled the PROSet/Wireless software from my system.

Then I ran the freshly downloaded Wireless_17.1.0_s64 installer again, and got that installed.

Now when I continue using the Intel Driver Update Utility (version 2), it reports

 

my PROSet/Wireless driver version ( 15.13.0.2 ) is out of date, since there is a latest version 15.13.0.1 available.

I think this is a confusing, stuck software update cycle which will never complete in a sensible manner, until you just put it aside.

Thanks ... Larry

0 Kudos
6 Replies
Kevin_M_Intel
Employee
75 Views

Hello LarryC,

Thank you for your feedback regarding the Intel® Driver Update Utility. We have received more feedback from other customers regarding this but all information has been sent to the corresponding department.

In regards the wireless issue, I would like you to try setting to enabled on the Adapter power management this option "Allow the computer to turn off this device to save power"

Here are the steps to do this:

  1. Access Device Manager.
  2. Expand Network Adapters, right-click the adapter, click Properties, click the Power Management tab.
  3. Check the Option "Allow the computer to turn off this device to save power"

Kevin M

BB4
New Contributor II
75 Views

The 17.1 driver has issues waking up in some configurations, no matter what the Power Mgt. settings.

Did you try the 17.12 version driver that Lenovo has up? I'm using it on a ThinkPad and it works fine.

LCarv2
Beginner
75 Views

Hi Kevin, I had tried that setting change too, on the same day I was submitting this thread,

and I do believe that made the main issue go away ... namely the PROSet/Wireless client

no longer gets itself into that state where it insists there are no adapters, and would have to be asked to reset its software stack.

I believe I may have had the power management (main power saving) option disabled, for some time (I don't know how many days or weeks).

So I think this particular complaint is resolved. Let me experiment for another day or so, then I'll come by and mark this as answered.

Thank you! Larry

LCarv2
Beginner
75 Views

Hi GattoNero, I have been running the "latest" software directed to me by the Driver Update Utility.

After reading your post, I visited the following websites,

http://www.intel.com/support/wireless/wlan/sb/cs-008168.htm Intel® Wi-Fi Products — Intel® PROSet/Wireless Software and Hardware Version Compatibility

http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=3316 Intel® Download Center

https://downloadcenter.intel.com/SearchResult.aspx?lang=&ProductID=3316&ProdId=3316 https://downloadcenter.intel.com/SearchResult.aspx?lang=&ProductID=3316&ProdId=3316

which searched for Intel Centrino Advanced-N 6205 driver software,

and that offers me the version 17.1.0 software and drivers for Windows 7,

and clearly indicates that this version is " Latest " ... posted there on 20-Aug-2014.

Then after a bunch of web searches, I located a package, released in September, which appears to

 

include a version 17.12 driver ( unless that really means 17.1.2 ? ).

This page mentions support for the Advanced-N 6205, and also for my ThinkPad model series (T430s).

http://support.lenovo.com/us/en/downloads/ds036007 http://support.lenovo.com/us/en/downloads/ds036007

I think I may try installing that (from the Lenovo site). Thanks!! Larry

LCarv2
Beginner
75 Views

On the matter of PROSet/Wireless software versions, I now believe my installed version

is already at the same driver level as the 17.12.0 package currently referenced by Lenovo.

Right now my installed driver for the Advanced-N 6205 is 15.13.0.2 (dated 22-Jul-2014).

I downloaded the software update (posted 19-Sep on Lenovo's support website) --

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/n14w210w_64.exe http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/n14w210w_64.exe

In the README file,

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/n14w210w.txt http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/n14w210w.txt

it reports the driver version that'll be installed is 15.13.0.2.

Here's the last two versions mentioned in the README.

Driver

for Windows 8.1/8/7 (**)

for Windows 8 (*)

Package for Windows 7 (*) Build ID Rev. Issue Date

------- ------------------------ -------- ---- ----------

17.12.0 17.12.0.4 N14W210W 01 2014/10/28

15.14.0.2

15.13.0.2

------- ------------------------ -------- ---- ----------

17.0.5 17.0.5.8 N14W207W 01 2014/07/07

15.12.0.6

15.11.0.7

So my confusion over software was, in part, from the Driver detection utility informing me that my driver version 15.13.0.2 is out of date.

Thanks; Larry

BB4
New Contributor II
75 Views

Larry, the drivers on Intel's site are not always the most current. They issue new drivers to the OEMs before them put them up here.

That's why I pointed you to Lenovo.

And, the Driver Update Utility is buggy. For now, don't rely on it. Do manual comparisons until they get it sorted out.

See that checkmark? The DUT wants to update my driver to the one on Intel's download list, despite that one being a previous version to the one I'm using.

Finally, with a Lenovo device, you're likely always to see a newer version of a driver there than you will here.