Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
890 Views

Driver installation problem with 82567LF2

Last week my area experienced a very strong set of T-storms. My router WRT-610N and my comcast modem were fried by a surge followed by an outage. When I got a new modem I find my ethernet controller will not work despite me having turned off my comp. It tells me when I try to load drivers that windows is unable to load drivers Code 31. When I try to load drivers I get an incorrect parameters error. It says I have driver version 10.0.2.2 there now.

I tried using a USB adapter and Windows will not recognize it.

I have installed drivers from Intels site, I have installed and reinstalled proset software to no avail. I have tried updating drivers from a disc and still no luck.

Does anybody have some info as to how to proceed or something?

This is very frustrating.

Tags (2)
0 Kudos
1 Reply
Highlighted
Community Manager
12 Views

Well I figured it out. I am really surprised at the severe lack of community effort. I always thought Intel was better than that. I guess I was wrong.

0 Kudos