Issues related to Intel® Wireless Adapters and technologies
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6087 Discussions

I want to connect to a specific AP, but all use the same SSID


Please forgive my errors and just tell how to do better.

I am trying to connect to Internet over one of several WiFi APs that all have the same SSID. I am told that some work and some are terrible. That seems to be correct. They have distinct MAC addresses (BSSID). Is there a way to use my AC-7260 to connect using the MAC address, or any 'best way' that I can connect to a specific AP?

Name: Intel(R) Dual Band Wireless-AC 7260

Device ID: PCI\VEN_8086&DEV_08B1&SUBSYS_44708086&REV_BB\4&4D3057A&0&00E2

Driver: C:\WINDOWS\system32\DRIVERS\Netwbw02.sys, 18.33.0012.0002 (English), 2/6/2018 08:57:58, 3521512 bytes

Driver: C:\WINDOWS\system32\DRIVERS\Netwfw02.dat, 2/6/2018 08:57:58, 10719648 bytes

I am using a Dell, M4800 laptop and this Intel AC 7260 came with it. Windows 10 Pro x64. V1709, Build 16299.371

Processor:"Intel(R) Core(TM) i7-4810MQ CPU @ 2.80GHz , GenuineIntel"

I ran the # SSU Scan Information if you want some of that info.




0 Kudos
2 Replies
Community Manager

Hello SaltyDave,

We understand you're connecting to a network made up of multiple wireless APs. Some APs which work well for you, while others that don't. Because of this, you would like to configure your computer to connect to an specific AP only.

This is a bit counterintuitive, as the point of broadcasting the same SSID throughout all the available access points is to allow clients to roam from one to the next without having to connect using a different wireless profile. At this time, we don't have a recommended method to filter single SSID APs by MAC address in Windows® 10.

Perhaps your network administrator will need to look into why some APs work and the others are terrible. A common pitfall is setting up neighboring APs to broadcast using the same wireless channels. You don't want the same channels on APs right next to each other. Your computer may mistakenly send half the packets to one AP and the other half to a second AP, causing problems.

As a workaround, we can recommend lowering your wireless adapter roaming aggressiveness through Device Manager. Either "1. Lowest" or "2. Medium-Low," may work best in this scenario. More info: https://www.intel.com/content/www/us/en/support/articles/000005546/network-and-i-o/wireless-networki... Wi-Fi Roaming Aggressiveness.

For further setting recommendations, please share your Intel® SSU report.

Best regards,


Carlos A.
Community Manager

Hello SaltyDave,



We haven't heard back from you. Has your question been answered? Let us know if there's anything else we can help you with.



Best regards,


Carlos A.