Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7658 Discussions

Intel AX200 bluetooth won't work on Linux

kapa
Beginner
3,380 Views

Hi,

I purchased a PCIE AX200 Wifi6 and Bluetooth adapter for my notebook (Asus Zenbook 14 OLED) as the WiFi performance of the factory delivered adapter of another manufaturer was not that good.

With AX200, Wifi was working out of the box, but the bluetooth device was not recognized at all. 


Since I have a dual boot set up, I booted into Windows 11 and wifi worked out of the box too, however the bluetooth adapter was not recognized, but after intalling Intel PROSet drives it was working! 

Conclusion: no hardware problem as such.

Then I disabled fast boot in BIOS and shut down the notebook. After a cold boot I could see the Bluetooth adapter in Linux dmesg, but the system fails to initialize it:

dmesg | grep Blue
[    9.205446] Bluetooth: Core ver 2.22
[    9.205474] Bluetooth: HCI device and connection manager initialized
[    9.205479] Bluetooth: HCI socket layer initialized
[    9.205482] Bluetooth: L2CAP socket layer initialized
[    9.205488] Bluetooth: SCO socket layer initialized
[    9.279965] Bluetooth: hci0: Bootloader revision 0.3 build 0 week 24 2017
[    9.281972] Bluetooth: hci0: Device revision is 1
[    9.281977] Bluetooth: hci0: Secure boot is enabled
[    9.281980] Bluetooth: hci0: OTP lock is enabled
[    9.281982] Bluetooth: hci0: API lock is enabled
[    9.281985] Bluetooth: hci0: Debug lock is disabled
[    9.281987] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    9.310291] Bluetooth: hci0: Found device firmware: intel/ibt-20-1-3.sfi
[    9.310300] Bluetooth: hci0: Boot Address: 0x24800
[    9.310302] Bluetooth: hci0: Firmware Version: 132-3.24
[    9.614685] Bluetooth: hci0: Failed to send firmware data (-19)
[    9.614724] Bluetooth: hci0: sending frame failed (-19)
[    9.614737] Bluetooth: hci0: FW download error recovery failed (-19)
[    9.614776] Bluetooth: hci0: sending frame failed (-19)
[    9.614786] Bluetooth: hci0: Reading supported features failed (-19)
[    9.614789] Bluetooth: hci0: Error reading debug features
[    9.614793] Bluetooth: hci0: HCI LE Coded PHY feature bit is set, but its usage is not supported.
[    9.614803] Bluetooth: hci0: sending frame failed (-19)
[    9.614812] Bluetooth: hci0: Failed to read MSFT supported features (-19)
[   10.175761] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   10.175768] Bluetooth: BNEP filters: protocol multicast
[   10.175774] Bluetooth: BNEP socket layer initialized


I am running Fedora 40 with kernel 6.8.8, also compiled tried 6.9 and 6.1.9 myself to see if it helps. Also tried Manjaro 240513 with kernel 6.9

Correspondingly hcitool, rfkill commands don't show anything and  /sys/class/bluetooth is an empty directory.

I could not find any info on which kernel it was supposed to work and why loading the firmware fails. I have tried different linux-firmware versions too, from latest Fedora to latest from kernel.org, just the (-19) code changes to (-22).

If I insert a USB bluetooh dongle, it works immediately, but not the AX200 bluetooth module, please help figuring out what can be done.

Best regards,

Kapa 

 

# inxi -E
Bluetooth:
  Message: No bluetooth data found.

# hcitool  dev
Devices:

# rfkill list
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
0 Kudos
25 Replies
kapa
Beginner
882 Views

Hi Caguicla,

great to hear back from you!

Please find the command outputs in the attached logs.tar.gz archive:

87713 Jun 18 10:41 dmesg.txt
0 Jun 18 10:40 hciconfig.txt
28987 Jun 18 10:40 lshw.txt
406 Jun 18 10:40 lsusb.txt

Note, that the output of the hciconfig is empty.

I understand there my be compatibility issues, but I need to know it for sure.
The AX200 adapter fully works in Windows (WiFi + Bluetooth) and there are numerous reports of
broken functionality of Bluetooth in Linix for the AX200.

If there is a regression, since you suggest to try an older kernel - do you happen to know which version is known to work with AX200?

I will try the USB tweaks and come back to you.


Best regards,
kapa

0 Kudos
kapa
Beginner
336 Views

I aplogize, I forgot to take out the USB bluetooth dongle, so there are new dmesg and lshw outputs.

Hciconfig and lsusb are same.


0 Kudos
kapa
Beginner
322 Views

Hi,

just a quick update:

- disabling USB 3.0 or to EHCI in BIOS is not possible (no such options in BIOS)

- changing power / autosuspend mod did not help too

As far as I understand, the kernel module btintel detects a supported device, loads a firmware to it and waits until it comes up with the firmware.

I see a disconnect of USB device 3-3 in dmesg, and later a timeout from the btintel module. So the device does not come up and is not detected anymore with lsusb. 

So, the firmware download from btintel module kinda wrecks the USB device until a cold start.

Disabling USB power / autosuspend does not help, as the device is not avaialable.

One remaining thing is tryin to get it running with an older kernel, but which one?

0 Kudos
Caguicla_Intel
Moderator
305 Views

Hi kapa,

 

I will pass on your response to our engineering team. Please await my update before we continue with this request.

 

Best regards,

 

Caguicla C.

Intel® Customer Support Technician


0 Kudos
Caguicla_Intel
Moderator
242 Views

Hi kapa,

 

Upon reviewing the provided logs and running hciconfig, it appears that no details regarding the Bluetooth (BT) adapter are present. Similarly, lsusb does not yield any information about the BT device. This suggests that the adapter may not be recognized by the system. To address this, I recommend verifying the adapter's compatibility and ensuring it has been integrated correctly. Please contact your system manufacturer for further assistance with these checks.

 

Regarding your inquiry about older kernel versions, it may be beneficial to seek advice from the Linux community forums. The members there often have a wealth of knowledge and experience and may be able to offer practical workarounds for your situation.

 

Best regards,

 

Caguicla C.

Intel® Customer Support Technician


0 Kudos
Reply