Showing results for 
Search instead for 
Did you mean: 

Intel Centrino N2230 with Windows 8.1 STILL not playing nice. Rampant connection issues.

Hey there, you've undoubtedly been getting a lot of these over the last 9 to 10 months, but any info is good info so I'm going to add my system details and what remedies I've tried so far that have all failed. First, my relevant system specs:

- Intel Core 15-3570K CPU

- Gigabyte GA-H77N-WIFI motherboard

- nVidia GeForce GTX 770 GPU

- Intel Centrino N2230 Mini-PCIe card (with stock antenna setup)

- - with most recent driver installed,, (checked against auto-updater)

- Running Windows 8.1 with most (if not all) recent updates

- ASUS N900 802.11N Router

- - with most recent firmware updates.

- - using WPA2/AES encryption

I actually own two computers with the exact same Mini-PCIe card in it. My second computer is the Wacom Cintiq Companion 256GB edition. It, too, has the N2230 inside running Windows 8.1, and is suffering the EXACT same issues as my desktop machine and as you've likely read elsewhere by other people. When my connection is working (on either machine) it's slow. Nominally I should be getting close to 30mbps download and 8 to 10 mbps upload. Under Windows 8.1, speeds are around 0.50 to 1.50 mbps down to 0.25 to 1 mbps up. My phone, a Nexus 5, gets my full network speed when tested right next to these computers on the same wifi network. It's worth noting that even when I have connection to the internet, logging into the GUI to my wireless router is painfully slow. So these slow network speeds aren't just the internet -- the very network connection itself is crawling as it struggles to even communicate with my local router. Full disconnections happen anywhere from as little as 3 minutes into computer usage to one to two hours after the system has been running. The "Limited" warning doesn't always appear when the connection is dropped like a mic by my computers in these cases reconnection can only occur by disconnecting/connecting from the network, disabling/enabling the adapter, or restarting the computer. Kind of like getting an old NES to work, blowing in the cartridge, whamming on the reset button...

Other things I've tried, all of which didn't make a difference:

- Setting my router's wifi channels to a set number instead of Auto

- Disabling B/G wireless signal protection

- Using the latest drivers


- Using older drivers

- Reinstalling current drivers


- Disabling power management for the adapter


- Setting specific public DNS server addresses (for both IPv4 and IPv6)

- Running the various command line "fixes" (disabling heuristics, setting log, those other 2 or 3 plastered on lots of blogs)

- Reformatting my system and starting over from scratch (albeit with Windows 8.1 as it's all I have)

If anyone knows of any particular things that I haven't done that you'd know would work, I'm all ears. If not, you can add my story to the pile, Intel. Let me know if you need any additional information.

0 Kudos
1 Reply

Hi fox-orian,

I am sorry you are having problems with the system but let me help you.

I see you have done many steps and all the post is very informative but I would like you to check some more information.

  1. How far are you from the router?
  2. Have you tested a different router or maybe a hotspot?
  3. Is there any way to test different antennas?
  4. Can you try updating the BIOS of your systems?

Kevin m