Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MPort6
Beginner
1,604 Views

Intel Centrino Ultimate 6300-N AGN Broken

First off, I'd like to thank Intel for giving me this W740SU ultrabook 2 years ago at a raffle at the Seattle HQ (during an Iris Pro demonstration), it's served me well, and I've appreciated it more than anyone else who could have possibly won the raffle - so a huge thank you, sincerely. On to the issue:

As I said, I'm using an W740SU CyberPowerPC ultrabook, which I got directly at an Intel office, so I expect the device is supported (har har)! I have a Intel Centrino Ultimate 6300-N AGN network adapter, and it's completely, utterly, 99.99% broken with Windows 10 on this device. I'm always "connected", but my speed is 0-1Mbps, rarely more than that, on a 25Mbps connection. I've tried:

  • Testing other devices in the house to isolate the issue to my device.
  • Changing the channel on my gateway
  • Uninstalling the device
  • Updating Drivers
  • Rolling back to various drivers from the most recent, to 2013.
  • Deleting the driver, and manually installing drivers.
  • Much more, that I simply can't remember right now.

That being said, nothing has worked. Directly wired works, using my TP-Link USB adapter works perfectly, but my natural adapter (Intel Centrino Ultimate 6300-N AGN) is just not working. I've seen various canned responses that this device isn't "officially" supported on Windows 10, but I don't find that an acceptable response, as operating systems move forward, and modern technology that isn't depreciated (this adapter for instance) should be supported, one way or another.

I don't care what I need to install, or from who (Microsoft, Intel, 3rd party, etc), but I would really appreciate an official, working response to this issue. As I said, I won this laptop from Intel, Intel gave this to me, it has Intel hardware, I expect it to be Intel compatible. Thanks a lot of taking the time to read, and please let me know if you have any further questions.

Tags (1)
0 Kudos
4 Replies
ASouz7
Honored Contributor II
128 Views

Gemfruit,

The Intel® Centrino® Ultimate-N 6300 is supported by Windows*10 inbox driver version (15.16.0.2). We don't have any recent driver release for this adapter and for the time being, we don't have any information whether this will change in the future. However, here is what you can do to improve connectivity.

http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-034658.htm Intel® Wi-Fi Products — Quick Checks That Might Improve or Fix Connection Issues

http://www.intel.com/support/wireless/sb/CS-029893.htm Wireless Networking — Frequently Asked Questions - Wi-Fi

You can also do the following:

1 - On Device Manager >> Network Adapters >> Intel® Centrino® Ultimate-N 6300, right click on it, select properties and then from the Advanced Tab, set the 802.11n Channel Widith for 2.4GHz to limit 20MHz.

2 - Check the value of Transmit Power and make sure it is set to 5. Highest.

3 - Disable Power Saving Functions: Control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply to default settings.

4 - Change the Power Plan settings and make sure it is set to Maximum performance on both battery and plugged in.

5 - Check if router is running the latest firmware as well.

MPort6
Beginner
128 Views

Odd that you list 15.16.02 as the supported drivers, as Windows automatically updates to 15.18.01, from 4/30/2015, VS yours at 1/6/15.

  1. My 802.11n channel width had "auto" and 20MHz, I made sure they were both 20MHz (one was auto, the other was 20MHz already).
  2. Check
  3. Check
  4. Check
  5. Check

I have manually set the driver back to your recommended 15.16.02, and checked the above, and I'm seeing no difference. The first link in your links above suggests setting both bands to auto, not 20MHz only - were you suggesting the opposite of that link, or am I confused? I'll note that I only have 2.4GHz, not 5. Is there anything else anyone can think of, as these changes haven't fixed the issue.

 

 

ASouz7
Honored Contributor II
128 Views

Gemfruit,

We understand your frustration but, at this point, it is important at this point that ou check with your computer manufacturer: http://www.intel.com/support/oems.htm Computer Manufacturer Support and Microsoft*:http://windows.microsoft.com/en-us/windows-10/support Need help with Windows 10? - Get answers to your questions here. to see if they have any available updates that might help resolve the issue. As we have previously informed, we don't have drivers for this adapter on Windows*10 and for the time being, there is no information whether this will change in the future. Answering your question, we aoplogize if it was not that clear. The idea was for you to try with both if applicable.

MPort6
Beginner
128 Views

I've contacted CyberPowerPC about the issue, and will report back with any findings (good or bad).