Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PBuss
Novice
1,678 Views

Intel Centrino Wireless-N-2200 keeps going to No Internet or Limited

I have a Toshiba laptop that has this chipset in it for wireless. (Satellite P875-S7310)

With Windows 8, going into the Adapter Settings and turning off N mode (802.11n) solved a lot of issues.

Since upgrading to Windows 8.1, it keeps dropping out, trying to connect to other networks other than my own and sits and spins when I have to try going back to mine. Router is a Linksys E3200 I have gone into the network adapter settings and again disabled the N mode.

Problems persist (knocked offline, limited internet...)

Did the Intel Update service and allowed it to update to newest drivers. No change

Noticed on here the suggestion to go into Device Manager , select the Wifi and update the driver. When I do so, it auto detects 7 drivers that all read Intel Centrino Wireless-N-2200 (which one?)

What else can I do to make this thing stable? When it drops the connection and I have to re-join, I get the "Windows is taking longer than expected..." then finally does, with no internet or limited.

Laptop is 22 feet away from router. Again, this all worked fine in 8 by disabled 802.11n mode

Thanks

0 Kudos
5 Replies
Jose_H_Intel1
Employee
82 Views

The difference here could be related to the fact that we do not have a driver for Windows* 8.1 at this time. Perhaps using Microsoft* driver may give different results.

PBuss
Novice
82 Views

Joe,

I went into

Computer Management

Device Manager > Network Adapters > Right Click on Intel Centrino card > Update Driver

Browse My Computer for Device Drivers > Let Me Pick

I had many drivers that had (Intel) at the end and one with (Microsoft)

I will try that for a while and see what happens.

DDiso
Beginner
82 Views

Here is what I had to do on a Lenovo T430 with Centrino Wireless-N 2200 adapter and Windows 8.1 x64:

Since my laptop has BIOS options for WiMAX and Wireless WAN, I entered the BIOS and went to Security and the I/O Port Access and disabled the WiMAX and Wireless WAN options as I do not use either.

Go to System screen and choose Device Manager

Right click on the Centrino Wireless-N 2200 and choose Update Driver Software

Click on Browse my Computer for driver software

Click Let me pick from a list of devices...

Select the Intel Centrino Wireless-N 2200 (Microsoft) entry and follow screen to complete install

Right click on the Wireless-N 2200 adapter again and choose Properties

Verify driver (after all Windows updates)

Provider: Microsoft

Date: 6/25/2013

Version: 15.10.0.12

Click on the Advanced tab

Select 802.11 n Mode and set to Disabled

Select Ad Hoc QoS Mode and set to WMM Enabled

Select Wireless Mode and verify it is set to 3. 802.11b/g

Click on the Power Management Tab and uncheck box Allow the computer to turn off device...

Where this is a development machine, I also adjusted the power settings as it is connected to a docking station and on all the time.

Wireless Adapter Settings set to Max Performance for Both

Sleep settings all set to Never for all sub components

PCI Express - Link state setting both set to Off.

Hope this might help your case but I have had no other issues on my Lenovo.

cwang72
Beginner
82 Views

But I can't see 802.11n Mode in advanced tab. I'm using intel dual band wireless-ac 7260, windows 8.1, and updated to the latest version driver.

Jose_H_Intel1
Employee
82 Views

Chongzhao, I already replied in the new thread you created, here: /thread/46589 https://communities.intel.com/thread/46589