Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JJopp1
Beginner
1,657 Views

Intel Dual Band Wireless-N 7260 only a/b/g mode

Jump to solution

Hi,

I have an Inspiron 7537 with Intel(R) Dual Band Wireless-N 7260. The problem is that the card only works in 802.11g. I have a 802.11n capable router and every other device connects in 802.11n speed.

My speed is capped to 54Mbps. In the driver's advanced panel I have HT mode enabled and I can only select between 802.11a/b/g modes.

I really can't understand why this card should work like that. I just want, in 2014, 802.11n connection.

What do?

netsh wlan>show interfaces

There is 1 interface on the system:

Name : Wireless Network Connection

Description : Intel(R) Dual Band Wireless-N 7260

GUID : 83f6b880-2b75-49fd-a7af-3709dc8e2978

Physical address : censored

State : connected

SSID : JoppenetN

BSSID : censored

Network type : Infrastructure

Radio type : 802.11g

Authentication : WPA2-Personal

Cipher : CCMP

Connection mode : Auto Connect

Channel : 9

Receive rate (Mbps) : 26

Transmit rate (Mbps) : 26

Signal : 86%

Profile : JoppenetN

Hosted network status : Not started

0 Kudos
1 Solution
tvete
Valued Contributor II
306 Views

Is HT mode enabled? Also follow these router and adapter settings from Intel:

http://www.intel.com/support/wireless/sb/CS-030709.htm Wireless Networking — What are the recommended settings for 802.11n connectivity?

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm Intel WiFi Products — Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured

Finally on your Router QoS settings, make sure WMM is enabled.

View solution in original post

2 Replies
tvete
Valued Contributor II
307 Views

Is HT mode enabled? Also follow these router and adapter settings from Intel:

http://www.intel.com/support/wireless/sb/CS-030709.htm Wireless Networking — What are the recommended settings for 802.11n connectivity?

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm Intel WiFi Products — Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured

Finally on your Router QoS settings, make sure WMM is enabled.

View solution in original post

JJopp1
Beginner
306 Views

I had to enable WMM in router's QoS settings. I don't understand why this is necessary and I'd like to disable WMM, but it is the only way to make it work.

All the other settings were correct.

Thank you kind sir!

Reply