Community
cancel
Showing results for 
Search instead for 
Did you mean: 
bfris1
Beginner
510 Views

Intel NUC8i7HVK Internet Connectivity Issues

I purchased the Hades Canyon less than 1 week ago and the #1 thing that stands out is the connectivity issues. I have both wired and wireless connections into my Google router. All basic diagnostics I've run show that everything is "healthy" but throughout the day it simply fails to not load web pages, or "Can't connect to server messages". After a few minutes I can retry and the web page might load. I also get very slow download speeds. I have 90mbs connection usually and it has taken well over 10 minutes to download a 1gb file where on other devices that might take half of the time.

 

Attached is the system support utility report. Thank you!

 

 

0 Kudos
5 Replies
AlHill
Super User
53 Views

You have a Hades Canyon nuc.

 

Same issue reported here: https://forums.intel.com/s/question/0D50P00004IyUqrSAF/intel-8265-dual-band-wireless-lan-speed-is-sl...

 

You may want to join that thread.

 

Doc

 

bfris1
Beginner
53 Views

Thank you sir. However, after reading that post I think my issue is slightly different. My internet speeds are the same across devices (including the NUC), but the NUC fails load webpages occassionally.

Oscar_A_Intel1
Employee
53 Views

Hello Bfris1, Thank you for posting on the Intel Community. Do you still need further assistance? I see that your NUC is having some issue loading some websites occasionally. I see you're some BIOS versions behind the latest one. Try updating the BIOS to the latest version, here's the download link: https://downloadcenter.intel.com/download/28642?product=126143 Please check this link that will show you how to update the BIOS by pressing F7. https://www.intel.com/content/www/us/en/support/articles/000005850/mini-pcs.html Also, do you have the same issue with other devices such as laptops, cellphones or other devices connected to the same network? Try connecting the NUC to a different network and check if you're having the same issue. Regards, Oscar A. Intel Customer Support Technician Under Contract to Intel Corporation
bfris1
Beginner
53 Views

Hi Oscar,

 

The link you sent me for the Bios update was for a different NUC model. Are you sure that is the correct one?

 

According to my Intel Driver & Support Assistant the latest BIOS version is 0054. Which is the same version I am on.

 

Thanks

LeonWaksman
Super User
53 Views

Hi @bfris1​ ,

  1. You are right and Oscar is wrong. You have the latest bios installed (i.e. 0054). The link, Oscar send is for NUC6i7KYK.
  2. Try to reset your router. Disconnect the Power Cable from the router and reconnect it after 1 minute waiting.
  3. Clear browsing data in you Internet Browser.
  4. Ask the Internet Provider to check the connection.
  5. Try to work only with one connection at time (i.e. only cable or only WiFi).

 

Leon