Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,624 Views

Intel(R) Dual Band Wireless-AC 7260 slow and unstable connection

My connection seems to be really slow and occasionally completely drops for 5-10 mins.

My wired connection is around 45-50 Mbps download and wireless around 20-30 Mbps (with other laptops)

What did I try?

  • Update driver + utilities (Wireless PROset)
  • Enhanced advanced config for my 2.4Ghz router
    • 802.11n Channel Width for 2.4Ghz: 20MHz only
    • HT Mode: VHT Mode
    • Preferred Band: Prefer 2.4Ghz Band
    • Roaming Aggressiveness: 1. Lowest
    • Transmit Power: Highest
  • Set Advanced Power Plan to Highest Performance
  • Bluetooth is disabled

I will attach my Intel report that has been made by the support utility.

After this, I have tried to uninstall my driver, so my OEM version is installed again. This, however, did also not work.

Hope fully somebody can asist me.

With kind regards,

Nkmol

0 Kudos
7 Replies
Highlighted
New Contributor I
53 Views

First of all, I'd try to:

  1. set "HT mode" to "HT"
  2. set "Channel width" to "Auto"
0 Kudos
Highlighted
Beginner
53 Views

I have tried different settings (and the ones you suggested), but it seems to have zero effect on my Mbps. It always stays the same.

0 Kudos
Highlighted
Beginner
53 Views

I have also tried to set my router to 802.11n with the WPA2-PSK (AES) security (as suggested for this protocol), where I have used the http://www.intel.nl/content/www/nl/nl/support/network-and-i-o/wireless-networking/000005544.html suggested settings for the n-protocol, but this also gives exactly the same speed.

The router is running on 802.11g as default (this runs best with my other devices).

0 Kudos
Highlighted
Community Manager
53 Views

Hello Nkmol,

 

 

We checked the SSU log you provided and the configuration is OK, we see that you already tried disabling Bluetooth* and the changes mentioned by rockit did not make a difference either, so we will need to consider other options.

 

 

The log shows Signal Strength: 80%. Please check the following items:

 

 

- Try placing the PC closer to the access point.

 

- Check if the issue happens with other Wireless Networks.

 

- Try using a different wireless channel (currently using channel 1). You might want to check with the access point manufacturer about how to perform this in your network.

 

 

Also, let us know the following information:

 

 

- Was this working fine before?

 

- Was the 7260 built from factory with your PC?

 

- Does the computer show connectivity issues in other networks?

 

 

Regards,

 

Jonathan B.
0 Kudos
Highlighted
Beginner
53 Views

Getting closer to the router seems to work (Stupid I did not test this first).

However, other devices (laptop and phone) shows higher Mbps at when I am further away, where the AC 7260 shows slow speed.

When I move 2-4 meters away, with 1 wall in between: I immediately notice a drop in speed

Is there any setting that could be responsible for this behavior?

To answer you questions.

Was this working fine before?

Yes, it used to work before. But I had trouble with my laptop speed, so I made a clean Windows 10 Install.

I made sure to update the driver according to the OEM drivers, that were on the manufactures website.

Try using a different wireless channel (currently using channel 1).

I tried channel 6 and 10, but neither do have any effect on my speed.

 

Was the 7260 built from factory with your PC?

Yes

Does the computer show connectivity issues in other networks?

At this moment I do not have access to any other network and I do not trust this laptop enough to bring it to work

 

But it seems it has trouble to connect through obstacles, even though 2,4Ghz should really work with this.

I am no expert, but could it be it is actually using 5Ghz? (802.11g should not support this, right?)

Thanks for your time!

0 Kudos
Highlighted
Community Manager
53 Views

Hello Nkmol,

 

 

Considering that you tried different actions and the connection is affected when the PC is moved away from the access point; this suggests that the issue is related to the signal strength. You already performed different configuration changes that normally help, so this may be due to the PC hardware, access point, or environmental interference.

 

Here are the options we consider relevant at this point:

 

 

- Check with the Access Point manufacturer (or provider) and make sure you are using the latest firmware for it. We've had cases where older access points do not communicate well with 802.11ac adapters.

 

- Have you checked if other devices get a better speed in the same location where the PC has issues?

 

- Check for possible sources of interference remove them if possible (power lines, microwaves, other wireless devices, etc.)

 

- Contact the http://www.intel.com/content/www/us/en/support/topics/OEMs.html Computer Manufacturer Support or their service provider, make sure the antennas are properly plugged to the wireless adapter and check with them for other hardware issues in the computer.

 

 

To answer your last question, you are correct, 2.4 GHz should have a longer range, however, the 5 GHz frequency is less crowded so it receives a lot less interference.

 

 

Regards,

 

Jonathan B.
0 Kudos
Highlighted
Community Manager
53 Views

Hello Nkmol,

 

 

We hope our last recommendations helped. Feel free to contact us if you require further assistance.

 

 

Regards,

 

Jonathan B.
0 Kudos