Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NSfan
Novice
2,280 Views

Intel(R) PRO/Wireless 3945ABG - Slow performance

Jump to solution

Dear friends,

I need your help on the following issue.

I am a windows 7 user and have the above mentioned wireless adapter on my laptop.

When I connect my laptop directly onto the router I get the maximum of the speed provided by local internet company, up to 50mbps.

However, each time I go back to the normal situation ( direct connection not practically available ) and use the wireless connection

then always the performance speed achieved is less by 50% from the cable connection on the router.

Can you please provide me with information regarding this experience and potential actions I should take in order for the problem be resolved?

Please note that the internet equipment , router and computer are located in the same open space room - no walls or other floors -

so this is the reason I cannot explain the results on the speed performance.

Many thanks for your help,

best regards,

Nikolas

Tags (1)
1 Solution
jbenavides
Honored Contributor II
818 Views

Hello nikolas@athens,

The speed you can get with a wireless connection is normally lower than the one you get with an Ethernet one. This can be even lower depending on the type of Wireless network, and the environmental conditions.

We would like to mention that the Intel® PRO/Wireless 3945ABG Network Connection has reached end of support so the options available for this adapter are very limited.

Here are some actions that can help you improve your wireless connectivity:

- Make sure you are using the latest driver for your wireless adapter, Version: 15.3.1 from 11/2012:

https://downloadcenter.intel.com/download/22116/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo... Download Intel® PROSet/Wireless Software and Drivers for Windows 7*

- Apply the configuration from the following advisory (some settings may not be available in legacy adapters): http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html?wa... Recommended Settings for 802.11n Connectivity

 

- Disable Bluetooth* in you PC. This is normally done with a switch in the chassis of the PC, or with a keyboard combination.

- Check the Power options of you laptop, in the Advanced Settings for your Power Plan, then make sure that the Wireless Adapter is set to work at "Maximum Performance" when plugged in and on battery.

View solution in original post

6 Replies
jbenavides
Honored Contributor II
819 Views

Hello nikolas@athens,

The speed you can get with a wireless connection is normally lower than the one you get with an Ethernet one. This can be even lower depending on the type of Wireless network, and the environmental conditions.

We would like to mention that the Intel® PRO/Wireless 3945ABG Network Connection has reached end of support so the options available for this adapter are very limited.

Here are some actions that can help you improve your wireless connectivity:

- Make sure you are using the latest driver for your wireless adapter, Version: 15.3.1 from 11/2012:

https://downloadcenter.intel.com/download/22116/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo... Download Intel® PROSet/Wireless Software and Drivers for Windows 7*

- Apply the configuration from the following advisory (some settings may not be available in legacy adapters): http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html?wa... Recommended Settings for 802.11n Connectivity

 

- Disable Bluetooth* in you PC. This is normally done with a switch in the chassis of the PC, or with a keyboard combination.

- Check the Power options of you laptop, in the Advanced Settings for your Power Plan, then make sure that the Wireless Adapter is set to work at "Maximum Performance" when plugged in and on battery.

View solution in original post

NSfan
Novice
818 Views

Hello Jonathan,

Thank you very much for your detail reply.

I'll try some of the actions you suggested me and I'll keep you posted of the outcome.

Best regards,

Nikolas

NSfan
Novice
818 Views

Hello Jonathan,

I've taken all the actions you recommended regarding the wireless adapter issue ( driver, s/w update - settings ) and finally I see no change

on the speed. The result remain 50% lower than the ethernet connection.

I would like to hear your opinion based on your knowledge regarding an external wireless usb connection which bybass the existing adapter of the

laptop? Do you believe that could be a solution ?

Thank you,

Nikolas

jbenavides
Honored Contributor II
818 Views

Hello Nikolas,

Keep in mind that the http://www.intel.com/content/www/us/en/wireless-products/pro-wireless-3945abg-network-connection-bri... Intel® PRO/Wireless 3945ABG Network Connection is a legacy adapter that operates in 802.11a/b/g, with a maximum data rate of 54 Mbps. However, this is theoretical and is normally lower due to network overhead, wireless interference, access point configuration, etc.

You may try using a different Wireless channel and check if this helps, this is done in the access point so you may check with the AP manufacturer for more details.

Using a different Wireless Adapter could be an option, especially if your network is 802.11n, or 802.11ac. Since the 3945 is limited to abg connections.

NSfan
Novice
818 Views

Dear Jonathan,

Thank you very much for your support.

Best regards,

Nikolas

jbenavides
Honored Contributor II
818 Views

We are glad to help. Feel free to let us know if you require any further assistance.

Reply