Issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6550 Discussions

Intel-i7 Gen 11 Bluetooth issues

New Contributor I

On my Dell XPS-13 2-in-1 I experience Bluetooth issues when using my mouse.

When using the mouse after a few seconds of inactivity, it skips a few beets. This means the pointer will 'jump' a few centimeters.

It looks like the mouse does send the signal but the signal is only interpreted a tiny moment later. This behavior makes a Bluetooth mouse virtually unusable.

Actions to reproduce:

  • Hook up a Bluetooth mouse.
  • Hold it still for a few moments.
  • Move it, you should see it 'jump'.

Source of the problem:

  • Tested two different mice, one Microsoft and one Logitech
  • Tested the mice on different laptops computers

The problem consequently occurs on the Dell with this hardware and the same mice show no problems on any other computer. I don't have another computer (yet) with an Intel i7 Gen11 to test.

1 Solution


There is a working resolution to this, apparently common, issue. Found it on Dell forum - Solved: XPS 9310 - Bluetooth lag with Logitech MX Keys + MX Master 3 - Page 19 - Dell Community

* Click Windows icon (start)
* Type regedit
* Right click regedit
* Click Run as administrator
* Navigate to =
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_8087&PID_0026\5&ed1e05a&0&10\Device Parameters]

It worked for me on MSI Prestige 14 Evo with i7-1185. A welcome relief after months of nothing from official MSI support.

View solution in original post

91 Replies

Hello peter_hendrix


Thank you for posting on the Intel️® communities. 


If this only happens with Bluetooth devices, we'll have to check the information from your computer and the wireless card. Please share with us the following information:


  • What's the model of the wireless card?
  • Do you get issues with the Wifi, only Bluetooth or both?
  • When did it start to happen?
  • Do you remember if this issue happened after a new OS update or a driver update?
  • Is this a new computer?
  • What operating system version are you using?
  • Is this the original adapter that came pre-installed in your system, or did you change/install a new adapter recently?
  • Have you installed any recent software or hardware in your system?
  • Have tried rolling back to a previous driver version for testing?


I will send you an e-mail to the e-mail address associated with your community profile requesting some reports that may contain sensitive information. 



David G 

Intel Customer Support Technician 



New Contributor I
  1. Intel Wireless Bluetooth, Killer® Wi-Fi 6 AX1650s 160MHz Wireless Network Adapter (201D2W).
  2. Only issues with Bluetooth.
  3. It happened right from the start since I got the laptop.
  4. The issue was always present.
  5. A brand-new Dell-XPS13 2-in-1 (32GB/1TB/i7-gen11)
  6. Windows 10 Pro 64-bit version 20H2 (build 19042.804)
  7. It is the original adapter.
  8. No software hardware changes have influenced the behavior.
  9. I have the latest driver installed from 1/22/2021 version, didn't make any difference with the previous one.

SSU-tool has bee executed and the results have been sent via mail.


Hello peter_hendrix


Thank you for your response, we recommend that you test the drivers from the manufacturer directly. This is because they include some customizations that could resolve your problem. You can try their latest version, downloaded from Dell's website directly. We recommend that you try a Clean Installation of Wireless Drivers:



David G 

Intel Customer Support Technician 



Hello peter_hendrix

Did you test the previous steps?  

Let us know if you still need assistance.   


Best regards,  

David G.   

Intel Customer Support Technician  

New Contributor I

I experience the same thing.  I use a Logitech MX Anywhere 2S mouse and MX Keys keyboard with two different laptops.  One is an HP Spectre x360 (10th gen) and the other is an HP Envy x360 (11th gen) and only on the 11th gen do I have these problems.  It was occurring when I first got the laptop (beginning of January of this year) and even when I updated to the latest drivers from Intel's site.  Nothing has helped.  There are numerous messages on many different forums (HP, Dell, Asus, Lenovo) of users complaining of the same issue.  This appears to be a Tiger Lake issue because it doesn't occur on my 10th gen laptop.  It's really frustrating that nobody can figure this out.

New Contributor I
Hi Jeff03,

To be honest, Intel has been actively following up on my issues so that is possitive. The downside is that there is no solution yet.
It is helpfull that you posted your experience, that indicates that it's not my setup.
Hopefully Intel can fix it via driverupdates.

HP Tech support said the Bluetooth Mouse is the problem, and not the New HP spectra x360 Convertible 14t laptop that I just bought. The problem I am having is, the laptop internal Bluetooth receiver wants to go to sleep or something. It takes a half a second to respond when moving the mouse. "It lags". Once it’s awake then it’s fine as long as you move mouse around. The laptop Bluetooth receiver falls asleep after 4 seconds when you don't move the mouse. It drives me crazy to see it jump when I move the mouse. I decided to buy another mouse, HP Z500 mouse., and another mouse. and another mouse. No Luck they all lags. Its the computer intel bluetooth not working. IT LAGS. if it turn OFF fingerprint power management then bluetooth works, go figure.. but when i restart the computer it turn on power management on fingerprint settings.

HP Support did not help at all, hope to spare you some time!

I think intel Bluetooth and Fingerprint are not compatible.

New Contributor I

I can confirm I have the exact same issue on:

  • Lenovo Yoga 9i
  • Processor 11th Gen Intel(R) Core(TM) i7-1185G7
  • Intel(R) Wi-FI 6 AX201 160 MHz, as I assume that is where the bluetooth chip also sits.

I have tried many things.

  • Been in contact with Lenovo support, tried both their driver and every Intel Bluetooth driver for the past 3 versions, all with clean installs. Uninstalled McAfee with their removal tool.
  • Re-installed Windows 10 (upgraded to latest Win 20H2 (19042.867)
  • Tried with two mice, one Microsoft Bluetooth Precision mouse and one Logitech MX Master 3. Both "jump" the exact same way as in the reproduction steps in the original post in this thread.
  • Both mice work just fine on an older laptop.
  • No power settings change this.
  • Going into Device Manager -> HID -> Rightclicking the Bluetooth LE HIDs and selecting "Allow the computer to turn off this device to save power" does not help either. Tried and tested.

I have seen there are others reporting this at various places. This is a real problem with Bluetooth and 11th gen Intel it seems, which I would label sever as it basically makes most work with Bluetooth mice unbearable.

New Contributor I
@intel: as you can read this should be easy to reproduce.

I just purchased an LG Gram 17 2021 that comes with the intel AX201 wifi/bluetooth adapter and I have the exact same problem with the bluetooth mouse lag.

I tried 4 different bluetooth mice and one of the mice can be used with a USB receiver or bluetooth. There is no lag when using with the receiver but frequent and intermittent lag when using on bluetooth.

I tried to reinstall windows, reinstall bluetooth and wifi drivers, update the bios and any other windows updates but the issue persists. I also tried unchecking "allow computer to turn off this device to save power" but there was no difference.

Very annoying problem to have on a new laptop. Resorted to using the USB receiver until the issue is fixed. Thankfully the LG Gram has USB A ports. I noticed this issue in another thread so I'm posting here as well to raise awareness. I'm surprised it's taking intel so long to fix.

New Contributor I

@David_G_Intel Do you see all these messages about people having Bluetooth issues?  LG, HP, Dell, Lenovo, ASUS.  Please expedite this issue to Intel support to get this fixed.

Look on each manufacturers support pages at the community boards and you'll see tons of messages there as well of people having this issue.


My Zenbook UX435EG laptop with 11th Gen Intel® Core ™ i7-1165G7 has the same bluetooth issue, which manifests itself as follows:
1. The bluetooth mouse freezes every 5 seconds (the Logitech M350 mouse is working, tested on other devices);
2. The JBL Link Portable column stutters (the column is working, tested on other devices).

Steps taken to resolve this issue:
1. Reinstalling the driver from the official ASUS website;
2. Reinstalling the driver from the Intel official website;
3. Rollback Windows 10 to its original state;
4. Windows 10 update has the latest update 20H2 (Build 19042.868)
5. Removed the checkbox to allow the disconnection of this device to save in the HID device, compliant with GATT Bluetooth Low Energy.

The above actions did not give any result.


Hello @peter_hendrix


Thank you for the information provided, please share with us the full model of the two mice tested. To confirm, the steps to reproduce the problem are:

  1. Connect WiFi to AP on 2.4 or 5 GHz, but do nothing (i.e. WiFi is not actively doing things like browsing the Internet)
  2. Connect Bluetooth to a Bluetooth mouse
  3. The mouse will lag randomly

@Dermeni please also provide the full model of the mice you tested.

We opened an investigation on this. If we need more information, we will let you know.


David G 

Intel Customer Support Technician

New Contributor I


  • Microsoft Bluetooth Mobile 3600 Mouse
  • Logitech MX Master 2S Graphite
  1. WiFi connection-state is irrelevant... connected or not
  2. Yes
  3. No, it is not randomly. The pointer only jumps on first movement after a few seconds of 'no-movement'. Once set in motion it does not jump. After no-movement of a few seconds (or longer) it jumps when you start moving.

Kind regards,


Hello @peter_hendrix


Thank you for the information provided, we are working on a fix.

@Dermeni let us know once you have the model of the 4 mice you tested.


David G 

Intel Customer Support Technician


1. Logitech MX Anywhere 3

2. Microsoft Designer Bluetooth Mouse

3. Microsoft Bluetooth Mouse

4. Microsoft Modern Mobile Mouse


Once again the issue happens only when using Bluetooth mice. The Logitech mouse can be used with bluetooth or usb dongle and there are no issues when using with the dongle.

The issue is most noticeable when letting go of the mouse to type with both hands and then going back to the mouse after typing for a few seconds. There is about a half second delay before the mouse responds and really slows down the workflow.

New Contributor I

Same for me.  I'll be using the mouse and everything is fine.  If I stop using for just a little bit, it take several seconds for it to start moving on the screen.  Same with the keyboard.  At times, I go to type, it hesitates and then suddenly I've got multiple keystrokes on the screen.  Very annoying when typing.  I'm using a Logitech MX Anywhere 2S mouse and Logitech MX Keys keyboard.  


The model of mouse I am using  is the M585 on the Intel AX201 160Mhz


I just wanted to add my two cents that I am experiencing the same on four new Dell Latitude 7420s with 1185G7 chips. Same lag/wake issues using Bluetooth mouse (tried with Surface Modern Mouse x 2 and Logitech MX Anywhere 3) and keyboard (Apple Magic Keyboard). Currently working with Dell to try to resolve, but I suspect the issue may be Intel-related as others here have indicated.