Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7662 Discussions

Intel killer performance suit UWD missing


(I don't know what location to put this so sorry if it's missplaced)

So I was updating my Intel killer performance suit when my computer got a blue screen. When i then started the computer again I saw that the update wasn't applied. Tried to do it again but now it prompts me this:

I have checked and most certainly the file is not there in the folder. I have tried getting this file through a different download/version and using that but didn't work.

I have tried uninstalling it directly but nothing happens. I have tried doing the solution in https://community.intel.com/t5/Wireless/Intel-Killer-Performance-Suite-fails-to-install-interrupted/m-p/1349098#M39651 and a bunch of others i found that were kinda related but nothing has worked. At the moment I can't update it nor remove it and my internet speeds seems to be getting heavily strangled because of it. 

I got a Killer E2400 Gigabit Ethernet controller and I'm using windows 10.

Hope someone knows of something other than just doing a clean install of my pc

Labels (1)
0 Kudos
1 Reply

Hello Sullivan,

Thank you for posting in Intel Ethernet Communities. 

Please allow us to route this query to the concerned team. They will get in touch with you as soon as possible.

Feel free to let us know if you have additional questions or clarifications.

Hoping for your kind patience. 

Best regards,

Crisselle C.

Intel® Customer Support

0 Kudos