Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ASheo
Beginner
3,008 Views

Very slow download and upload speed on Intel Dual Band Wireless- AC 3160

Hello, I recently bought a Lenovo Y50-70 laptop and am receiving horrible download speeds with it, I usually get around 40mbps with my old laptops yet with this one I can barely go past 5mbps, so I figured it might be some setting I screwed around with. The wifi chip is an Intel Dual Band Wireless- AC 3160 and my drivers are up to date.

Any help would be appreciated.

also I noticed that mine does not support 801.11n yet in other discussions regarding the same chip, I have seen them support it.

0 Kudos
18 Replies
ASouz7
Honored Contributor II
417 Views

Hello Anuvrat1

Our first recommendation is to always update the drivers directly from your computer manufacturer support page if the wireless card came already installed in it when you bought. However, you can also try the following below but please, access this link link first: http://www.intel.com/support/wireless/wlan/sb/CS-034875.htm?wapkw=intel+7260+tp-link Intel® Wi-Fi Products — TechNote: Access Point Interoperability Issue with uAPSD

 

Regarding the frequent disconnection, this is what you do:

1 - turning off the power saving related functions can prevent unexpected disconnecting, sudden connections speed drops and the adapter working at its maximum performance. Go to control panel >>> Hardware and Sound >>> Power Options >>> Set the High Performance and apply the default settings. (Check the Change Plan Settings >>> Change Advanced Power Settings >>> Wireless Adapter >>> Power Saving Mode and make sure both On battery and Plugged in are set to Maximum performance).

/servlet/JiveServlet/downloadImage/2-283535-242986/pastedImage_1.png

2 - Set the advance settings of the Intel® Dual Band Wireless-AC 3160:

- Right click on Windows Icon and choose Device manager >>> Network Adapters >>> Intel® Dual Band Wireless-AC 3160 and right click and select Properties.

/servlet/JiveServlet/downloadImage/2-283535-242987/pastedImage_3.png

  • Select Advanced page to set the value of u-SPDA support to disabled.
  • Check value of transmit power and make sure it is set to 5. Highest.

/servlet/JiveServlet/downloadImage/2-283535-242988/pastedImage_6.png

*Very Important: It's recommended to use 2.4HGz band for better penetration capabilities which improves the connection signal if there are walls or other solid objects blocking between the router and your laptop. Next, change the Intel® Dual Band Wireless-AC 3160 advanced settings in order to match the settings with the router.

  • Set the Wireless Mode, example : 802.11 a/b/g/n according to the support mode of your router.

/servlet/JiveServlet/downloadImage/2-283535-242990/pastedImage_11.png

  • Set the preferred band to Prefer 2.4GHz band (considering the obstacles such as walls... etc.)
  • Set the HT Mode for 802.11n compatibility. (VHT Mode is for 802.11ac compatibility).

/servlet/JiveServlet/downloadImage/2-283535-242991/pastedImage_15.png

  • Set the 802.11n Channel Width for 2.4GHz to limited 20MHz. This one has smaller bandwidth than 40MHz, but it has better penetration capabilities which improves the connection signal.

/servlet/JiveServlet/downloadImage/2-283535-242992/pastedImage_19.png

Furthermore, if there no Bluetooth devices to be connected to your computer, turn it off because the wireless and Bluetooth* combo share the same wireless connection and antenna so turning off the Bluetooth can let the wireless connection has the entire usage of bandwidth and the antenna. Also, by turning off the Bluetooth*, it will help to decrease the signal interference since Bluetooth devices uses the same band.

Lastly, setup these two properties as shown below can improve the quality of the wireless connection.

  • Set the value of Roaming Aggressiveness to Lowest.
  • Set the value of Ad Hoc QoS Mode to WMM disabled.

/servlet/JiveServlet/downloadImage/2-283535-242993/pastedImage_22.png

We do hope this helps you to resolve this issue.

ASheo
Beginner
417 Views

thanks for the reply

Ok, I have tried these suggestions and am able to raise the download speed from 5mbps to 6mbps.

Currently my wireless mode is 802.11b as I have tried all the other modes including 802.11a/b/g but the 802.11b proves to be the fastest one. Is it possible to use 802.11n in it instead? I do not see it on the list.

ASouz7
Honored Contributor II
417 Views

Hello Anuvrat1,

In order to use N and/or AC you will need to do the following: Go to Control Panel >>> device manager >>> Networking >>> select the adapter, right click on it and then properties and do the settings as shown below.

ASheo
Beginner
417 Views

Thanks for the reply, ok I have checked my settings and U-APSD support is disabled and HT mode is set, but I am unable to find the first picture which shows '802.11n mode as enabled'

here is a pic of my setting

as you can see, there is no option for using 802.11n or 802.11ac which this adapter can easily support and run.

ASouz7
Honored Contributor II
417 Views

Hello Anuvrat1,

Try the the following as shown on your dialog box below.

 

ASheo
Beginner
417 Views

I have tried pretty much everything and still am unable to get anything out of this adapter. Really disappointing that my 4 year old laptop gets better speed than this intel hardware. Its just sad that this adapter cannot even run 802.11n connection forget about running 802.11ac.

ASouz7
Honored Contributor II
417 Views

Hello Anuvrat1,

Please give us some time to analyze this for you.

mJohn30
Novice
417 Views

OK why are you linking pictures of a completely different network adapter aleki_intel part of your analysis problem is that you are taking screenshots and referencing a Centrino Advanced N 6205 and we are referencing problems with Duabl band wireless-AC 3160 adapter... thats apples and oranges dont you think?

FOlar
Beginner
417 Views

Hi aleki_intel,

I have the exact same problem as the poster of this issue. The advanced settings for the adapter do not include the "N Mode" options at the top of the list in your screenshot.

Also, under "Wireless Mode" and "HT Mode", the only options are a, b, g, b/g, a/g, and a/b/g. There is no /n here either.

My connection's bandwidth is 100 Mbs (tested and working consistently over 90 Mbps). I should be getting at least 50 Mbps through WiFi, but I get a maximum of 18-20.

I am also very disappointed with my new Lenovo Thinkpad for this reason. Please advise asap!

Thank you in dvance.

ALibr
Beginner
417 Views

Blah, I've just spent a few hours going through all the possible solutions online and trying various others. Choice of band to Router seems to be the most effective change. Other changes like turn off bluetooth seem to have an effect but eliminating bluetooth on my new laptop is not a solve.

Ac 3160 sucks. Enough that I registered for Intel forum just to say so while leaving my notes on solves.

17.16 driver, brand new lenova y50 clean of bloatware. will continue to look for solves but really, this adapter is just junk.

POrne
Beginner
417 Views

Hey Guys

Any update to this?

 

I have the chip in my HP laptop and have serious issues with the downloading speed. Ive made all the changes mentioned here and modified the registry to turn off the associated scaning and its still slows as hell.

 

My speed jumps around from 500kb to 2.2megabit according to task manager on windows 8.1, in fact it bounces around so much that i cant even get netflix to stream anything over 480p.

 

The laptop is less then a month old.

 

I am testing less then a meter away from the wireless router.

 

All other devices i have tested on can stream 1080p on our 20 megabit internet connection
ASouz7
Honored Contributor II
417 Views

Hello Petero,

Is this wireless card the original one that came installed in your computer?

Did you check firewall and antivirus configurations as they may impact on the speed as well?

Is your router running the latest firmware?

We recommend that if this wireless card came installed by factory that you contact the OEM (Original Equipment Manufacturer) first to see if they have any updates that might help you to improve your experience. Also, in our download center, you can find the latest version (18.11.0) of the Intel® PROSet/Wireless Software for Windows 8.1* in this link: https://downloadcenter.intel.com/download/25138/Intel-PROSet-Wireless-Software-for-Windows-8-1- Intel® Download Center

Which file should you download? 

If you have Windows 8.1 32-bit and 8.1 64-bit:

DRIVERS ONLY: Wireless_18.11.0_De132.exe and Wireless_18.11.0_De164.exe

Intel PROSet/Wireless WiFi Software (includes Drivers): Wireless_18.11.0_e132.exe and Wireless_18.11.0_e164.exe

POrne
Beginner
417 Views

Hey Guys.

I had the latest that was available from the hp website which has is why I downloaded new one from the Intel website.

I downloaded the 64 bit drivers only file as I do not like to have to many services running slowing down the laptop.

It's an i7 with 8 gig of ram.

The chipset was pre installed on the laptop.

I use the stock standard windows firewall and avast free antivirus. Both which I have disabled and tried. Made no effect.

ASouz7
Honored Contributor II
417 Views

Petero,

In this case that the card came installed. We recommend that you check with your computer manufacturer if they have any updates that might solve the issue as they modify the card to be fully compatible with the type of system this card is in. Which band are you using, 2.4GHz or 5GHz ? Please understand that 5GHz is more susceptible to interference cause by physical objects such as walls as its penetration is not as deep as that of 2.4GHz. Take a look at this link as well: http://www.intel.com/content/dam/www/public/us/en/documents/pdf/next-gen-80211ac-wifi-for-dummies.pd... Next-Gen 802.11ac Wi-Fi For Dummies - next-gen-80211ac-wifi-for-dummies.pdf

On our best effort to help you with this inconvenience we invite you to look at these solutions below that might help you improve your experience.

http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Recommended Settings for 802.11n Connectivity

http://www.intel.com/support/wireless/wlan/sb/CS-034658.htm Intel® Wi-Fi Products - Quick Checks That Might Improve or Fix Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-031509.htm Intel® Wi-Fi Products — Possible Interference by Other Wireless Devices May Impact 802.11n Performance

http://www.intel.com/support/wireless/sb/CS-029893.htm Wireless Networking — Frequently Asked Questions - Wi-Fi

RBarc2
Beginner
417 Views

Hey Guys,

I also am having GREAT connectivity problems with this AC 3160 WIFI Adapter. I have a new DELL i5547 and for the life of me cannot upload or download anything

whenever it does feel like connecting to mt Linksys "N" router. I have tried EVERY suggestion on this post and other similar to it. It doers seem to work okay with "G" networks.

My real question is has INTEL made a improved model that I can purchase and replace the existing one?????

GBoy
Beginner
417 Views

Hello,

I recently bought the Intel® Dual Band Wireless-AC 3160 chip from an online store. So it didn't come installed OEM in my laptop.

I installed it in my ASUS laptop and I don't have the /n or /ac options in the Adapter properties !!!! So my speed is limited to 30mbps.

I have Windows 10 and the driver version is 18.12.0.3 .

It seems that this is a common problem so can you please look into it?! Maybe give us other drivers or something?!?!

GBoy
Beginner
417 Views

aleki_intel

There is no /n or /ac option!!!!!

TKaka
Beginner
417 Views

WIRELESS MOUSE - try disconnecting your wireless mouse and see how internet works on Intel Dual Band Wireless - AC 3160 , it solved my problem. I really tried everything drivers, settings, optimization, wasted a year on solving this.