Wireless
Issues related to Intel® Wireless Adapters and technologies
5972 Discussions

Wi-Fi 6 AX200 5ghz AC: connected, no internet access

Ninja6661
Beginner
452 Views

Hi.

I recently bought a TP-Link Archer TX50E PCIE card for my desktop, and the card wont connect to my router though the 5ghz AC-standard of wifi. The only way i can get the 5ghz to connect with internet access is by letting the card use the old 802.11a-standard with limitation of 54mbps...

I have done a lot of research so far, and it seems like the issue is due to a combination of windows 10 and the Intel drivers.

I have tried manually reinstalling the lates driver for the chip (22.40.0.7) which didnt help.
I have tried changing the wireless standard for 802.11n/ac/ax to ac in device manager which didnt help.

I have a laptop running the AC-standard of 5ghz with no troubles (not AX200 chip) which makes me think the router isnt the problem.

It seems like the issue is due to the card not getting a valid IPv4 configuration.

Please stop denying the driver is the issue to all this.. Call MS and get this sorted out, please.

0 Kudos
6 Replies
Ninja6661
Beginner
446 Views

Sometimes i am able to get the 5ghz AC-standard up and running for a minute or two, and then i lose connection to the internet and the card changes connection to 2,4 ghz N-standard.

5ghz AC, ingen IP.PNG

5ghz AC virker, ingen internet.PNG

  

2,4ghz N-standard.PNG

Alberto_Sykes
Employee
412 Views

Ninja6661, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this scenario, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

If this is a laptop, what is the model of it?

What is the model of the Router?

Is this a new computer?

Was it working fine before?

When did the issue start?

Did you make any recent hardware/software changes?

The wireless card, did you purchased it separately or did it came installed on the computer?

Which Windows* version are you using?

Does the problem happen at home or work environment?

Please attach the SSU report so we can verify further details about the components in your platform, please check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...


Any questions please let me know.


Regards,

Albert R.


Intel Customer Support Technician


Ninja6661
Beginner
405 Views

Hi Alberto,

Attached please find the enquired SSU-file.

Model of mobo = b450 steel legend i accordance to the SSU
Its not a laptop, its a desktop which i have build my self.
The router is a tp-link archer c2300.
It's not a new computer, but i havent had a wireless PCIE card installed before.
"Working before?" - as said, its the first time it has a wifi PCIE card installed.
Issue "started" when i installed the card. I never got it to work properly.
Yes I mad hardware and software changes. I installed the PCIE card and manually installed the intel drivers to get it to work. I started trying to get it to work with the "original" TP-Link software which didnt work out either.
I purchased the wireless card separately and installed it myself. I have tried another PCIE slot as well - didnt help the issue.
I use the 20H2 version of windows.
The problem is happening in a home environment.

winver.PNG

Alberto_Sykes
Employee
393 Views

Hi Ninja6661, Thank you very much for providing that information and the SSU report.


Just to let you know, we always recommend to install the Wireless driver provided by the manufacturer of the computer, since that driver was heavily customized by them to work with your specific platform. 


I looked on ASRock's website and there is no Wireless driver tested and validated from them. The Intel® Wireless drivers are generic, meaning they might or might not work with your specific platform.


Since the Intel® Wireless driver is currently installed and unfortunately the problem remains, we will do further research on this matter, but before we do that:

-Please get in contact directly with ASRock to gather the instructions on how to do a BIOS update to the latest version

-Additionally, once you get in contact with them, please also verify that all the parts are compatible with each other, their board and the Intel® Wireless card, since this problem could be related to a compatibility of the parts being used:

https://www.asrock.com/support/


Just to confirm, did you purchase the Intel® Wireless card as a kit or just the card itself? 

Could you please provide a link from where you get it from so we can see the parts included?

Do you have the option to test the wireless connection with a different Router?


Regards,

Albert R.


Intel Customer Support Technician


Alberto_Sykes
Employee
361 Views

Hello Ninja6661, I just wanted to check if you saw the information posted previously and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician


Alberto_Sykes
Employee
340 Views

Hello Ninja6661, Since I have not heard back from you, we are closing the case, but if you have any additional questions, please post them on a new thread so we can further assist you with this matter.


Regards,

Albert R.


Intel Customer Support Technician


Reply