Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7580 Discussions

Wi-Fi AC9560 error code 10. Notorious driver/config defect.

dorcom
New Contributor I
888 Views

Wi-Fi AC9560 error code 10. Notorious driver/config defect.

 

This is getting very tiring: The [new] notorious Wi-Fi AC9560 error code 10

 In late 2019 I bought an Asus Q536F laptop (zenbook 15")

The laptop came installed with Windows 10 home.
Shortly thereafter I upgraded to Windows 10 professional.
Everything worked fine I survived all the "forced down your throat whether you want it or not" Windows updates without any problems.

About a year ago, most likely after some of these forced Windows updates, I started to experience the ominous and notorious issue that my Wi-Fi would not work, reporting in the device manager under:

"network adapters" the entry:

  "Intel (R) wireless-AC 9560 160MHz" (this device cannot start (code10))

With this, another apparently related issue appeared in the section:
"universal serial bus controllers"  the entry:
"unknown USB device (device descriptor request failed)"

Recently,  after updating to the latest Intel drivers, the problem still persists but also added 2 new errors in the device manager under:

sensors > HID sensor collection V2
(this device is not working properly because Windows cannot load the drivers required for this device (code 31))

And under:
system devices > detection verification
(this device is not working properly because Windows cannot load the drivers required for this device (code 31))

Of course contacting Assus I was told the incompetent response this is an Intel problem, asides from reformatting and reinstalling Windows...! DUH?
Back then, I then contacted Intel and was told of course this is an Asus problem. 

Chances of getting any competency let alone a qualified reply from the manufacturer of Windows 10 has the same chance as winning the Powerball jackpot....

Upon further "drilling" I was told that I might have a defective Wi-Fi card. (which is soldered integrated on the motherboard, thus not really user-friendly replaceable.)

My question is, why then the Wi-Fi works for hours, days and weeks flawlessly, if I do a hard reset restart until the next shutdown, remained of course unanswered. Nobody has a clue.

Doing extensive research on the Internet I found first that a lot of people have this code 10 problem. So, a lot of "defective WiFi cards?"
Tinkering around, "re- un- down- up- clean- left- right- elsewhere-" installing etc. et al yielded nothing.
But, after wasting many hours, I did find a "quasi" sort of workaround which in my opinion is a hunch to where the problem really lies.

1) When I start the laptop and go immediately into BIOS and check “discard changes” and "restore defaults"> “load optimized defaults” and thereafter boot into Windows the Wi-Fi works. perfect and flawlessly.  But only if I first shut the laptop down and then start.

2) If I shut down Windows by means of "hibernate" it still works upon coming out of hibernation.

3) However(!!), if the hibernation phase is overnight, i.e. longer than about ~+7 hours, for some weird reason, most of the time but not always, it loses the Wi-Fi and I have to start all over again as in 1).

4) Occasionally the Wi-Fi got kicked out while in operation i.e. browsing up or downloading, streaming. that after no Wi-Fi exists as if it is banned. Only remedy: see 1)

NOTE: If the Wi-Fi is running, obviously the first two device errors mentioned (Intel wireless AC 9560 and universal serial bus controller)  are not present.

It is my understanding that the UEFI bios settings gets copied into Windows upon boot and Windows manages it.
(So discovered on an older laptop and I can verify & demonstrate such, as I could bypass a BIOS incompatibility/non recognition of an add-on device by simply powering the add-on device on after Windows began to boot! Worked flawlessly!)

So it appears something in Windows, after some update about a year ago, doesn't like the Intel AC 9560 and if it can't "kick it out" right away eventually will do so with time given or upon a regular restart.

Once I go back, upon start, immediately into the BIOS settings and check "discard changes” and “restore defaults"> “load optimized defaults” and start, everything is hunky-dory. Unless and until either a prolonged hibernation or regular shutdown/restart. This phenomenon/routine happens and works guaranteed, as if designed. Testing this further I shut down (hibernated) my laptop several times a day and restarted it within no less than seven hours and for weeks on there was no issue.  I ran the Wi-Fi with much streaming and many up- and downloads and it worked flawlessly. Surprisingly even the most recent Windows update that required a reboot had no effect.  Windows update however, bugs me about a driver “Intel Corporation-extension-22.1 120.0.1” but cannot install it.

Then (drumroll) today (11/14/22) the Intel website offered and recommended to update the WiFi driver (22.170.0.3). 
So I did, anticipating that somebody at Intel woke up and realized how to solve the problem.

What could possibly go wrong…
Now WiFi does not work at all in I can't get it to work.
Same device errors in the registry

So, dear engineers, got any clues? Where is your "Intel"?
Any reasonable and real working solutions? Driver software that actually works and not some shabby patchy quick fixes?
Down the rabbit hole you go and find this bug!

I'm willing to bet --if I find the time and install on another SSD an older version of Windows 10-- the problem likely won't be present but will reappear when I would update that older version to current!

In fact I just tested and booted from an USB a Hiren WinPE version (1709). Guess what?
Yes!  The Wi-Fi works in that WinPE OS boot!

PS My laptop is current on all drivers from Asus to Windows 10 (19045.2251) and all needed Intel drivers (via online Intel Driver & Support Assistant) as of November 11, 2022. The system is clean, there are no viruses or any malware on it (ESET).  SFC is good too.

At one time, a couple of months ago, I even did a restore reinstall (keep files and apps) but the problem persisted.  I also tried the Tweaking.com excellent Windows Repaired Utility, also to no avail.  The whole Intel WiFi code 10 thing is a classic S.N.A.F.U.!

PPS Please don't tell me the classic desperate "have no clue advice" to do a [sledgehammer approach] reformat and clean reinstall Windows! Everything else is working flawlessly.

You don't tear down your house when your front door jams from time to time...

 

 

0 Kudos
0 Replies
Reply