oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
730 Discussions

Error: A license for Comp-FL could not be obtained with oneAPI HPC Toolkit installed

leepearson
Beginner
866 Views

Hi every, I am a Ph.D. student, and I used student version of Intel® Parallel Studio XE Cluster Edition 2020 for Linux in my research. My current license is expired recently, and I cannot recompile my code with modification. I tried to use the oneAPI toolkit and set the environment variables with the setvars.sh file, but it still shows the following error in my code making:

 

‘Error: A license for Comp-FL could not be obtained Your license is not current enough to allow you to use this newer version of our software.Usually this occurs because your support services license expired before we created this version. You will need to purchase a new license. ... ifort: error #10052: could not checkout FLEXlm license.’

Have the oneAPI toolkit already contained those licenses? Could anyone help me? Thanks very much!

 

0 Kudos
1 Solution
Dilanjan_J_Intel
Moderator
814 Views

Hi leepearson,


In response to your post, we offer support for hardware platforms that the Intel® oneAPI product supports. These platforms include those that are part of the Intel® Core™ processor family or higher, the Intel® Xeon® processor family, the Intel® Xeon® Scalable processor family, and others which can be found in the below link.


Intel® oneAPI HPC Toolkit System Requirements - https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-hpc-toolkit-system-requir...


If you wish to use Intel® oneAPI on hardware that is not listed at the site above, we encourage you to visit and contribute to the open oneAPI specification - https://www.oneapi.io/spec/


Have a pleasant day ahead!


Regards,

Dilanjan


View solution in original post

6 Replies
Dilanjan_J_Intel
Moderator
829 Views

Hi leepearson, thanks for posting your query on the Community forum. You would only be able to install a package with a build date earlier than your product support expiration date. However, using the Intel® OneAPI toolkits doesn't require a license. It is free to download and use for all. To download Intel®oneAPI Base Toolkit and Intel®oneAPI HPC Toolkit visit the below link.


Link - https://software.intel.com/content/www/us/en/develop/tools/oneapi/all-toolkits.html#base-kit


Support is provided by the Intel Forums or you can choose to pay for support. For queries regarding the purchase and pricing plan of a license, we would suggest you check with our authorized resellers. You may visit the below links to do so.


Resellers' Information Link: https://software.intel.com/content/www/us/en/develop/tools/resellers.html


However, if you are a part of our previous Student, Academic or Open Source Developer Tools program and wish to extend your existing license, please email your serial number and contact information to software_tools_request@intel.com to request a license.


Have a pleasant day ahead!


Regards

Dilanjan



leepearson
Beginner
821 Views

Thanks,it is helpful to me! I have another problem, I carried out the parallel computing simulation (vasp and lammps) on the CPU of AMD 7742. Do you know how to set environment variables to achieve the best computing performance by using Intel®oneAPI HPC Toolkit?  Thanks very much!

Dilanjan_J_Intel
Moderator
815 Views

Hi leepearson,


In response to your post, we offer support for hardware platforms that the Intel® oneAPI product supports. These platforms include those that are part of the Intel® Core™ processor family or higher, the Intel® Xeon® processor family, the Intel® Xeon® Scalable processor family, and others which can be found in the below link.


Intel® oneAPI HPC Toolkit System Requirements - https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-hpc-toolkit-system-requir...


If you wish to use Intel® oneAPI on hardware that is not listed at the site above, we encourage you to visit and contribute to the open oneAPI specification - https://www.oneapi.io/spec/


Have a pleasant day ahead!


Regards,

Dilanjan


leepearson
Beginner
758 Views

Dear Dilanjan,

I successfully installed the oneAPI on the AMD 7742 CPU, but I found the simulation time is much longer than before. I heard that the Intel software toolkit cancellations AVX2 on AMD servers by default, I don't know whether is this problem, while I add the environment variables to activate AVX2 and running VASP code, it shows error information:

‘’WARNING: Sub-Space-Matrix is not hermitian in DAV           16

  -1.01495278995960

Error EDDDAV: Call to ZHEGV failed. Returncode =  15 2  16.‘’

 (when compiling the vasp, OFLAG are already added the AVX2 parameter)

Could you give me some guidance? Thanks so much!

Best regards

pearson

Dilanjan_J_Intel
Moderator
771 Views

Hi leepearson,


This is to check if you may have any further questions or queries regarding this.

 

Have a pleasant day ahead!

 

Regards,

Dilanjan


Dilanjan_J_Intel
Moderator
738 Views

Hi leepearson,


Thanks for getting back. As mentioned in our previous response, we offer support for hardware platforms that the Intel® oneAPI product supports. These platforms include those that are part of the Intel® Core™ processor family or higher, the Intel® Xeon® processor family, the Intel® Xeon® Scalable processor family, and others which can be found in the below link.


Intel® oneAPI HPC Toolkit System Requirements - https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-hpc-toolkit-system-requir...


This is the best answer we can provide regarding this. With that said if you need any additional information please feel free to post a new question as this thread will be no longer monitored by Intel®


Have a pleasant day ahead!


Regards,

Dilanjan


Reply