oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio

Re: OneAPI 2023 installation fails

publiusrgj
Novice
197 Views

Jasper,

          I wish I could help, but I can only tell you I'm in the exact same boat as you. I've got tons of development tools installed, multiple versions of Visual Studio installed, and on several different machines. All have the same problems. On my main machine, I spent several days trying to remove all traces of the previous product codes from the registry and anywhere else that looked promising.

    No luck, the OneAPI installer still somehow thinks the products are still installed.  I was searching around for another problem and happened to see your post here, and so registered to reply.

     It would be nice if there was a "zapper" tool or something that could remove all traces from the system. Only intel knows where all such traces are. 

4 Replies
Soumya_M_Intel
Moderator
125 Views

Hi publiusrgj,

 

Thanks for posting regarding your concern on the prior forum thread. Please note, this a new forum post that has been generated (from your comment) by our internal team so that we could assist you regarding your concern.

 

Kindly let us know the below details with respect to the mentioned main machine (for now). Once the issue resolves for the main machine, we would address the issues on the other different machines as well.

 

  • The version of the Windows operating system.
  • During the installation of which Intel® oneAPI toolkits (name & version) are you facing the issue?
  • A screenshot of the issue from the GUI installer.
  • The log files (if available).
  • What are the versions & builds of Visual Studio recently uninstalled & currently installed (if any)?
  • What are the Intel® product toolkits & suites recently uninstalled & currently installed (if any)?
  • Did you uninstall the Intel® products & Visual Studio using their own installers?
  • Have you tried using the InstallCleanup.exe to make sure the Visual Studio instances are properly uninstalled? If not, you may refer to the below link for more information regarding it.

 

The above information will provide us with a better understanding of the concern. Looking forward to your update. 

 

Regards,

Soumya

 

publiusrgj
Novice
110 Views

 

   Thanks.  The problem is the old problem of a previous Parallel Studio installation not compatible with the later VS installers. The OneAPI installer thinks the old version of the integrations is still installed in VS 2019 and tries to uninstall, which fails. Uninstalling VS 2019 completely and even going through the registry and removing all instances of the product codes (which I can find) doesn't do it. Installer still thinks it's installed. 

     I know the fix for that is to completely uninstall everything, all instances of VS and start from scratch, but I don't want to go to the trouble of doing that on my main machine here -- too much developer stuff installed, and lots of time and probably other problems triggered.  The OneAPI integrations do work with VS 2022, and I can live with that. 

          So, no need to open a support ticket. Thank you anyway, I appreciate it. 

jasper
Beginner
98 Views

This experience differs from mine. Complete uninstall and re-install of Visual Studio does not do the trick - I tried this last year. And integration fails also in VS2022.

Soumya_M_Intel
Moderator
88 Views

Hi publiusrgj,


Thanks for getting back to us on the thread. We appreciate you responding back to us with the context. Based on your response, we are closing this thread.


However, if you need any additional information, please feel free to post a new question as this thread will no longer be monitored by Intel®. 


We are always here to assist you.


Regards,

Soumya


Reply