Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
71 Views

How to change directory for VTune in command line

I am attempting to collect VTune data via command line but it seems to want to store information in a temporary directory and I can figure the option to tell it to use a different directory (insufficient memory in the VTune selected default directory).

I first ran like this:

amplxe-cl -collect <analysis type> ./a.out 

But I got errors about directory so I tried this: 

amplxe-cl -collect <analysis type> -result-dir ./dir1 -user-data-dir ./dir2 ./a.out 

However, I get the same error either way: 

amplxe: Error: There is not enough free disk space available in the `/tmp/amplxe-tmp-drmackay/amplxe-res-66436-9349951234026312/data.0' directory. The free disk space is less than 100 MB.

How can I tell VTune not use /tmp/amplxe-tmp-. . .  but instead to use dir1 or dir2 or someother directory?  I don't have permissions to increase directory size on /tmp

Thank you kindly.

 

0 Kudos
2 Replies
Highlighted
71 Views

Hello David,

Let me paste what we have in VTune help on this:

Configuring an Alternative Temporary Directory for Local Targets:
For local targets, you may set the standard Linux TMPDIR environment variable to an alternate directory path with the sufficient temporary storage space. To configure the TMPDIR environment variable, do the following:

From within the shell where you will be running the VTune Amplifier command line or GUI, assign a value and export TMPDIR, for example:
> export TMPDIR=/directory_path/ tmp
Verify the assignment:
> echo $TMPDIR
Verify directory permissions are sufficient for the directory assigned to TMPDIR:
> ls -ld /directory_path/ tmp
From the shell window, run the VTune Amplifier hardware event-based sampling collection using either the command line or GUI.

Please let know if it works for you.

Thanks & Regards, Dmitry

0 Kudos
Highlighted
Beginner
71 Views

Yes, thank you Dmitry that is the setting I was looking for.  This gets me over the first hurdle.  Now I set TMPDIR and when I run I have a problem with the sep drivers.  Here is what I enter:

amplxe-cl -collect memory-access -result-dir dir1 -user-data-dir dir2 ./a.out

When I do this I get the error:

amplxe: Warning: To profile kernel modules during the session, make sure they are available in the /lib/modules/kernel_version/ location.
amplxe: Error: Failed to execute sep process. Data collection is interrupted.
amplxe: Internal Error

 

 

To verify that sep is loaded I followed advice from other forum thread and ran lsmod | grep.  Here is the output from that command:

lsmod | grep sep
sep4_0                767375  516
socperf2_0             33414  1 sep4_0

Here is information about VTune version:

amplxe-cl -version
Intel(R) VTune(TM) Amplifier XE 2017 Update 2 (build 499904) Command Line Tool
Copyright (C) 2009-2017 Intel Corporation. All rights reserved.

So yes, your suggestion resolved setting the tmp directory, but I am now at the next roadblock.

-David

 

0 Kudos