Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jimdempseyatthecove
Black Belt
56 Views

Howto - Advanced Hotspots on KNL

I have a KNL system, Installed Parallel Studio XE Cluster Edition 2016.0.3. C++ and IVF projects build (so does Intel MPI)

Having an issue with VTune Amplifier running Advanced Hotspots.

As distributed, the VTune drivers were not installed during installation of PS (due to KNL CPU), however, in following the instructions for building the drivers, the build succeeds, and installation of drivers succeeds

insmod-sep -q

shows

pax driver is loaded and owned by group "vtune" with file permissions "666"
socperf2_0 driver is loaded ...
sep4_0 driver is loaded...
vtsspp driver is loaded...

groups shows my user account is a member of vtune

Any hints on how to get5 hardware sampling working would be appreciated.

Jim Dempsey

0 Kudos
3 Replies
Dmitry_P_Intel1
Employee
56 Views

Hello Jim,

What are the exact symptoms do you have for non-working advanced hotspots?

 The issue might be that VTune 2016 U3 requires NDA package to work with SEP on KNL.

I would recommend to install 2016 U4 that does not require NDA package and has some fixes e.g. more correct BW metrics for MCDRAM cache mode in memory access analysis and also has HPC Performance Characterization analysis type adapted for KNL.

Thanks & Regards, Dmitry

jimdempseyatthecove
Black Belt
56 Views

I've had independent confirmation from Ryo (Colfax) that U3 Advanced Hotspots does not work with KNL. U4 will as well as V17

I haven't received an email notice that U4 is available. Is it available for download?

Jim Dempsey

Dmitry_P_Intel1
Employee
56 Views

Hello Jim,

Let me confirm that 2016 U3 Advanced Hotspots works on KNL but you need to get NDA package from Intel Premier to install over public bits to make it workable.

Yes - VTune Amplifier XE 2016 Update 4 standalone package is available for download from Intel Registration Center. Let me know if you have problems finding it.

Thanks & Regards, Dmitry