Community
cancel
Showing results for 
Search instead for 
Did you mean: 
gartss
Beginner
43 Views

The Activity failed to run

Hello all,

I'm going through a problem when running the Activity tool.
As an early test before benchmarking my application, I ran the following command:

"vtl activity Dummy -c sampling -app ls run"

and get the following result:

"
VTune Performance Analyzer 9.1 for Linux* build 432
Copyright (C) 2000-2009 Intel Corporation. All rights reserved.

The Activity has been successfully created.
The Activity is running.
The Activity failed to run. The cause of error could not be determined. The error code is 0x800706BA.
"

I could not find anything about that error. It is the same with any other applications (even mine), with or without arguments.
Also I'm not the administrator of the system, and the administrator does not know nothing about using intel softwares.
The system is a red hat real time. The command "uname -a" gives:

"Linux XXXXX 2.6.24.7-149 #1 SMP PREEMPT RT Tue Jul 20 10:51:31 CEST 2010 x86_64 x86_64 x86_64 GNU/Linux"


I would appreciate any help, especially if someone knows what this error code is for.
Thank you,
Gartss
0 Kudos
2 Replies
Peter_W_Intel
Employee
43 Views

First at all, please check if your OS is supported in release notes of VTune Analyzer 9.1 Update 8.

Secondary, you have to use "root" privelige to install the product, then check if vtune driver has been installed - "lsmod | grep vtune".

If vtune driver hasn't been installed - you can't use sampling data collection, only call graph data collection can be used. You may go vtune/vdk/src to build/insert vtune module into system.

You can use samplingbynon-root user, but please add user account into "vtune" group first.

Please note that if your account directory is mapped in NFS - this will causefailure when creating vtune project and save results.Save result in local driver...

By the way, nowwe have new product VTune Amplfier XE 2011 XE Update 4 - old productalready is out-of-support now.

Hope it helps.

Regards, Peter
gartss
Beginner
43 Views

Thanks for the answer.

The OS is RedHat 5.3 but with the real-time extension MRG, so build on the kernel 2.6.24.7-149. It is not offically supported. So we'll try with the default kernel and without real-time extension.

To answer your other comments:

Yes we installed vtune as root, and the associated driver too, which is running well.
Now I can be root, and I lauched the application as root, so on a non-NFS local drive.
The error persists.

We are quite sure that the cause of the problem is from the non-supported kernel associated to the real-time extension.
So we'll try wthout and let you know.

Thanks for your help,
Simon
Reply