Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JESSE_M_
Beginner
104 Views

The application has no response,when using the Intel Inspector XE collecting Result datata

Jump to solution

Hi all,

       I find our application becomes very slow, then always has no response,when Use the Intel Inspector XE to coolect  the memory leaks or thread errors.

    Who met this kind of phenomenon?how I should  Set the something?

thanks

Jesse

     

 

0 Kudos
1 Solution
Peter_W_Intel
Employee
104 Views
Reducing overhead from Inspector XE, please read my old article here - know that you can use Collection Control APIs, at Finally part... https://software.intel.com/en-us/articles/use-new-collection-control-apis-in-inspector-xe-2013

View solution in original post

9 Replies
Peter_W_Intel
Employee
105 Views
Reducing overhead from Inspector XE, please read my old article here - know that you can use Collection Control APIs, at Finally part... https://software.intel.com/en-us/articles/use-new-collection-control-apis-in-inspector-xe-2013

View solution in original post

Peter_W_Intel
Employee
104 Views

And, please use mi1 or ti1 instead of m3 or ti3, set stack depth as 1.

JESSE_M_
Beginner
104 Views

Tanks Peter Wang(Intel)

I Use mi1 or ti1 and Set stack Dept as 1,our project becomes quickly than before, but I Intentionally added a memory to constructor  of one module, and  Include this model.the Intel Inspector XE cannot find He memory leaks.

  • A::A(void)
    {
    	for (int i =0; i<100;i++)
    	{
    		p= new QThread;
    	}
    }
  •  

Peter_W_Intel
Employee
104 Views

Was it possible that return address is a global variable? Before application exits, there is no leak detected.

Can you try allocation memory for local (stack) variable? 

JESSE_M_
Beginner
104 Views

Thanks,

I try allocation memory for local variable ,but Intel Inspector XE also cannot find the memory Leak in our project.

I try added the same code to Smaller project,it can Find.the memory leaks.

 

Peter_W_Intel
Employee
104 Views

Was it due to no debug(symbol) info generated when compiling? Please use "-g" for Linux*, "/Zi /DEBUG" for Windows*.

JESSE_M_
Beginner
104 Views

Thanks.

       Mybe I don't Set Optimization to Disabled(/Od),Now The Inspector XE Can Find this king of Memory Leaks.But It still Let our Application that Performance is very Low,I had Removed Modules do not to analyze.Especially Use mi2 or mi3

 

Peter_W_Intel
Employee
104 Views

Using optimization switchers will not cause leaks not found. Anyway, it's good that you can find memory leaks for now.

You said, "...I Use mi1 or ti1 and Set stack Dept as 1,our project becomes quickly than before..." - if you still are not satisfied with this, you can use Collection Control APIs I posted at 02/05/2015 - 10:30 to reduce overhead.

JESSE_M_
Beginner
104 Views

Thanks .

I understand what you mean.I Will try it.

Reply