Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Clifton_L_
Beginner
303 Views

The latest Intel Inspector 2017 update 3 stops working

After I installed the update 3 of Intel Inspector 2017, it fails with unknown error. It does not matter what analysis type I have and this is the same project that worked fine with update 2.

 

Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading up to the problem and contact the Intel customer support team.
Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading up to the problem and contact the Intel customer support team.
 

0 Kudos
23 Replies
Kevin_O_Intel1
Employee
260 Views

 

I see the error. What OS version are you using?

Clifton_L_
Beginner
260 Views

Windows 10. I have not had issues with the previous update.

Clifton_L_
Beginner
260 Views

 

BTW, with the latest updates for VTune Amplifier (Basic Hotspot) and Advisor, I am getting the following errors

__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!
__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!
__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!

Is it possible that Inspector is having the same issue with some PIN incompatible security software ? Since this is a corporate PC and there is no easy way to bypass the security software, is there a way to find the conflicting software before I can proceed to the next step ?

Thx,

Clifton

 

Kevin_O_Intel1
Employee
260 Views

 

Is it possible for you to share the executable that reproduces this issue?

Clifton_L_
Beginner
260 Views

No, this is the firm IP and against policy to share any code. But this is not particular to my code. I get the same errors running the sample code from Intel distribution (tachyeon_insp_xe)

Kevin_O_Intel1
Employee
260 Views

 

Understood.

I am in discussion with our development team... I'll let you know the status

Kevin_O_Intel1
Employee
260 Views

 

Can you run

inspxe-feedback.exe -create-bug-report=c:\temp\report.txt

And send the report to kevin.p.oleary@intel.com

Our current theory is the security software but we would like to confirm. Is there a way for you to exclude pin.exe from the list of software scanned?

Clifton_L_
Beginner
260 Views

Hi,

I have put in an inquiry to the security team to see if it's acceptable to do this. At the same time, I have reverted to the previous version and inspector works just fine and am able to proceed with my work. In the meantime, I will try to install the latest inspector on a different PC and see if I can generate the report for you. This PC actually runs Windows 7.

Regards,

Clifton

 

Clifton_L_
Beginner
260 Views

BTW, I just installed Inspector update 3 on a Windows 7 corporate PC and did not experience this issue. Let me install this again on my PC

Clifton_L_
Beginner
260 Views

Hi Kevin,

I sent you the info as requested and the inspxe-feedback.exe also crashed on my Windows 10 PC. Note that I have Symantec Endpoint Protection running on the Windows 7 corporate PC also and Inspector worked just fine without any issues. I think it's Windows 10 specific. I tried an evaluation version on my home PC, running Windows 10, with virus software disabled, it had the same problem. For the time being, I just have to revert to the previous update.

Regards,

Clifton

Kevin_O_Intel1
Employee
260 Views

 

I will pass this along to engineering and get back to you.

Kevin

Kevin_O_Intel1
Employee
260 Views

 

Hi Clifton,

I wanted to let you know that we have an engineering release of Inspector that we believe will resolve this issue. Would you be interested in giving it a try. Please file a support ticket at http://www.intel.com/supporttickets

Also, for VTune the issue is resolved in VTune 2017 update 4.

Thanks!

 

Popov__Maxim
Beginner
260 Views

VTune 2017 update 3 and update 4 doesn't work:

2017-07-17_08-16-25.png

 

Rollback to Vtune 2017 u2 - it works OK.

Windows 7

Kevin_O_Intel1
Employee
260 Views

 

Hi Clifton,

I am escalating the issue with the vtune team.

Kevin

Kevin_O_Intel1
Employee
260 Views

 

Can you verify the vtune build # for update 4... help->about->details

Thanks!

Popov__Maxim
Beginner
260 Views

I already use update 2.

I found the problem after installing update 3. After that I found this page and downloaded and installed update 4 - it didn't help, so I pretty sure that Update 4 didn't helped me.

 

BTW: Update 3 works fine on the same task, but on Windows Server 2012 R2

Kevin_O_Intel1
Employee
260 Views

 

Thanks Maxim,

Can you please file a support ticket at http://www.intel.com/supporttickets

Kevin

Popov__Maxim
Beginner
260 Views

I'm not sure that I have time for it

jimdempseyatthecove
Black Belt
260 Views

I get the __bionic... failure with VTune 2017u4 on Win7 Pro x64, MSVS 2013

Jim Dempsey

jimdempseyatthecove
Black Belt
103 Views

Note, VTune 2017u4 on Win7 Pro x64, MSVS 2013 worked a few times before this showed up.

Jim Dempsey

Reply