Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4682 Discussions

Unable to View Statistic of OpenMP Region CPU Usage Histogram

CWhit10
Beginner
216 Views

Hi,

Currently, I'm running analysis on the executable file generated from the compilation of C source code.

However, at the Summary window, certain OpenMP regions' CPU Usage Histograms are not displayed at the GUI, and some of them do.

Attached is the screenshot of Summary window. Hope it'll help to clarify my statement above.

Is there any solution to this problem?

 

Thank you.

0 Kudos
2 Replies
David_A_Intel1
Employee
216 Views

Basically, I don't see 220-227 in the top five loops on the Summary and, except for the first two, the rest have insignificant time.  Also, looks like you are pretty max'd out.  Total potential gain is 2%!  You're done! ;)

Also, notice, that the histogram shows you have exactly one instance of the loop at 220 and its duration is 0.0141789.  I think there just isn't enough time to sample how many threads were active.  If you used Advanced Hotspots, you can try reducing the sampling interval to 0.1 ms.  But, seriously, why?!

Vitaly_S_Intel
Employee
216 Views

Yes, likely there are no samples on given region since it was too short.

BTW, did your analysis was running for 2 hours? I noticed that based on Elapsed Time on summary.

Reply