Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4554 Discussions

VTune 2016 Update 1 Bluescreen with Advanced Hotspots

Richard_S_4
Beginner
185 Views

Hi there,

I've been using VTune Amplifier 2016 on a Dell Precision T7600 workstation running Windows 8.1 for a couple of months with great success. A new hardware rollout has seen me upgraded to a T7910 with Windows 10, but the Advanced Hotspots Analysis is resulting in a bluescreen every time I run it, in vtss.sys. I was initially seeing a DRIVER_OVERRAN_STACK_BUFFER error, but since removing all Hyper-V options from my BIOS as suggested in another thread I am now seeing KMODE_EXCEPTION_NOT_HANDLED

Meanwhile the Basic Hotspots view is fine.
 

​I think we technically have premium support but not associated with my developer account. Any assistance would be appreciated...

 

- Richard Semmens

0 Kudos
10 Replies
Peter_W_Intel
Employee
185 Views

> A new hardware rollout has seen me upgraded to a T7910 with Windows 10, but the Advanced Hotspots Analysis is resulting in a bluescreen every time I run it, in vtss.sys

What is new hardware to be upgraded to T7910 with Windows, probably there is resource conflict at driver module (interrupt service)?

I seems there is no way to avoid this, don't used event-based sampling but user-mode data collection can work. Remove vtss.sys ("VTune\bin64\amplxe-sepreg.exe -u")

It will be appreciated if you can send report to our developer when you meet BSOD again:

amplxe-feedback -create-bug-report <report archive>
amplxe-feedback -send-crash-report=<report archive>

 

Richard_S_4
Beginner
185 Views

Peter Wang wrote:
What is new hardware to be upgraded to T7910 with Windows, probably there is resource conflict at driver module (interrupt service)?

If you're asking what the hardware is, it's a Dual Xeon E5-2687W v3 @ 3.10Ghz on a Dell 0215PR motherboard (Intel X99 motherboard).

I'll get the bug report sent, but my expectation would be for us to work out a way to get event based sampling working, not just disable one of the key product features.

Richard_S_4
Beginner
185 Views

A couple of other points of note:

I am using the stand alone GUI to run this

Within Advanced Hotspots the top selection - Hotspots - works fine. Selecting Hotspots, stacks and context switches causes the bluescreen immediately.

I have generated and submitted the crash dump using the command line that you provided - is there anything further I need to do to associate the crash dump on your end with myself and this post?

Vitaly_S_Intel
Employee
185 Views

Hi Richard,

Will you please upgrade to VTune Amplfiier XE 2016 Update 2? Very similar issue was fixed in this version already.

Also, does your application encodes/decodes video streams or renders graphics on the screen?

Richard_S_4
Beginner
185 Views

Update 2 does not appear to be available on general release; I can't see it in the Intel System Studio download area; only 2015 or 2016, version default or Update 1. Whereabouts could I get hold of Update 2?

Peter_W_Intel
Employee
185 Views
Richard_S_4
Beginner
185 Views
"We are unable to find registrations / downloads matching this request"
Peter_W_Intel
Employee
185 Views

I you have registered product, such as Intel? Cluster Studio XE 2016 for Windows*, Intel? Parallel Studio XE 2016 for Windows*, or VTune(TM) Amplifier XE 2016 for Windows*. The URL should work.

Richard_S_4
Beginner
185 Views

Ah-ha, my product is "Intel® System Studio Professional Edition for Windows* (All Tools)" which includes Intel VTune Amplifier 2016 for Systems

Can I get access to the VTune update separately or do I need for it to be rolled into the System Studio download?

Vitaly_S_Intel
Employee
185 Views

Hi Richard,

Update 2 for Systems should appear soon. Please stay tuned for the announce from Intel Registration Center.

Reply