Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5021 Discussions

Vtune 2022.4.1 does not work Ubuntu 20.04 - use case

bariserkus
Novice
1,910 Views

I have installed Vtune 2022.4.1 to my Ubuntu 20.04, and it simply has errors that prevents the loading drivers correctly. When I switch to 2022.2.0, it worked fine. I am not sure if the newer version supports Ubuntu 20.04, maybe there are some limitations.

 

This post -as a use case- is just to inform people, who recently upgraded to 2022.4.1, that switching to an older version may help in the short run. Good Luck!

0 Kudos
1 Solution
RemyaP_Intel
Moderator
1,583 Views

Hi,

 

We note that as per the system requirements, the processors with 5th Gen and above are only supported on the latest version(2023.0.0). Could you please try running the analysis on a machine that meets the system requirements and let us know if the issue still exists or not?

 

RemyaP_Intel_0-1672301968257.png

 

 

Regards,

Remya Premdas

 

 

View solution in original post

0 Kudos
7 Replies
bariserkus
Novice
1,889 Views

I have tried Vtune 2022.4.1 On MS Windows 10 machine and it cannot recognize the processor on Windows as well. So the problem may be the processor I have: Intel Core i7-4930K CPU @ 3.40GHz. I do not have this problem with version 2022.0.0 on Windows.

0 Kudos
RemyaP_Intel
Moderator
1,859 Views

Hi,

 

Hi,

 

Thank you for posting in Intel Communities.

 

We are unable to reproduce your issue. We tried installing VTune version 2022.4.1 in Ubuntu 20.4 and the drivers were loaded successfully. If you are getting issues related to loading drivers, please try the below steps. This will reload your driver.

 

cd /opt/intel/oneapi/vtune/latest/sepdk/src

./insmod-sep -q

 

Can see the drivers loaded successfully. If not,

 

cd vtsspp

./rmmod-vtsspp

./insmod-vtsspp -r

 

This will remove all the drivers and reload them.

 

Also, could you please send a screenshot of the error you are getting on Windows machine.

 

Regards,

Remya Premdas

 

0 Kudos
bariserkus
Novice
1,669 Views

Hello,

 

On Windows machine, I am currently working on a project, therefore I do not want to take the risk of not being able to install Vtune at all. But I can try it on another Windows machine with the same processor. Please give me couple of days.

Please note that the problem is not Vtune not starting. Vtune starts fine, but analysis that require the recognition of the processor gives the error that Vtune cannot recognize the processor and that specific analysis cannot be performed. 

I have another Linux machine with the same processor, and having similar issues. I will try your suggestion and get back to you on that as well.

Thanks for your assistance.

0 Kudos
RemyaP_Intel
Moderator
1,675 Views

Hi,


We haven't received any update from you. Is your issue resolved?


Regards,

Remya Premdas


0 Kudos
bariserkus
Novice
1,642 Views

Hello,

I have installed standalone VTune Profiler 2023.0.0 on Ubuntu Linux 20.04.5 LTS. I was able to load the Sampling Drivers successfully(*).

A) I receive the following error for the

  • Performance Snapshot
  • Hotspots - Hardware Event Base Sampling
  • Memory Access
  • Threading - Hardware Event Base Sampling

"This analysis type is not applicable to the system because VTune Profiler cannot recognize the processor. If this is a new Intel processor, please check for an updated version of VTune Profiler. If this is an unreleased Intel processor, please contact Online Service Center for an NDA product package."

 

B) I receive the following error for the

  • Performance Snapshot
  • Microarchitecture Exploration
  • Memory Access:

"This analysis type is not applicable to the current machine microarchitecture."

 

C) Also for Memory Access this error occurs:

"Cannot collect memory bandwidth data. Make sure the sampling driver is installed and enabled on your system. See the "Sampling Drivers" help topic for more details. Note that memory bandwidth collection is not possible if you are profiling inside a virtualized environment."

 

Considering the last error listed above, I verified that my sampling drivers are installed and are loaded properly using the "insmod-sep -q" tool.

For another attempt: I have installed Vtune 2023.0.0 from the the OneAPI Base Toolkit 2023 GUI installer (along with the DPC++ compiler) on top of the VTune standalone 2023.0.0. During the install it gives the warning that the following libraries are not available and needs to be installed:

  • libgbm1
  • libdrm2
  • libxcb-dri3-0

However these are all installed on my Ubuntu Linux.

After re-installing VTune 2023.0.0 (this time from the OneApi Base Toolkit GUI Installer as explained above), I re-checked VTune and got the same errors as above.

Again: My processor is Intel Core i7-4930K CPU @ 3.40GHz. I have installed VTune 2022.2.0 on another Ubuntu Linux machine with the same processor and it works fine.

I will not try VTune 2023.0.0 on Windows at the moment. Lets see if we can solve the Linux problem first. Thanks in advance.

0 Kudos
RemyaP_Intel
Moderator
1,584 Views

Hi,

 

We note that as per the system requirements, the processors with 5th Gen and above are only supported on the latest version(2023.0.0). Could you please try running the analysis on a machine that meets the system requirements and let us know if the issue still exists or not?

 

RemyaP_Intel_0-1672301968257.png

 

 

Regards,

Remya Premdas

 

 

0 Kudos
RemyaP_Intel
Moderator
1,563 Views

Hi,


Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Remya Premdas


0 Kudos
Reply