Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,797 Views

Adapter X710 DA2 and SFP+ LR Module does not working in link mode 1GB

HI!

I have the adapter X710 DA2 and X710 DA4, using LR SFP+ Module (Intel DUAL RATE 1G/10G SFP+ LR (bailed) FTLX1471D3BCV-IT),

does not UP ethernet link in mode 1G between devices.

Also can not dump the settings to the EEPROM of the SFP module in response to receiving

Cannot get module EEPROM information: Operation not supported

When you try to off auto-negotiation or change speed to 1000 also have

 

Cannot get current device settings: No such device

not setting speed

not setting duplex

not setting autoneg

below information about

driver information:

driver: i40e

version: 1.5.16

firmware-version: 4.42 0x80001921 0.0.0

bus-info: 0000:0a:00.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes

interface status :

p2p1 Link encap:Ethernet HWaddr 3c:fd:fe:9d:40:38

inet addr:xxx.xxx.xxx.xxx Bcast:xxx.xxx.xxx.xxx Mask:255.255.255.0

inet6 addr: fe80::3efd:feff:fe9d:4038/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:4358 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:728252 (728.2 KB)

Settings for p2p1:

Supported ports: [ FIBRE ]

Supported link modes: 1000baseT/Full

10000baseT/Full

Supported pause frame use: Symmetric

Supports auto-negotiation: No

Advertised link modes: 10000baseT/Full

Advertised pause frame use: No

Advertised auto-negotiation: No

Speed: 10000Mb/s

Duplex: Full

Port: FIBRE

PHYAD: 0

Transceiver: external

Auto-negotiation: off

Supports Wake-on: d

Wake-on: d

Current message level: 0x0000000f (15)

drv probe link timer

Link detected: yes

Is it possible the work of these SFP+ when using the adapter X710 DA2 in 1GB mode?

If so, why do I have these conflicts with modules?

Tags (1)
0 Kudos
3 Replies
idata
Community Manager
193 Views

Hi Konstantin_1975,

 

 

I've noticed you've also posted similar question in this link - https://communities.intel.com/thread/105405 https://communities.intel.com/thread/105405

 

 

please continue the issue investigation on that thread.

 

 

regards,

 

Vince

 

idata
Community Manager
193 Views

Yes, the ticket # 105405 is created as deeper in terms of information.

Continued research in this ticket

idata
Community Manager
193 Views

Guys, was there any resolution in that ticket? We have exactly same problem: intel X710-DA2 network controller with Intel's SFP+ module (Intel® Ethernet SFP+ SR Optics E10GSFPSR - Dual Rate 10GBASE-SR/1000BASE-SX) is not working. No link up and attempts to get module information ends with "Operation not supported".

~ # ethtool -i enp4s0f1

driver: i40e

version: 1.5.25

firmware-version: 5.04 0x800024c6 0.0.0

expansion-rom-version:

bus-info: 0000:04:00.1

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes

~ # ethtool -m enp4s0f1

Cannot get module EEPROM information: : Operation not supported

We've also updated NVM to the latest version, and we use recent driver (1.5.25).

Reply