Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MLeis3
Beginner
1,935 Views

Duplicates of packets on VMSwitch using Intel x722

We have Hyper-V Server on which we created VMSwitch (with Switch Embedded Teaming) on two built in Intel722 adapters.

On VMSwitch we have NetAdapter for Management OS with ip assigned(created along with vmswitch). After creation everything works fine until reboot, after which we are observing duplicates of packets ie:

18 bytes from xxx: icmp_seq=1 ttl=128

18 bytes from xxx: icmp_seq=1 ttl=128 (DUP!)

18 bytes from xxx: icmp_seq=2 ttl=128

18 bytes from xxx: icmp_seq=2 ttl=128 (DUP!)

If we remove VMSwitch and create it again, everything works fine until reboot.

MacAddress/IP configuration is always the same and don't change after reboot. We investigated the network, but it seems that those macaddressess exist only on that host and we see (using Wireshark/tcpdump) that duplicates are indeed coming from that server. If we use different network card (Intel x550) to create VMSwitch on that server it all works fine. Also if we use those cards without VMSwitch there are no duplicates.

Mobo: X11SPH-nCTF + built in Intel X722 for 10GBASE-T

Processor: Intel Xeon Silver 4110 2.1GHz

OS: MS Hyper-V Server 2016 Version 10.0.14393 Build 14393 + all updates (also tested on MS Windows Server Standard 2016 + all updates)

Driver: c:\windows\system32\drivers\i40eb65.sys (1.8.94.0, 996.54 KB (1,020,456 bytes), 2/19/2018 11:50 PM) (from latest 23.1 Driver Pack)

We don't see anything in logs. We tried reinstalling, even with different OS, situation seems to be the same.

We have the same OS + VMSwitch configuration on different Motherboards/Network Cards but there we don't observe any problems.

Are there any known bugs related to x722 and Microsoft VMSwitch or do you have any suggestion?

Tags (1)
0 Kudos
11 Replies
idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

Thank you for posting in Wired Communities. I can see you are using PROSet 23.1 from our website, as this is an onboard NIC on Supermicro* system (based on the motherboard), have you tried obtain the customized driver from Supermicro? It is recommended to use driver from the board vendor for the embedded NIC. Please double check with them about this concern as well and feel free to update me. Thank you.

 

 

Regards,

 

Sharon T
idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

Please feel free to update me if you have contacted the board vendor and if other assistance needed.

 

 

Thanks,

 

Sharon T
MLeis3
Beginner
213 Views

Hi Sharon,

yes, I contacted the vendor (Supermicro) and we were investigating the issue, but it was not solved.

They don't have any customized driver and are suggesting latest Intel driver available or to contact Intel to solve the issue.

Any other suggestions?

Best Regards,

Malwina Leis

idata
Community Manager
213 Views

Hi Wi2dzma,

Thank you for the update. Let me further check for you and do you have the service ticket number from Supermicro*? Please feel free to update me. Thanks.

Regards,

 

Sharon T
idata
Community Manager
213 Views

Hi Wi2dzma,

 

 

The duplicate packets could be due to a teaming policy enforced or possible due to multiple interface's on the same VM due to redundancy. Can you try disabling promiscuous mode with one of the interface's to see if this could fix the issue.

 

 

Please try do a trace on the VMswitch using the following command:

 

 

 

netsh trace start provider=Microsoft-Windows-Hyper-V-VMSwitch capture=yes

 

 

 

 

netsh trace convert input=c:\dropped_packets.etl output=dropped_packets.txt dump=txt

 

 

Please feel free to provide the output file.

 

 

Thanks,

 

Sharon T

 

 

 

MLeis3
Beginner
213 Views

Hi Sharon,

how can I disable "Promiscous Mode" on network adapter? Do you know what registry setting or Powershell command can do that?

VMSwitch is configured with 2 X722 network cards using SET (Switch Embeded Teaming) and Hyper-V host has one virtual network adapter configured(standard way for Hyper-V). For now there are no VMs on that hosts.

When we debugged with Wireshark indeed we seen that each card is sending the reply.

Best Regards,

Malwina

idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

Please try use below command to check the promiscuous mode on your adapter:

 

 

Get-NetAdapter | Format-List -Property PromiscuousMode

 

 

Thanks,

 

Sharon T
MLeis3
Beginner
213 Views

Hi Sharon,

Get-NetAdapter shows PromiscousMode set to True for both cards, but I was asking about cmdlet to turn it on/off.

idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

Thank you for the update.The command tells us the Promiscuous mode is enabled. Let me further check for you.

 

 

Regards,

 

Sharon T

 

 

idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

You may try below command to disable promiscuous mode on an interface:

 

 

user@host# delete interfaces interface-name promiscuous-mode

 

 

Let me know if this works for you.

 

 

Thanks,

 

Sharon T
idata
Community Manager
213 Views

Hi Wi3dzma,

 

 

Please feel free to provide updates. Thanks.

 

 

Regards,

 

Sharon T
Reply