Ethernet Products
Intel® Ethernet products and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3970 Discussions

Intel 82579LM Gigabit Network is really slow

mhat
Beginner
6,095 Views

hi,

I have this lenovo M92P computer that has an embedded Intel 82579LM Gigabit Network adapter.

the OS is windows 2012 R2

When I run a internet speed test (speedtest.net), I get 300 mbps (both up and down)

my internet connection is 1 Gbps (both up and down)

300 is really too slow.

to further isolate the problem, I plugged a " Linksys USB Ethernet Adapter USB3GIG" in one of the M92P usb3 port. I get 900+ mbps (both up and down)

so it seems that the problem is with this 82579LM chip.

What can I do to get the speed it's supposed to deliver?

I already tried to turn off any energy saving settings but that didn't help.

thanks for you suggestions

0 Kudos
3 Replies
st4
New Contributor III
4,183 Views

Hi Caj,

Thank you for the post. Please make sure you are using the latest drive

 

for the NIC, it is recommended to contact the system vendor for the latest driver.

You may also refer to below link on the advance property setting,

 

try make adjustment if this will improve the link speed

 

http://www.intel.com/support/network/sb/CS-025841.htm http://www.intel.com/support/network/sb/CS-025841.htm

rgds,

 

wb
RandomPerson
Beginner
3,137 Views

I've solved this problem. Mine was defaulting to 10/10 when this setting was on auto. I made this one setting change, and my network speed is normal. (1 GB).intelslow.JPG

andrejsferreira
Beginner
286 Views

Could i open after all this year this post to question what's the solution for slow LAN speeds in this hardware?

 

I have one HP compaq with this ethernet hardware, last driver installer for windows 10 pro, and when i do a speedtest i have 1GB of internet connection.

When i try to download a file from a NAS server, the speed it's only about 11/13MB at maximum.  My other computer download the same file at 100MB.

Can anyone help me? I think this is a problem with network adapter and not from the HP.

 

Best regards;

Andrejsferreira

Reply